Community discussions

MikroTik App
 
Scruffyedc
just joined
Topic Author
Posts: 3
Joined: Mon Apr 13, 2020 7:48 am

set a VPN for a client - Microtik in bridge mode

Tue Aug 11, 2020 4:12 am

Hello,

I have one mikrotik in bridged mode, using only eth1 and eth2.

I am trying to set vpn for a computer which needs all traffic through the vpn.

I probably made a mistake, because no traffic at all is going through.

also I am trying to use the mode button to start the vpn and routing.

thanks for help :)

# aug/11/2020 11:08:59 by RouterOS 6.46.5

/interface bridge
add admin-mac=74:4D:28:A6:1D:4D auto-mac=no comment=defconf name=bridgeLocal
/interface pptp-client
add add-default-route=yes connect-to=********** disabled=no name=\
"CZ Mikrotik" password=************** user=******
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/interface bridge port
add bridge=bridgeLocal comment=defconf interface=ether1
add bridge=bridgeLocal comment=defconf interface=ether2
add bridge=bridgeLocal comment=defconf interface=ether3
add bridge=bridgeLocal comment=defconf interface=ether4
add bridge=bridgeLocal comment=defconf interface=ether5
/ip firewall connection tracking
set enabled=yes
/interface detect-internet
set detect-interface-list=all
/interface list member
add interface=ether1 list=WAN
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
add interface=ether5 list=LAN
/ip dhcp-client
add comment=defconf disabled=no interface=bridgeLocal use-peer-dns=no
/ip dns
set allow-remote-requests=yes servers=8.8.4.4,8.8.8.8
/ip firewall mangle
add action=mark-routing chain=prerouting new-routing-mark=VPN_CZ passthrough=\
yes src-address=192.168.1.155
/ip firewall nat
add action=masquerade chain=srcnat out-interface="CZ Mikrotik"
/ip route
add distance=1 gateway="CZ Mikrotik" routing-mark=VPN_CZ
/ip traffic-flow
set enabled=yes
/system clock
set time-zone-name=Australia/Sydney
/system routerboard settings
# Firmware upgraded successfully, please reboot for changes to take effect!
set auto-upgrade=yes
/system routerboard mode-button
set enabled=yes on-event=vpn
/tool graphing interface
add interface=ether1
/tool traffic-monitor
add interface=ether1 name=tmon1 threshold=0 traffic=received trigger=always
add interface="CZ Mikrotik" name=tmon2 threshold=0 traffic=received

Who is online

Users browsing this forum: No registered users and 11 guests