Community discussions

MikroTik App
 
albe77laser
just joined
Topic Author
Posts: 2
Joined: Mon Oct 19, 2020 6:09 pm

Problems with ID routers in OSPF Instance

Mon Oct 19, 2020 6:14 pm

Hi,
i'm changing to OSPF router ID instance in my routers.

I see that some old router ID still presents in the TAB "AS Border Routers". And the Cost for these instance are very high.

Is this normal? I tried to reloaded some of these routers but the problem persist.

Someone can help me.

Thanks.
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1313
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: Problems with ID routers in OSPF Instance

Tue Oct 20, 2020 3:50 pm

Please post the output of the following commands

/routing ospf export

/routing ospf neighbor print detail

/routing ospf as-border-router print detail
Global - MikroTik Support & Consulting - English | Español | Serbian | Danish +1 855-645-7684
https://iparchitechs.com/ecosystem/mikr ... consulting mikrotiksupport@iparchitechs.com
 
albe77laser
just joined
Topic Author
Posts: 2
Joined: Mon Oct 19, 2020 6:09 pm

Re: Problems with ID routers in OSPF Instance

Wed Oct 21, 2020 3:35 pm

Hi, i post the output you asked:

-----
routing ospf export
# oct/21/2020 14:19:54 by RouterOS 6.47.2
# software id = GGNF-8DCL
#
# model = RB750Gr3
# serial number = 8AFF0BBAA99C

/routing ospf area
add area-id=0.0.0.57 name=area8
/routing ospf instance
set [ find default=yes ] redistribute-connected=as-type-1 router-id=10.63.243.5

/routing ospf interface
add authentication=md5 authentication-key=***** interface=\
ether1 network-type=point-to-point
add interface=bridge_mngt network-type=broadcast passive=yes
add interface=ether2 network-type=broadcast passive=yes
add interface=ether3 network-type=broadcast passive=yes

/routing ospf network
add area=area8 network=10.63.0.216/30
add area=area8 network=10.59.10.0/24
add area=area8 network=10.59.11.0/24
add area=area8 network=10.63.243.5/32

[ADM@R] > routing ospf neighbor print detail
0 instance=default router-id=10.63.243.4 address=10.63.0.217
interface=ether1 priority=1 dr-address=0.0.0.0
backup-dr-address=0.0.0.0 state="Full" state-changes=5 ls-retransmits=0
ls-requests=0 db-summaries=0 adjacency=5d21h8m29s

[ADM@R] > routing ospf as-border-router print detail
0 instance=default routerid=0.0.0.11 state=inter-area gateway=10.63.0.217 interface=ether1 cost=4830

1 instance=default routerid=0.0.0.13 state=inter-area gateway=10.63.0.217 interface=ether1 cost=6010

2 instance=default routerid=0.0.0.16 state=inter-area gateway=10.63.0.217 interface=ether1 cost=5810

3 instance=default routerid=0.0.0.26 state=inter-area gateway=10.63.0.217 interface=ether1 cost=5810

4 instance=default routerid=0.0.0.40 state=inter-area gateway=10.63.0.217 interface=ether1 cost=11380

5 instance=default routerid=0.0.0.44 state=inter-area gateway=10.63.0.217 interface=ether1 cost=5870

6 instance=default routerid=0.0.0.47 state=inter-area gateway=10.63.0.217 interface=ether1 cost=11360

7 instance=default routerid=0.0.0.51 state=inter-area gateway=10.63.0.217 interface=ether1 cost=11300

8 instance=default routerid=0.0.0.57 state=inter-area gateway=10.63.0.217 interface=ether1 cost=4840

9 instance=default routerid=0.0.0.60 state=inter-area gateway=10.63.0.217 interface=ether1 cost=9600

10 instance=default routerid=0.0.0.63 state=inter-area gateway=10.63.0.217 interface=ether1 cost=5780

11 instance=default routerid=0.0.0.71 state=inter-area gateway=10.63.0.217 interface=ether1 cost=39260

12 instance=default routerid=0.0.0.74 state=inter-area gateway=10.63.0.217 interface=ether1 cost=5890

13 instance=default routerid=0.0.0.80 state=inter-area gateway=10.63.0.217 interface=ether1 cost=5760

14 instance=default routerid=0.0.0.81 state=inter-area gateway=10.63.0.217 interface=ether1 cost=5750

15 instance=default routerid=0.0.0.88 state=inter-area gateway=10.63.0.217 interface=ether1 cost=4940

16 instance=default routerid=0.0.0.89 state=inter-area gateway=10.63.0.217 interface=ether1 cost=4580

17 instance=default routerid=0.0.0.90 state=inter-area gateway=10.63.0.217 interface=ether1 cost=5040

18 instance=default routerid=0.0.0.94 state=inter-area gateway=10.63.0.217 interface=ether1 cost=4875

19 instance=default routerid=0.0.0.99 state=inter-area gateway=10.63.0.217 interface=ether1 cost=4800

20 instance=default routerid=0.0.0.102 state=inter-area gateway=10.63.0.217 interface=ether1 cost=2150

21 instance=default routerid=0.0.0.110 state=inter-area gateway=10.63.0.217 interface=ether1 cost=1760

22 instance=default routerid=0.0.0.113 state=inter-area gateway=10.63.0.217 interface=ether1 cost=120

23 instance=default routerid=0.0.0.116 state=inter-area gateway=10.63.0.217 interface=ether1 cost=4070

24 instance=default routerid=0.0.0.117 state=inter-area gateway=10.63.0.217 interface=ether1 cost=27640

25 instance=default routerid=0.0.0.122 state=inter-area gateway=10.63.0.217 interface=ether1 cost=237730

26 instance=default routerid=0.0.0.127 state=inter-area gateway=10.63.0.217 interface=ether1 cost=5890

27 instance=default routerid=0.0.0.128 state=inter-area gateway=10.63.0.217 interface=ether1 cost=5880

28 instance=default routerid=0.0.0.141 state=inter-area gateway=10.63.0.217 interface=ether1 cost=5920

29 instance=default routerid=0.0.0.143 state=inter-area gateway=10.63.0.217 interface=ether1 cost=4420

30 instance=default routerid=0.0.0.152 state=inter-area gateway=10.63.0.217 interface=ether1 cost=6000

31 instance=default routerid=0.0.0.155 state=inter-area gateway=10.63.0.217 interface=ether1 cost=2950

32 instance=default routerid=0.0.0.162 state=inter-area gateway=10.63.0.217 interface=ether1 cost=5890

33 instance=default routerid=0.0.0.170 state=inter-area gateway=10.63.0.217 interface=ether1 cost=74120

34 instance=default routerid=0.0.0.176 state=inter-area gateway=10.63.0.217 interface=ether1 cost=11850

35 instance=default routerid=0.0.0.201 state=inter-area gateway=10.63.0.217 interface=ether1 cost=5050

36 instance=default routerid=10.56.0.1 state=inter-area gateway=10.63.0.217 interface=ether1 cost=100

37 instance=default routerid=10.63.240.1 state=inter-area gateway=10.63.0.217 interface=ether1 cost=80

38 instance=default routerid=10.63.240.2 state=inter-area gateway=10.63.0.217 interface=ether1 cost=90

39 instance=default routerid=10.63.240.4 state=inter-area gateway=10.63.0.217 interface=ether1 cost=70

40 instance=default routerid=10.63.240.5 state=inter-area gateway=10.63.0.217 interface=ether1 cost=80

41 instance=default routerid=10.63.240.8 state=inter-area gateway=10.63.0.217 interface=ether1 cost=80

42 instance=default routerid=10.63.240.10 state=inter-area gateway=10.63.0.217 interface=ether1 cost=60

43 instance=default routerid=10.63.240.14 state=inter-area gateway=10.63.0.217 interface=ether1 cost=80

44 instance=default routerid=10.63.240.16 state=inter-area gateway=10.63.0.217 interface=ether1 cost=80

45 instance=default routerid=10.63.240.17 state=inter-area gateway=10.63.0.217 interface=ether1 cost=90

46 instance=default routerid=10.63.240.18 state=inter-area gateway=10.63.0.217 interface=ether1 cost=100

47 instance=default routerid=10.63.240.24 state=inter-area gateway=10.63.0.217 interface=ether1 cost=60

48 instance=default routerid=10.63.240.25 state=inter-area gateway=10.63.0.217 interface=ether1 cost=70

49 instance=default routerid=10.63.240.34 state=inter-area gateway=10.63.0.217 interface=ether1 cost=190

50 instance=default routerid=10.63.240.35 state=inter-area gateway=10.63.0.217 interface=ether1 cost=200

51 instance=default routerid=10.63.240.38 state=inter-area gateway=10.63.0.217 interface=ether1 cost=2020

52 instance=default routerid=10.63.240.40 state=inter-area gateway=10.63.0.217 interface=ether1 cost=110

53 instance=default routerid=10.63.240.41 state=inter-area gateway=10.63.0.217 interface=ether1 cost=120

54 instance=default routerid=10.63.241.1 state=inter-area gateway=10.63.0.217 interface=ether1 cost=130

55 instance=default routerid=10.63.241.4 state=inter-area gateway=10.63.0.217 interface=ether1 cost=110

56 instance=default routerid=10.63.241.5 state=inter-area gateway=10.63.0.217 interface=ether1 cost=90

57 instance=default routerid=10.63.241.7 state=inter-area gateway=10.63.0.217 interface=ether1 cost=100

58 instance=default routerid=10.63.241.13 state=inter-area gateway=10.63.0.217 interface=ether1 cost=110

59 instance=default routerid=10.63.241.14 state=inter-area gateway=10.63.0.217 interface=ether1 cost=110

60 instance=default routerid=10.63.241.16 state=inter-area gateway=10.63.0.217 interface=ether1 cost=110

61 instance=default routerid=10.63.241.18 state=inter-area gateway=10.63.0.217 interface=ether1 cost=160

62 instance=default routerid=10.63.241.19 state=inter-area gateway=10.63.0.217 interface=ether1 cost=100

63 instance=default routerid=10.63.241.20 state=inter-area gateway=10.63.0.217 interface=ether1 cost=2240

64 instance=default routerid=10.63.241.25 state=inter-area gateway=10.63.0.217 interface=ether1 cost=120

65 instance=default routerid=10.63.241.28 state=inter-area gateway=10.63.0.217 interface=ether1 cost=2230

66 instance=default routerid=10.63.241.29 state=inter-area gateway=10.63.0.217 interface=ether1 cost=140

67 instance=default routerid=10.63.241.36 state=inter-area gateway=10.63.0.217 interface=ether1 cost=100

68 instance=default routerid=10.63.241.38 state=inter-area gateway=10.63.0.217 interface=ether1 cost=150

69 instance=default routerid=10.63.241.39 state=inter-area gateway=10.63.0.217 interface=ether1 cost=160

70 instance=default routerid=10.63.242.1 state=inter-area gateway=10.63.0.217 interface=ether1 cost=180

71 instance=default routerid=10.63.242.3 state=inter-area gateway=10.63.0.217 interface=ether1 cost=160

72 instance=default routerid=10.63.242.4 state=inter-area gateway=10.63.0.217 interface=ether1 cost=180

73 instance=default routerid=10.63.242.7 state=inter-area gateway=10.63.0.217 interface=ether1 cost=150

74 instance=default routerid=10.63.242.13 state=inter-area gateway=10.63.0.217 interface=ether1 cost=140

75 instance=default routerid=10.63.242.14 state=inter-area gateway=10.63.0.217 interface=ether1 cost=150

76 instance=default routerid=10.63.242.17 state=inter-area gateway=10.63.0.217 interface=ether1 cost=150

77 instance=default routerid=10.63.242.18 state=inter-area gateway=10.63.0.217 interface=ether1 cost=160

78 instance=default routerid=10.63.242.22 state=inter-area gateway=10.63.0.217 interface=ether1 cost=160

79 instance=default routerid=10.63.242.23 state=inter-area gateway=10.63.0.217 interface=ether1 cost=170

80 instance=default routerid=10.63.242.25 state=inter-area gateway=10.63.0.217 interface=ether1 cost=190

81 instance=default routerid=10.63.243.1 state=inter-area gateway=10.63.0.217 interface=ether1 cost=50

82 instance=default routerid=10.63.243.2 state=inter-area gateway=10.63.0.217 interface=ether1 cost=50

83 instance=default routerid=10.63.243.3 state=intra-area gateway=10.63.0.217 interface=ether1 cost=40

84 instance=default routerid=10.63.243.4 state=intra-area gateway=10.63.0.217 interface=ether1 cost=10

85 instance=default routerid=10.63.243.7 state=inter-area gateway=10.63.0.217 interface=ether1 cost=1810

86 instance=default routerid=10.63.243.8 state=inter-area gateway=10.63.0.217 interface=ether1 cost=90

87 instance=default routerid=10.63.243.9 state=inter-area gateway=10.63.0.217 interface=ether1 cost=100

88 instance=default routerid=10.63.243.12 state=inter-area gateway=10.63.0.217 interface=ether1 cost=3680

89 instance=default routerid=10.63.243.13 state=intra-area gateway=10.63.0.217 interface=ether1 cost=100

90 instance=default routerid=10.63.243.16 state=intra-area gateway=10.63.0.217 interface=ether1 cost=120

91 instance=default routerid=10.63.243.18 state=inter-area gateway=10.63.0.217 interface=ether1 cost=3010

92 instance=default routerid=10.63.243.19 state=intra-area gateway=10.63.0.217 interface=ether1 cost=90

93 instance=default routerid=10.63.243.23 state=inter-area gateway=10.63.0.217 interface=ether1 cost=40

94 instance=default routerid=10.63.243.24 state=inter-area gateway=10.63.0.217 interface=ether1 cost=160

95 instance=default routerid=10.63.243.26 state=inter-area gateway=10.63.0.217 interface=ether1 cost=2640

96 instance=default routerid=10.63.244.1 state=inter-area gateway=10.63.0.217 interface=ether1 cost=180

97 instance=default routerid=10.63.244.3 state=inter-area gateway=10.63.0.217 interface=ether1 cost=160

98 instance=default routerid=10.63.244.5 state=inter-area gateway=10.63.0.217 interface=ether1 cost=160

99 instance=default routerid=10.63.244.7 state=inter-area gateway=10.63.0.217 interface=ether1 cost=170

100 instance=default routerid=10.63.244.12 state=inter-area gateway=10.63.0.217 interface=ether1 cost=130

101 instance=default routerid=10.63.244.16 state=inter-area gateway=10.63.0.217 interface=ether1 cost=170

102 instance=default routerid=10.63.244.17 state=inter-area gateway=10.63.0.217 interface=ether1 cost=170

103 instance=default routerid=10.63.245.1 state=inter-area gateway=10.63.0.217 interface=ether1 cost=120

104 instance=default routerid=10.63.245.3 state=inter-area gateway=10.63.0.217 interface=ether1 cost=100

105 instance=default routerid=10.63.245.4 state=inter-area gateway=10.63.0.217 interface=ether1 cost=110

106 instance=default routerid=10.63.245.5 state=inter-area gateway=10.63.0.217 interface=ether1 cost=130

107 instance=default routerid=10.63.245.6 state=inter-area gateway=10.63.0.217 interface=ether1 cost=140

108 instance=default routerid=10.63.245.7 state=inter-area gateway=10.63.0.217 interface=ether1 cost=4280

109 instance=default routerid=10.63.245.9 state=inter-area gateway=10.63.0.217 interface=ether1 cost=110

110 instance=default routerid=10.63.245.12 state=inter-area gateway=10.63.0.217 interface=ether1 cost=120

111 instance=default routerid=10.63.245.15 state=inter-area gateway=10.63.0.217 interface=ether1 cost=110

112 instance=default routerid=10.63.245.16 state=inter-area gateway=10.63.0.217 interface=ether1 cost=120

113 instance=default routerid=10.63.246.1 state=intra-area gateway=10.63.0.217 interface=ether1 cost=130

114 instance=default routerid=10.63.246.3 state=intra-area gateway=10.63.0.217 interface=ether1 cost=110

115 instance=default routerid=10.63.246.10 state=intra-area gateway=10.63.0.217 interface=ether1 cost=120

116 instance=default routerid=10.63.248.1 state=inter-area gateway=10.63.0.217 interface=ether1 cost=140

117 instance=default routerid=10.63.248.2 state=inter-area gateway=10.63.0.217 interface=ether1 cost=150

118 instance=default routerid=10.63.248.3 state=inter-area gateway=10.63.0.217 interface=ether1 cost=160

119 instance=default routerid=10.63.250.1 state=inter-area gateway=10.63.0.217 interface=ether1 cost=140
-------

As you can see, there are some cost very high, and the routerid of that routers are non more active. For exemple, the first one:

"0 instance=default routerid=0.0.0.11 state=inter-area gateway=10.63.0.217 interface=ether1 cost=4830"

has the new router ID 10.63.244.7:

"99 instance=default routerid=10.63.244.7 state=inter-area gateway=10.63.0.217 interface=ether1 cost=170 "

Thank you for your help.

Who is online

Users browsing this forum: No registered users and 17 guests