Community discussions

MikroTik App
just joined
Topic Author
Posts: 6
Joined: Tue Nov 03, 2020 9:12 pm

Trying to route multicast

Fri Nov 13, 2020 6:32 pm


I have a UPnP media server on my workstation and I occasionally stream media to my DNLA capable Smart-TV. I used to have a flat network with one subnet and everything worked but as soon as I split the network I can't stream media to my Smart-TV anymore. My workstation is connected to a CRS305-1G-4S+IN which is connected to an ASUS RT-AC68U running DD-WRT. The Smart-TV is connected to the Asus router. I am 99% sure that the problem is that DLNA is multicast over and uses SSDP. I managed to install the RouterOS multicast package and I was hoping to get everything working with IGMP Proxy - but something is still broken. I am not sure if the problem is at CRS side or Asus side.

To make things even more complicated all non-local traffic from the Smart-TV is routed to a OpenVPN tunnel between the Asus router and a VPN provider For that I have a special ip rule and alternative routing table. The br0 device in the Asus router (the physical port to which the Smart-TV connects is add to this bridge) has IGMP snooping on.

I tried playing with the IGMP-Proxy but I have no idea which interface should be marked upstream and even if IGMP proxy could help me in this scenario. Do I have to configure anything on the Asus router also?

I am attaching my home network schematic. The Smart-TV is and my workstation is
You do not have the required permissions to view the files attached to this post.
just joined
Posts: 18
Joined: Sun May 21, 2017 1:55 pm

Re: Trying to route multicast

Sat Nov 21, 2020 10:51 am

What you probably need is an mDNS reflector.

Open-WRT supports this, not sure if DD-WRT does also.

More on mDNS:

Who is online

Users browsing this forum: No registered users and 7 guests