Community discussions

MikroTik App
 
sryan2k1
just joined
Topic Author
Posts: 1
Joined: Wed Nov 18, 2020 6:41 am

BGP + VRFs - Issues

Wed Nov 18, 2020 6:42 am

So I'm coming over to Mikrotik from a heavy Cisco/Arista/Juniper background and am having some issues around BGP and VRFs.

I've got a pair of CCR2004's in the lab that are going to be BGP Edge routers, however I really do not want to have the management services in the same VRF as production traffic so I've been going down that rabbit hole. In doing my research it's difficult to impossible for a lot of the mgmt stuff in the non-default VRF so in my testing I've got the default, and a new one marked "internet".


The lab setup is simple, ethernet1 on both units is plugged into 192.168.1.x/24 with a 0.0.0.0/0 route pointed at .1, this works lovely for management.


They also have a 25G link between them on sfp28-2, with each side being in 10.10.10.0/30, and sfp28-2 in the "internet" VRF.


All straight forward so far right?


If I set up eBGP by setting the "routing table" property to "internet" the session comes up, however it will not redistribute connected or static routes. I'm guessing because that even though BGP is using the right VRF the VRF aware parts are not.


However, if I leave the routing table blank, and instead create a new BGP VRF with the right routing mark I can't get the peers to ever come up (perpetually Active). I've tried all combo's of "address family" on the peer itself (checking vpn4, unchecking ip, etc). I even added a /32 route rule pointing the other side of the link to "Lookup" and the right VRF.


What am I missing here? All I want at the end of the day is a pair of ports in the "internet" VRF to do BGP and pass along connected and static routes inside that VRF as well.


Thanks in advance!

Who is online

Users browsing this forum: Google [Bot] and 22 guests