Community discussions

MikroTik App
 
digitec
just joined
Topic Author
Posts: 19
Joined: Wed Jan 31, 2018 3:13 pm

RIPv2 MD5 to Quagga

Fri Dec 25, 2020 10:35 am

I have been trying transcript Mikrotik configuration to quagga.conf but I'm lost with prefix-lists and the mask because manual says prefix-length=0-32 but in this configuration
is prefix-length=0-128 i.e. ipv6? and in-prefix-list=in01 and out-prefix-list=out01 I have no idea how to transcript that. Quagga RIP MD5 does not work now. I'm confused with validity of the MD5 key that is not mentioned in quagga too. Any help?

/routing prefix-lists
add chain=out01 prefix=10.11.241.184/29
add action=discard chain=out01 prefix-length=0-128
add action=discard chain=in01 prefix-length=0-128
/routing rip
set redistribute-connected=yes
/routing rip interface
add authentication=md5 authentication-key=SECRET in-prefix-list=in01 interface=ether1 key-chain=key out-prefix-list=out01 receive=v2
/routing rip keys
add chain=key from-date=dec/24/2020 key=SECRET key-id=1 to-date=forever
/routing rip network
add network=10.250.0.160/29
/ip route
add distance=1 gateway=192.168.66.1


!
! Zebra configuration saved from vty
! 2020/12/25 08:58:45
!
hostname pc
password zebra
log file /var/log/quagga/ripd.log
!
debug rip events
debug rip packet
!
key chain RIP-MD5
key 1
key-string SECRET
!
interface eth0
ip rip authentication mode md5 auth-length old-ripd
ip rip authentication key-chain RIP-MD5
!
router rip
network 10.250.0.160/29
network eth0
distribute-list private-only in eth0
distribute-list prefix 10.11.241.184/29 out eth1
route 192.168.66.0/24
!
access-list private-only permit 192.168.66.0/24
access-list private-only deny any
!
line vty
!

Who is online

Users browsing this forum: ScottReed and 25 guests