Community discussions

MikroTik App
 
terafirma
just joined
Topic Author
Posts: 8
Joined: Fri Aug 23, 2019 9:49 am

BGP VPLS with Cisco

Tue Jan 12, 2021 11:24 pm

Hi,

Wondering if anyone has any info on configuring VPLS with Cisco but not using the Cisco style VPLS feature, material I can find on this all seems to be either old pre-dating Cisco adding BGP signaling or using old hardware with IOS. I ask as Cisco do support BGP or LDP discovery and signaling on some models. e.g. ASR1000 series see: https://www.cisco.com/c/en/us/td/docs/i ... 9765E1EDA2
Enables BGP signaling and discovery or LDP signaling and enters L2VPN VFI autodiscovery configuration mode.
Note
For the VPLS BGP Signaling feature use the autodiscovery bgp signaling bgp command.
Has anyone done this or has it not been tested? I have an ASR I am about to setup with a CCR to test this but wanted to see if anyone else has. If we introduce some Cisco hardware I would prefer not to have to re-do all our VPLS setup in our network.
 
terafirma
just joined
Topic Author
Posts: 8
Joined: Fri Aug 23, 2019 9:49 am

Re: BGP VPLS with Cisco

Mon Jan 18, 2021 4:53 am

as an update:

I have built a lab in CML2 using the Cisco CSR1000 as it runs the same IOS-XE as the ASR routers.

I have VPLS working using BGP advertisements and BGP signaling I am now going through more extensive testing to check traffic etc.

to get it working on the cisco side all I had to do was:

Cisco enable LDP
mpls label protocol ldp
mpls ldp advertise-labels interface GigabitEthernet2
!
...
interface GigabitEthernet2
 mtu 1600 
 ip address 192.168.0.1 255.255.255.252
 mpls ip  
 mpls label protocol ldp
Cisco side VPLS
l2vpn vfi context customer
 vpn id 100                            <--- give the connection an ID
 autodiscovery bgp signaling bgp       <--- enable BGP discovery and signaling (not LDP signaling or Cisco style VPLS)
  ve id 1                              <--- set the site ID this one is 1 while the MT was set to 3
  rd 1:50                              <--- set the route distinguisher if not defaults to <BGP AS>:<VPN ID> so 65530:100
  route-target export 1:50             <--- set your import and export targets
  route-target import 1:50
  control-word include                 <--- include control word if set MT side (is by default)
BGP peering to a route reflector
note the address-family and the suppression of the LDP signaling (not sure the LDP suppression is required but added as per best practice)
router bgp 65530
 bgp router-id 10.255.254.1
 bgp log-neighbor-changes
 neighbor 10.255.254.4 remote-as 65530
 neighbor 10.255.254.4 update-source Loopback0
 !
 address-family ipv4
  no neighbor 10.255.254.4 activate     <--- doing IP routing via OSPF so not required in BGP
 exit-address-family
 !
 address-family l2vpn vpls
  neighbor 10.255.254.4 activate
  neighbor 10.255.254.4 send-community extended
  neighbor 10.255.254.4 suppress-signaling-protocol ldp     <--- suppress LDP signaling
 exit-address-family
Cisco setup a VRF for customer traffic and add interfaces etc.,
create a bridge-domain add the VPLS to it and add it to the VRF. Add local edge ports to the VRF for upstream routing
ip vrf customer
!
bridge-domain 100 
 member BD-VIF 100
 member vfi customer
!
interface BD-VIF100
 ip vrf forwarding customer
 ip address 172.16.0.1 255.255.255.0
!
interface GigabitEthernet4
 ip vrf forwarding customer
 ip address 172.16.1.1 255.255.255.0
 
On the MT side it was basically enable MPLS/OSPF/BGP/BGP VPLS as per defaults/wiki example.

Who is online

Users browsing this forum: AdrianT88 and 8 guests