Community discussions

MikroTik App
 
keryax
just joined
Topic Author
Posts: 5
Joined: Tue Jul 03, 2018 3:34 pm

OSPF redistributed route disappearing

Fri Jan 29, 2021 10:25 am

network.PNG
Hello. I've configured redistribution of static route (172.16.203.0/25) on router R1 to OSPF.
Then i see that this route is disappearing every 5-10 sec. on router R0.
[admin@R0] /routing ospf route> print where interface=sstp2
 # DST-ADDRESS        STATE          COST                     GATEWAY         INTERFACE
 0 172.16.0.3/32      intra-area     20                       172.16.100.29   sstp2
 1 172.16.100.28/32   intra-area     20                       172.16.100.29   sstp2
 2 172.16.100.29/32   intra-area     10                       0.0.0.0         sstp2
 3 172.16.203.0/25    ext-1          40                       172.16.100.29   sstp2         <<<< ONLY This route is disappearing
 4 172.16.203.128/25  intra-area     20                       172.16.100.29   sstp2

Some config from R1

[admin@R1] /routing ospf> export
/routing ospf area
add area-id=172.16.0.3 name=ocvn

/routing ospf instance
set [ find default=yes ] redistribute-static=as-type-1 router-id=172.16.0.3

/routing ospf interface
add interface=sstp0 network-type=point-to-point

/routing ospf network
add area=ocvn network=172.16.100.28/31
add area=ocvn network=172.16.0.3/32
add area=ocvn network=172.16.203.0/24


[admin@R1] /routing filter> export
/routing filter
add action=accept chain=ospf-out disabled=yes prefix=172.16.0.0/12
add action=discard chain=ospf-out prefix=0.0.0.0/0

[admin@R1] /ip route> export
/ip route
add distance=1 gateway=172.16.203.200
add distance=1 dst-address=172.16.203.0/25 gateway=172.16.203.200


So, I see packet loss to the host 172.16.203.3

ping.PNG
Please tell me, what is wrong? How to fix it?
You do not have the required permissions to view the files attached to this post.
 
keryax
just joined
Topic Author
Posts: 5
Joined: Tue Jul 03, 2018 3:34 pm

Re: OSPF redistributed route disappearing

Sat Jan 30, 2021 6:46 pm

Hello. I've found the cause of my problem. There is another router with IP address 172.16.0.2 but incorrectly specified instance id 172.16.0.3. So there were two router with the same instance routerId

Who is online

Users browsing this forum: No registered users and 28 guests