Page 1 of 1

OSPF config to pair with OpenWRT

Posted: Sat Apr 10, 2021 3:13 pm
by orisis
Hi all,

I'd like to connct routerOS with openwrt..
My network already have ospfd running and redistributing network routing tables.
I tried to pair it with mikrotik router without success.
What do I need to do to match this config:
!
! OSPFD configuration
!
!
hostname NODE4
!
password xxxxx
enable password xxxxx
no banner motd
!
router ospf
	network 192.168.11.0/24 area 1
!
ospf router-id 192.168.11.1
!
redistribute connected
!
! Enable RFC-1583 compatibility to avoid routing loops
    compatible rfc1583 
!
line vty
!
!log file /var/log/quagga/ospfd.log
Thank you!

Re: OSPF config to pair with OpenWRT

Posted: Sun Apr 11, 2021 2:19 am
by IPANetEngineer
Assuming the router id for the other side is 192.168.11.2 , this should be all you need to match that config.
/routing ospf instance
set [ find default=yes ] router-id=192.168.11.2 redistribute-connected=as-type-1
/routing ospf network
add area=backbone network=192.168.11.0/24