Community discussions

MUM Europe 2020
 
User avatar
thesimj
just joined
Topic Author
Posts: 18
Joined: Thu Dec 11, 2008 9:24 pm
Location: Ukraine, Odessa
Contact:

VPLS (MK.3.20) and RB433 freezing router!

Fri Feb 27, 2009 1:33 am

Hello!

Today i am start to testing RB433AH and enabled package mpls.
Configure ospf, mplsm and start to add vpls interface, but when i press button "ok" in winbox, nothing change.
But the my router is freezing, i reboot router (by power off/on), and start to add vpls interface in console, same situation.

I got another router x86 Alix 3c1 and do the same (MK.3.20).. results : equal. router is freezing, and only power off will helps.

strange problem, anybody test VPLS on MK.3.20


P.S. Hello to MUM, from Odessa :). Bad that i am not drive to MUM. Maybe next year.
Τι μάτια βλ., μυαλά πιστεύουν
bel.net.ua
 
uldis
MikroTik Support
MikroTik Support
Posts: 3427
Joined: Mon May 31, 2004 2:55 pm

Re: VPLS (MK.3.20) and RB433 freezing router!

Fri Feb 27, 2009 2:44 pm

Try mpls-test and routing-test package.It should work.
 
User avatar
thesimj
just joined
Topic Author
Posts: 18
Joined: Thu Dec 11, 2008 9:24 pm
Location: Ukraine, Odessa
Contact:

Re: VPLS (MK.3.20) and RB433 freezing router!

Mon Mar 02, 2009 10:07 pm

when i add VPLS interface in console show this error message

On version MK.3.17 all work fine :shock:, on ver. MK.3.18 and later hang with errors.
$ 4   : c79960d0 c700ba7c 00000000 c700ba78                                           
$ 8   : 000005dc c7865048 00000000 05d10000                                           
$12   : 00080014 c700be54 00000000 0000000e                                           
$16   : 00000000 00000000 c79960d0 c72cec00                                           
$20   : 00000005 c7865000 00000004 00000000                                           
$24   : 00000000 c7330a40                         
$28   : c700a000 c700ba68 00000040 c026cbf4                                           
Hi    : 00000000                
Lo    : 00000000                
epc   : c026cc58 rtnl_fill_ifinfo+0x1d8/0x4e0                                             
    Tainted: P              
ra    : c026cbf4 rtnl_fill_ifinfo+0x174/0x4e0                                             
Status: 1000f603    KERNEL EXL IE                                 
Cause : 00800008                
BadVA : 00000010
PrId  : 00019374 (MIPS 24K)
Process route (pid: 844, threadinfo=c700a000, task=c7862b70, tls=00000000)
Stack : 00000000 c01d1c60 c019ade0 c0168d20 000005dc c026d1f4 00000150 c7802cc0
        000000d0 c025852c c034c5b4 00000000 c7aa4a80 c72cee98 c72cec00 c79960d0
        00000010 ffffffff 00000005 0000000e 00000004 c026d21c c72cef44 c72cee30
        00000000 c72cee98 00000000 ffffffff 00000000 c02328f8 c034bfb0 fffffffe
        00000000 c72cec00 c026d338 0000000f c034c41c 00000000 c78951b8 c72cee30
        ...
Call Trace:
[<c026cc58>] rtnl_fill_ifinfo+0x1d8/0x4e0
[<c026d21c>] rtmsg_ifinfo+0x70/0x11c
[<c026d338>] rtnetlink_event+0x70/0x80
[<c014332c>] notifier_call_chain+0x48/0xa4
[<c0143448>] raw_notifier_call_chain+0x14/0x20
[<c02613a4>] register_netdevice+0x470/0x4d0
[<c7317b14>] mpls_pw_add+0x34c/0xe6c [mpls]
[<c73150a4>] mpls_nl_init+0x25c/0xef8 [mpls]


Code: 044000b5  00000000  8e700180 <8e020010> 1040000d  00000000  8c440010  0c08
20ff  24840008
---[ end trace d54575d606cfd1f6 ]---
Τι μάτια βλ., μυαλά πιστεύουν
bel.net.ua
 
User avatar
thesimj
just joined
Topic Author
Posts: 18
Joined: Thu Dec 11, 2008 9:24 pm
Location: Ukraine, Odessa
Contact:

Re: VPLS (MK.3.20) and RB433 freezing router!

Thu Mar 05, 2009 8:03 pm

anybody help here?
it's only my problem, or anybody have this problem with ROS 3.18+
Τι μάτια βλ., μυαλά πιστεύουν
bel.net.ua
 
Mplsguy
MikroTik Support
MikroTik Support
Posts: 226
Joined: Fri Jun 06, 2008 5:06 pm

Re: VPLS (MK.3.20) and RB433 freezing router!

Thu Mar 05, 2009 10:46 pm

anybody help here?
it's only my problem, or anybody have this problem with ROS 3.18+
This is known (old) problem. Make sure you use latest routing-test & mpls-test.
 
diegotormes
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Feb 15, 2006 11:45 pm

Re: VPLS (MK.3.20) and RB433 freezing router!

Fri Mar 27, 2009 2:35 am

anybody help here?
it's only my problem, or anybody have this problem with ROS 3.18+
This is known (old) problem. Make sure you use latest routing-test & mpls-test.
mmm, I'm not sure

I have the same issue, I downgrade to the version 3.17 and all is fine again

I made the downgrade through netinstall, the donwgrade via packages don't work

I use OSPF, MPLS and VPLS and the new versions don't work for me
 
User avatar
thesimj
just joined
Topic Author
Posts: 18
Joined: Thu Dec 11, 2008 9:24 pm
Location: Ukraine, Odessa
Contact:

Re: VPLS (MK.3.20) and RB433 freezing router!

Tue Mar 31, 2009 8:33 pm

anybody help here?
it's only my problem, or anybody have this problem with ROS 3.18+
This is known (old) problem. Make sure you use latest routing-test & mpls-test.
mmm, I'm not sure

I have the same issue, I downgrade to the version 3.17 and all is fine again

I made the downgrade through netinstall, the donwgrade via packages don't work

I use OSPF, MPLS and VPLS and the new versions don't work for me
How works MPLS & VPLS? stable?
Τι μάτια βλ., μυαλά πιστεύουν
bel.net.ua
 
itfutura
newbie
Posts: 32
Joined: Tue May 22, 2007 1:25 pm
Location: Poland
Contact:

Re: VPLS (MK.3.20) and RB433 freezing router!

Tue Mar 31, 2009 10:25 pm

seems to me work stable

Who is online

Users browsing this forum: No registered users and 8 guests