Community discussions

MikroTik App
 
jirkaehm
newbie
Topic Author
Posts: 30
Joined: Tue Jan 09, 2007 12:07 pm

OSPF Problem with redistributing connected routes

Mon Apr 20, 2009 1:57 pm

Hi,

I'm having some troubles with redistributing connected routes into a different area.

I have backbone area where this function work's correcly.

Then I have approx 20 router's in area2 randomly conected between them.
I want to redistribute connected routes into OSPF.

When I set them to As type 1, routes are in OSPF routes but without area. Also on next router in network's routes are'nt displayed.

I solved this by adding each directed IP address into networks and set interface to passive mode. But more clear solution would be to get working redistribute connected routes.

Does anyone have some ideas?


Second problem I have that some time on incoming wireless interface is ospf status down. If i disable and enable IP address on interface it start to work again. Anyone seen this problem?

thank you!
 
CarulloS
Member
Member
Posts: 406
Joined: Thu Feb 02, 2006 5:52 am

Re: OSPF Problem with redistributing connected routes

Tue Apr 21, 2009 4:55 am

Please provide ROS version...
 
jirkaehm
newbie
Topic Author
Posts: 30
Joined: Tue Jan 09, 2007 12:07 pm

Re: OSPF Problem with redistributing connected routes

Tue Apr 21, 2009 10:25 am

3.22
 
jirkaehm
newbie
Topic Author
Posts: 30
Joined: Tue Jan 09, 2007 12:07 pm

Re: OSPF Problem with redistributing connected routes

Wed Apr 22, 2009 1:18 am

I did some more testing today and find some troubles.

I'm using stub area at end of network. and this is probaly why connected routes does'nt import into ospf.

I did some more digging on internet and it looks like ospf don't support external routes in stub area.

Is there some way around this problem? I don't want to use normal areas, because I have to this day 1k routes in backbone and I don't want to distribute them to all of my network devices.

thanks for any help!
 
awsmith
newbie
Posts: 45
Joined: Wed May 31, 2006 8:18 am

Re: OSPF Problem with redistributing connected routes

Fri Apr 24, 2009 11:06 pm

I did some more testing today and find some troubles.

I'm using stub area at end of network. and this is probaly why connected routes does'nt import into ospf.

I did some more digging on internet and it looks like ospf don't support external routes in stub area.

Is there some way around this problem? I don't want to use normal areas, because I have to this day 1k routes in backbone and I don't want to distribute them to all of my network devices.

thanks for any help!
Use routing-test and change your stub area to a NSSA (not-so stubby area).
 
jirkaehm
newbie
Topic Author
Posts: 30
Joined: Tue Jan 09, 2007 12:07 pm

Re: OSPF Problem with redistributing connected routes

Fri Apr 24, 2009 11:40 pm

thank you for hint.

But is routing-test stable and ready for production enviroment?

I had some other interesting idea how to solve this problem, and I think this could work pretty well.

I will use severeal areas in my network.
for example I say that area 1.1.1.1 will have IP addresses from subnet 10.0.0.0/16
then I write filter for ospf-in in which I say that anything that is'nt from prefix 10.0.0.0/16 with prefix length 16-32 will be discarded.
of course I add rule to permit 0.0.0.0/0 destination.

I tested it and it seems to be working just fine, but isn't there something that I'm missing or anyone see something wrong in this setup?

thanks.

Who is online

Users browsing this forum: No registered users and 15 guests