Community discussions

 
-headstrong-
Member
Member
Topic Author
Posts: 377
Joined: Thu Jun 05, 2008 8:04 pm
Location: South Africa

OSPF or BGP for MPLS network for WISP

Sat Aug 01, 2009 1:39 pm

Hi Guys

I have been following the wiki's regarding MPLS setups and I have a question:

What is the more robust routing protocol to use to distribute LDP packets in an MPLS network? ie OSPF or BGP?

Reason i'm asking is because our current OSPF network has a few links which change between states too often...ie from "full to Down" and i'm scared that this will affect the performance of the MPLS network

Thanks
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8318
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: OSPF or BGP for MPLS network for WISP

Sun Aug 02, 2009 3:59 pm

what do you call 'too often'? anyway, the performance of MPLS network should not be affected
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
-headstrong-
Member
Member
Topic Author
Posts: 377
Joined: Thu Jun 05, 2008 8:04 pm
Location: South Africa

Re: OSPF or BGP for MPLS network for WISP

Mon Aug 03, 2009 11:49 pm

about 4 times a day...would the OSPF changing state not affect a RSVP-TE tunnel?
thanks
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8318
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: OSPF or BGP for MPLS network for WISP

Tue Aug 04, 2009 12:43 pm

MPLS works over current routing table, it do not depend on link state changes directly, so it's not affected by appearing/disappearing of one (not significant?) route
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
-headstrong-
Member
Member
Topic Author
Posts: 377
Joined: Thu Jun 05, 2008 8:04 pm
Location: South Africa

Re: OSPF or BGP for MPLS network for WISP

Tue Aug 04, 2009 6:25 pm

oh I see what you mean...if I had a mesh network for example then it would be irrelavent if a link went down...ok thanks

Next question, if I may :)

Lets say I have multiple highsites routed with MPLS but I have a single pppoe server near the internet breakout....All the clients would establish a pppoe session across the MPLS right? So now what would happen if a link went down? Would the pppoe sessions get dropped and then reconnected, assuming the primary LDP was over the link that went down? If yes, then how would one keep the pppoe session up during a re-route?

thanks
 
Mplsguy
MikroTik Support
MikroTik Support
Posts: 226
Joined: Fri Jun 06, 2008 5:06 pm

Re: OSPF or BGP for MPLS network for WISP

Fri Aug 07, 2009 4:33 pm

PPPoE sessions will not necessarily go down (provided that you do not add your PPPoE server and client interfaces directly to VPLS interfaces that will go down, but instead add PPPoE to bridge) - during "reroute" you will simply experience packet loss. It depends on your PPPoE config if that will terminate the session or not.
 
-headstrong-
Member
Member
Topic Author
Posts: 377
Joined: Thu Jun 05, 2008 8:04 pm
Location: South Africa

Re: OSPF or BGP for MPLS network for WISP

Sun Aug 09, 2009 6:52 pm

So if my VPLS is bridged to my AP ( on the interface that the stations connect to) and the stations dial the pppoe..In theory would the sessions stay up? granted there will be some packet loss
 
Mplsguy
MikroTik Support
MikroTik Support
Posts: 226
Joined: Fri Jun 06, 2008 5:06 pm

Re: OSPF or BGP for MPLS network for WISP

Sun Aug 09, 2009 11:07 pm

In general yes, as long as packet loss will not cause connections to get terminated, but that is only one part of the story - you also have to add PPPoE server on bridge interface and add VPLS interfaces ("the other ends" so to say) as ports to it, so that PPPoE server does not terminate connections because it looses interface it is added to.
 
-headstrong-
Member
Member
Topic Author
Posts: 377
Joined: Thu Jun 05, 2008 8:04 pm
Location: South Africa

Re: OSPF or BGP for MPLS network for WISP

Mon Aug 10, 2009 1:29 pm

ahh yes that makes sense...

I'm assuming that I should be using "split horizon" on all the VPLS ports that are added to the bridge? Otherwise each pppoe connection attempt would flood the network with broadcast packets...am I correct?
 
Mplsguy
MikroTik Support
MikroTik Support
Posts: 226
Joined: Fri Jun 06, 2008 5:06 pm

Re: OSPF or BGP for MPLS network for WISP

Mon Aug 10, 2009 9:20 pm

Yes, you are correct, in order to limit unnecessary broadcasting you should use either split horizon feature or bridge firewall.
 
-headstrong-
Member
Member
Topic Author
Posts: 377
Joined: Thu Jun 05, 2008 8:04 pm
Location: South Africa

Re: OSPF or BGP for MPLS network for WISP

Fri Aug 14, 2009 12:09 am

Hi MPLSGUY

Well I got my 1st lab setup up and running and all is going well...VPLS works like a charm, thanks

1 last question regarding vrf's:

Can I use OSPF to distribute the vrfs along the mpls cloud or must I use BGP? All the example's i've read use BGP but none use OSPF
 
Mplsguy
MikroTik Support
MikroTik Support
Posts: 226
Joined: Fri Jun 06, 2008 5:06 pm

Re: OSPF or BGP for MPLS network for WISP

Fri Aug 14, 2009 6:07 pm

If you mean distributing routes installed in VFRs between PE routers, then yes, you must use BGP.
 
-headstrong-
Member
Member
Topic Author
Posts: 377
Joined: Thu Jun 05, 2008 8:04 pm
Location: South Africa

Re: OSPF or BGP for MPLS network for WISP

Fri Aug 14, 2009 6:32 pm

thanks

I'm having difficulting getting BGP to work, OSPF for MPLS + VPLS worked fine

Can I use OSPF between the all the MPLS routers to distribute the LDP's and then BGP between just the PE routers for specific vrfs? or must I choose BGP or OSPF?

I hope i'm making sense
 
Mplsguy
MikroTik Support
MikroTik Support
Posts: 226
Joined: Fri Jun 06, 2008 5:06 pm

Re: OSPF or BGP for MPLS network for WISP

Fri Aug 14, 2009 9:51 pm

Can I use OSPF between the all the MPLS routers to distribute the LDP's and then BGP between just the PE routers for specific vrfs? or must I choose BGP or OSPF?
To clarify: you must use some IGP (RIP, OSPF or even static routing) to ensure end-to-end connectivity between PE routers. Then LDP distributes MPLS labels for existing routes. Note that OSPF (in case you use it) has nothing to do with MPLS - it simply distributes routes. MPLS switching along existing routes is ensured by LDP.

BGP is necessary to exchange routes in VRFs (so called VPNv4 routes) between PEs. BGP is required only between PEs.
 
-headstrong-
Member
Member
Topic Author
Posts: 377
Joined: Thu Jun 05, 2008 8:04 pm
Location: South Africa

Re: OSPF or BGP for MPLS network for WISP

Sat Aug 15, 2009 12:44 am

thanks, makes more sense now

Regarding the CE-PE link for vrf's...Should I use OSPF as the CE-PE routing protocol http://wiki.mikrotik.com/wiki/OSPF_as_P ... g_protocol

or something like this:

/ip route vrf add disabled=no routing-mark=cust-one route-distinguisher=1.1.1.1:111 \
export-route-targets=1.1.1.1:111 import-route-targets=1.1.1.1:111 interfaces=ether1
/routing bgp instance set default as=65000
/routing bgp instance vrf add instance=default routing-mark=cust-one redistribute-connected=yes
/routing bgp peer add remote-address=10.5.5.3 remote-as=65000 address-families=vpnv4 \
update-source=lobridge

Taken from here: http://wiki.mikrotik.com/wiki/Virtual_R ... Forwarding.

I want to use the more stable option
 
Mplsguy
MikroTik Support
MikroTik Support
Posts: 226
Joined: Fri Jun 06, 2008 5:06 pm

Re: OSPF or BGP for MPLS network for WISP

Sun Aug 16, 2009 10:08 pm

You can use OSPF or you can use static routing - depends on what are the requirements and your preferences. If your policy is to allow your customer to introduce new networks and distribute routes across your core to other sites of that customer, then I guess you should use OSPF so you do not have to configure routing every time your customer changes something. If your customer routing is as simple as single net connected to your PE routers at multiple sites, then you do not need static routing.
 
-headstrong-
Member
Member
Topic Author
Posts: 377
Joined: Thu Jun 05, 2008 8:04 pm
Location: South Africa

Re: OSPF or BGP for MPLS network for WISP

Tue Aug 18, 2009 11:44 pm

thanks mplsguy

My customer needs are pretty simple so static routing should do the trick...

My lab test only had 1 CE router per PE so it was easy enough to specify the "interface". What happens when I have +-30 customers connecting to the same sector? My gut feeling would be to create a unique vlan from the CPE <==> AP and then use that as the interface? Is there an easier way?
 
Mplsguy
MikroTik Support
MikroTik Support
Posts: 226
Joined: Fri Jun 06, 2008 5:06 pm

Re: OSPF or BGP for MPLS network for WISP

Wed Aug 19, 2009 10:15 am

It is mandatory to have separate CE-PE interface in order to use multiple VRFs. There are multiple ways to achieve this (though none of them will probably be as easy as you would like) - VLANs (like you suggest), separate WDS interface for every customer (in case you use RouterOS on client side as well - I think this would be the preferred way because you would also eliminate broadcasting/multicasting in wireless), or any other way of tunneling.

If CPEs are in your control, you can also consider making CPE routers to be PE routers (and simply MPLS switch at the AP) - this would be the most efficient solution performance wise.
 
-headstrong-
Member
Member
Topic Author
Posts: 377
Joined: Thu Jun 05, 2008 8:04 pm
Location: South Africa

Re: OSPF or BGP for MPLS network for WISP

Wed Aug 19, 2009 3:50 pm

Thanks again mplsguy

I tried the WDS setup before and it gave me issues with nstreme so I'm going to try the CPE being part of the MPLS cloud.....

All our CPE's are mikrotik and we have control, so am I correct in assuming that I would only use BGP on the CPE's (for vrf's) instead of on the highsites? This would simplify things quite a bit for the backbone network.

EDIT: would having all these additional MPLS routers (CPE's) affect performace of the MPLS network? CPE's are normally lower spec routerboards than the highsites
 
Mplsguy
MikroTik Support
MikroTik Support
Posts: 226
Joined: Fri Jun 06, 2008 5:06 pm

Re: OSPF or BGP for MPLS network for WISP

Wed Aug 19, 2009 5:25 pm

Thanks again mplsguy

I tried the WDS setup before and it gave me issues with nstreme so I'm going to try the CPE being part of the MPLS cloud.....
You must use station-wds mode on client in order to have WDS links in nstreme network.
All our CPE's are mikrotik and we have control, so am I correct in assuming that I would only use BGP on the CPE's (for vrf's) instead of on the highsites? This would simplify things quite a bit for the backbone network.
Yes.
EDIT: would having all these additional MPLS routers (CPE's) affect performace of the MPLS network? CPE's are normally lower spec routerboards than the highsites
I do not think that moving MPLS ingress point to CPE would significantly degrade its performance compared to regular routing (taking into account that it is transmitting over wireless, not over gigabit ethernet - so it should not be at its max load anyway). I would even say that this would give overall performance benefits, because: 1 - you will eliminate one hop that does IP routing (AP), 2 - you will distribute the load of "introducing" labels across multiple CPE routers where before it was done by single AP.
 
-headstrong-
Member
Member
Topic Author
Posts: 377
Joined: Thu Jun 05, 2008 8:04 pm
Location: South Africa

Re: OSPF or BGP for MPLS network for WISP

Wed Aug 19, 2009 6:41 pm

I do not think that moving MPLS ingress point to CPE would significantly degrade its performance compared to regular routing (taking into account that it is transmitting over wireless, not over gigabit ethernet - so it should not be at its max load anyway). I would even say that this would give overall performance benefits, because: 1 - you will eliminate one hop that does IP routing (AP), 2 - you will distribute the load of "introducing" labels across multiple CPE routers where before it was done by single AP.
I was thinking a similar thing actually...I'm ganna give all the above tips/tricks a shot and report back once done...

thanks again for your time
 
phendry
Member Candidate
Member Candidate
Posts: 258
Joined: Fri May 28, 2004 4:42 pm

Re: OSPF or BGP for MPLS network for WISP

Sat Aug 22, 2009 1:53 pm

If CPEs are in your control, you can also consider making CPE routers to be PE routers (and simply MPLS switch at the AP) - this would be the most efficient solution performance wise.
We where looking at this but wheren't sure of the QoS implications. If the CPE's are all PE routers causing the AP's to be P routers then how could the AP be set to priorities traffic over the wireless interface?
 
Mplsguy
MikroTik Support
MikroTik Support
Posts: 226
Joined: Fri Jun 06, 2008 5:06 pm

Re: OSPF or BGP for MPLS network for WISP

Sun Aug 23, 2009 11:12 pm

Depends on what QoS feature you want to implement - if you want to use WMM, then setup is rather simple - MPLS switching automatically sets up packet priority (that is later used by WMM to select access category) based on label EXP field value, see http://wiki.mikrotik.com/wiki/EXP_bit_behaviour. You just have to set proper priority value for packet on MPLS ingress router, so that EXP field in label gets initialized properly.
 
phendry
Member Candidate
Member Candidate
Posts: 258
Joined: Fri May 28, 2004 4:42 pm

Re: OSPF or BGP for MPLS network for WISP

Mon Aug 24, 2009 12:12 am

We use NStreme on all our AP's so can't utilise WMM. Any other options?
 
-headstrong-
Member
Member
Topic Author
Posts: 377
Joined: Thu Jun 05, 2008 8:04 pm
Location: South Africa

Re: OSPF or BGP for MPLS network for WISP

Mon Aug 24, 2009 2:51 pm

We use NStreme on all our AP's so can't utilise WMM. Any other options?
Why does nstreme break WMM?
 
Mplsguy
MikroTik Support
MikroTik Support
Posts: 226
Joined: Fri Jun 06, 2008 5:06 pm

Re: OSPF or BGP for MPLS network for WISP

Tue Aug 25, 2009 9:40 am

We use NStreme on all our AP's so can't utilise WMM. Any other options?
Well, if you insist on doing QoS on AP (that is - QoS on ingress router is not enough), then I guess you should have your AP as PE router and use queues. Currently RouterOS does not have queue type that would prioritize based on packets priority value.
Why does nstreme break WMM?
Nstreme does not break WMM - WMM is 802.11 hardware feature, but nstreme is somewhat different protocol that does not have internal priorities for different traffic types.
 
-headstrong-
Member
Member
Topic Author
Posts: 377
Joined: Thu Jun 05, 2008 8:04 pm
Location: South Africa

Re: OSPF or BGP for MPLS network for WISP

Tue Aug 25, 2009 11:27 pm

Ok so got my vrf lab setup working today with BGP running between 2x PE routers. MPLS and LDP is running on the PE routers aswell as the other P router between them...VRF works like a charm.

I have followed this http://wiki.mikrotik.com/wiki/A_complet ... PN_example except that I have BGP running directly between PE1 and PE2 and P is just another hop in the MPLS cloud.

But my question is how do I know that the VRF is using MPLS instead of standard routing?

thanks
 
Mplsguy
MikroTik Support
MikroTik Support
Posts: 226
Joined: Fri Jun 06, 2008 5:06 pm

Re: OSPF or BGP for MPLS network for WISP

Wed Aug 26, 2009 3:13 pm

Currently there is no feature that would display what labels are attached when packets are sent using some route. It is on TODO list. In your case - you can be pretty sure that MPLS is used if your P router does not have your VPN routes and therefore would not be able to forward traffic without MPLS.
 
-headstrong-
Member
Member
Topic Author
Posts: 377
Joined: Thu Jun 05, 2008 8:04 pm
Location: South Africa

Re: OSPF or BGP for MPLS network for WISP

Fri Aug 28, 2009 3:54 pm

thanks

I've encounted my 1st issue, I have a LAB with 4x mpls routers:

PE-A <===> P-1 <===> P-2 <===> PE-B

P-2 can ping PE-A but PE-A cannot ping P-2...Why is this? It seems to happen all the time even with different configs
 
-headstrong-
Member
Member
Topic Author
Posts: 377
Joined: Thu Jun 05, 2008 8:04 pm
Location: South Africa

Re: OSPF or BGP for MPLS network for WISP

Fri Aug 28, 2009 8:19 pm

Fixed it...replace static routing with OSPF
 
phendry
Member Candidate
Member Candidate
Posts: 258
Joined: Fri May 28, 2004 4:42 pm

Re: OSPF or BGP for MPLS network for WISP

Sat Aug 29, 2009 4:46 pm

We use NStreme on all our AP's so can't utilise WMM. Any other options?
Well, if you insist on doing QoS on AP (that is - QoS on ingress router is not enough), then I guess you should have your AP as PE router and use queues. Currently RouterOS does not have queue type that would prioritize based on packets priority value.
QoS is best used at the bottle neck of any network as there is no point prioritising traffic on a 100mb link if traffic is being dropped on a 10mb link before it gets to the 100mb link. RF part of AP will always be the bottle neck which is normally where you would utilise QoS.

Does anyone else have any ideas on a way to use the priority within the EXP field to prioritise traffic across an RF link within a P router?
 
-headstrong-
Member
Member
Topic Author
Posts: 377
Joined: Thu Jun 05, 2008 8:04 pm
Location: South Africa

Re: OSPF or BGP for MPLS network for WISP

Sun Aug 30, 2009 1:12 am

Does anyone else have any ideas on a way to use the priority within the EXP field to prioritise traffic across an RF link within a P router?
Wouldn't WMM between the links do the trick? provided nstreme is off?
 
phendry
Member Candidate
Member Candidate
Posts: 258
Joined: Fri May 28, 2004 4:42 pm

Re: OSPF or BGP for MPLS network for WISP

Sun Aug 30, 2009 4:19 pm

Does anyone else have any ideas on a way to use the priority within the EXP field to prioritise traffic across an RF link within a P router?
Wouldn't WMM between the links do the trick? provided nstreme is off?
That's the problem. Our AP's and CPE's run RouterOS so we can benefit from NStreme. Anyone from Mikrotik have any comment on this as MPLS+NStreme+QoS would be a great setup that no one else can currently offer.

Who is online

Users browsing this forum: No registered users and 9 guests