Community discussions

 
rucevzhuru
newbie
Topic Author
Posts: 43
Joined: Fri May 25, 2007 6:57 pm

Database description packet has different master status flag

Thu Aug 13, 2009 10:22 pm

Hi guys,
we have started to deploy OSPF on our whole network (around 40 routers). We use only mikrotiks and all ROS versions are 3.10 (except 3 routers with 3.24). On some routers we have problems with OSPF routing. Routers can't make adjacency. Situation is everytime same: One router thinks that it has full adjacency(call its A), second router is frozen in Exchange state (call its B). After few seconds A writes to the log (Database description packet has different master status flag, new master flag = false) and B writes to the log(OSPF neighbour XX.XX.XX.XX: state from exchange to 2-way). Logs on both routers are full of these messages. Sometimes after while this problem disappears and both routers make adjacency. We had to use static routes otherwise this link would be unusable. When it happens there is no adjacency and it means no routes.

We have same problem on more routers. There are more links on the routers and it usually affects only one of this link. There is simple help when it happens. I have to disable affected network in the ospf routing menu on both routers and then enable it again. One can call it a solution but whole network is then not autonomous with this. I can even simulate this error on affected routers (to stop given network in ospf menu on one router and then reenable it, if you stop them on both routers simultanely and then enable both networks error doesn't occur).

I made some investigations with wireshark. There are screenshots from the good situation (network 10.250.0.48/29 were enabled in ospf menu on both routers in almost same time) and also from bad situation. I also enclosed traffic dumps from both situations (pcap format, sorry for rsc file extensions but i couldn't upload it to forum).

According to screenshots after few packets of database exchange router 10.250.0.49 sends multicast to DR multicast address (224.0.0.6) in good situation but it doesn't happen in bad situation. I suppose that it has to be a bug in ospf implementation.

Do you have some solution suggestions?
You do not have the required permissions to view the files attached to this post.
 
rucevzhuru
newbie
Topic Author
Posts: 43
Joined: Fri May 25, 2007 6:57 pm

Re: Database description packet has different master status flag

Thu Aug 13, 2009 10:23 pm

There was 3 attachments limit, so I had to add reply with bad situation traffic dump.
You do not have the required permissions to view the files attached to this post.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8305
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Database description packet has different master status flag

Thu Aug 13, 2009 11:37 pm

upgrade to the latest version, then check. maybe you should better use routing-test package - it has some more fixes
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
rucevzhuru
newbie
Topic Author
Posts: 43
Joined: Fri May 25, 2007 6:57 pm

Re: Database description packet has different master status flag

Fri Aug 14, 2009 12:37 am

upgrade to the latest version, then check. maybe you should better use routing-test package - it has some more fixes
I have just tried Mikrotik 3.28 on both ends of the link and situation is completely same. When I enable network(10.250.0.48/29) on both ends of the link (10.250.0.49, 10.250.0.50, it is ptp wireless link with only these two ip address) in almost same time it works and routers find adjacency. Then if I disable network (in ospf menu) and then enable again on one of the router => they dont make full adjacency.

We use very simple ospf settings. It's almost default configuration, I only set router-id(10.11.0.48 and 10.11.0.56) and add network in ospf network menu.
 
sup5
Member
Member
Posts: 322
Joined: Sat Jul 10, 2010 12:37 am

Re: Database description packet has different master status

Thu Jul 14, 2011 1:02 pm

I am experiencing exactly the same problem with RouterOS 5.5.
The Routers are a RB1200 and a x86.

Is there any usable solution for this issue?
 
athatare81
just joined
Posts: 1
Joined: Wed Aug 24, 2011 2:47 am

Re: Database description packet has different master status

Wed Aug 24, 2011 2:50 am

I have the same problems with Mikrotik Version 5.6 and RB750G on each ends of the link. Is there any solution to this question?

Or any explanation to that debug output, since MTU sizes on both routers matches and Multicasts are allowed.
 
lorell
newbie
Posts: 30
Joined: Fri Oct 02, 2009 3:15 am

Re: Database description packet has different master status

Mon Sep 12, 2011 2:01 am

I am having this same problem on RouterOS v5.5 with x86, mipsbe (RB750) and power-pc (RB1100) platforms.

Same error messages in the log files as the entries at the top. If I disable the instance and re-enable, the adjacencies are re-formed and it trudges on for about a week and then fails again.

Annoying and customer-un-friendly.
 
supp
just joined
Posts: 1
Joined: Tue Sep 27, 2011 8:27 am

Re: Database description packet has different master status

Tue Sep 27, 2011 8:30 am

I am having this same problem on RouterOS v5.7 with x86, mipsbe (RB750) platforms.
 
bobanus
just joined
Posts: 4
Joined: Fri Oct 21, 2011 4:25 pm

Re: Database description packet has different master status

Fri Oct 21, 2011 5:08 pm

Guys do you use any bonding (EtherChannels) on these links by chance?
 
ckgth
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Wed Jun 06, 2007 5:03 pm

Re: Database description packet has different master status

Mon Oct 24, 2011 2:29 am

Hi!

same in 5.5 with ppc and 5.7 with mipsbe.
We have no bonding-Interfaces.
only a simple config

regards
 
lavv17
Member Candidate
Member Candidate
Posts: 120
Joined: Sat Sep 01, 2007 9:01 am

Re: Database description packet has different master status

Mon Oct 24, 2011 10:00 am

It can be a problem with multicast. I had a similar problem with unreliable radio link and also with a switch with incorrectly set multicast traffic control.
 
changeip
Forum Guru
Forum Guru
Posts: 3803
Joined: Fri May 28, 2004 5:22 pm

Re: Database description packet has different master status

Mon Oct 24, 2011 7:21 pm

nbma mode should be used on wireless links.
Colo and Wholesale Bandwidth Available! Sales at SanDiegoBroadband dot com
 
lavv17
Member Candidate
Member Candidate
Posts: 120
Joined: Sat Sep 01, 2007 9:01 am

Re: Database description packet has different master status

Thu Oct 27, 2011 1:26 pm

usually default mode works well, unless the radio link is not reliable.
 
sricci
just joined
Posts: 18
Joined: Thu Jul 28, 2011 12:57 pm

Re: Database description packet has different master status

Fri Nov 18, 2011 10:58 am

Has someone found a solution for the issue ? We're experiencing it often and often, seems to me that a flapping link is likely to trigger the problem...that's a real no-go issue for us.
I tried using nbma too, but it doesn't seem to work well with many routers on the same segment (10+).


Regards,
Simone.
 
changeip
Forum Guru
Forum Guru
Posts: 3803
Joined: Fri May 28, 2004 5:22 pm

Re: Database description packet has different master status

Fri Nov 18, 2011 5:58 pm

post your config - this thread is 2+ years old and is probably not related to your problem.
Colo and Wholesale Bandwidth Available! Sales at SanDiegoBroadband dot com
 
sricci
just joined
Posts: 18
Joined: Thu Jul 28, 2011 12:57 pm

Re: Database description packet has different master status

Mon Nov 21, 2011 6:46 pm

post your config - this thread is 2+ years old and is probably not related to your problem.
This is the AP:
/routing ospf instance
set default disabled=no distribute-default=never in-filter=ospf-in metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=\
    auto metric-rip=20 metric-static=20 name=default out-filter=ospf-out redistribute-bgp=no redistribute-connected=no \
    redistribute-other-ospf=no redistribute-rip=no redistribute-static=no router-id=172.31.0.1
/routing ospf area
set backbone area-id=0.0.0.0 disabled=no instance=default name=backbone type=default
add area-id=0.0.0.25 disabled=no instance=default name=area25 type=default
/routing ospf interface
add authentication=none authentication-key="" authentication-key-id=1 cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 \
    interface=all network-type=broadcast passive=yes priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=none authentication-key="" authentication-key-id=1 cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 \
    interface=wlan1 network-type=broadcast passive=no priority=10 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=none authentication-key="" authentication-key-id=1 cost=1 dead-interval=40s disabled=no hello-interval=10s instance-id=0 \
    interface=ether1 network-type=default passive=no priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
/routing ospf network
add area=backbone disabled=no network=172.31.0.1/32
add area=area25 disabled=no network=172.17.0.0/24
add area=backbone disabled=no network=192.168.3.0/24
And a client
/routing ospf instance
set default disabled=no distribute-default=never in-filter=ospf-in metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=\
    auto metric-rip=20 metric-static=20 name=default out-filter=ospf-out redistribute-bgp=no redistribute-connected=no \
    redistribute-other-ospf=no redistribute-rip=no redistribute-static=no router-id=172.31.1.1
/routing ospf area
set backbone area-id=0.0.0.0 disabled=no instance=default name=backbone type=default
add area-id=0.0.0.25 disabled=no instance=default name=area25 type=default
/routing ospf interface
add authentication=none authentication-key="" authentication-key-id=1 cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 \
    interface=all network-type=broadcast passive=yes priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=none authentication-key="" authentication-key-id=1 cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 \
    interface=wlan1 network-type=broadcast passive=no priority=0 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=none authentication-key="" authentication-key-id=1 cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 \
    interface=ether1 network-type=default passive=no priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
/routing ospf network
add area=area25 disabled=no network=172.17.0.0/24
add area=area25 disabled=no network=172.16.254.0/24
add area=area25 disabled=no network=172.31.1.1/32
Pretty much default config, not so stable. I tried nbma, but got even worse: when rebooting AP - for example - often adjacencies fails to form, really weird.
My feeling is that OSPF has been somehow broken few release ago (we're currently trying 5.9, same problems), another tower running 5.4 doesn't exhibit so much problems (but nbma fails to work correctly there, too).

BR,
Simone
 
Lognet
just joined
Posts: 7
Joined: Fri Sep 09, 2011 1:19 am

Re: Database description packet has different master status

Sun Dec 04, 2011 11:03 pm

Same probleme, test with version 5.6, 5.7, 5.8 and now 5.9 on all router that participate in the exchange of OSPF
We are using nbma everywhere, priority and cost setup correctly.
We have two network on physical local switch and one wireless between them, really stable link, up to 130 mbs on it, latency 2 ms, no packet lost, no drop, no problem.
Only one router don't show the ''state change from Exchange to 2-Way'' or the ''Database Description packet has different master status flag new master flag false'', all the other exibite that error on the log

Only solution we found so far to allow us to keep ospf for our backbone redondancy is to add on top of it RIP with limited network subnet :shock:

Any chance Mikrotik guru will find a solution ? Or is this a bug ?

Thank you
Simon
 
sricci
just joined
Posts: 18
Joined: Thu Jul 28, 2011 12:57 pm

Re: Database description packet has different master status

Sun Dec 04, 2011 11:17 pm

Same probleme, test with version 5.6, 5.7, 5.8 and now 5.9 on all router that participate in the exchange of OSPF
We are using nbma everywhere, priority and cost setup correctly.
We have two network on physical local switch and one wireless between them, really stable link, up to 130 mbs on it, latency 2 ms, no packet lost, no drop, no problem.
Only one router don't show the ''state change from Exchange to 2-Way'' or the ''Database Description packet has different master status flag new master flag false'', all the other exibite that error on the log

Only solution we found so far to allow us to keep ospf for our backbone redondancy is to add on top of it RIP with limited network subnet :shock:

Any chance Mikrotik guru will find a solution ? Or is this a bug ?

Thank you
Simon
Hi, unfortunately we found the mikrotik ospf implementation to be quite buggy...and unable to find any workaround so far.

BR,
Simone.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24142
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Database description packet has different master status

Mon Dec 05, 2011 1:07 pm

Hi, unfortunately we found the mikrotik ospf implementation to be quite buggy...and unable to find any workaround so far.
such statement needs more explanation
No answer to your question? How to write posts
 
User avatar
Bernardo
newbie
Posts: 27
Joined: Wed Nov 02, 2011 12:05 pm

Re: Database description packet has different master status

Wed Dec 21, 2011 4:49 pm

Hi, unfortunately we found the mikrotik ospf implementation to be quite buggy...and unable to find any workaround so far.
such statement needs more explanation
Normis,

sadly the above statement is very true.
Just read all those related postings allover the forum.

I'm a Mikrotik user for at least 10 years now, started even way before PPPoE was implemented, and RouterOS was still called Mikrotik, but lately I'm getting really tired of this kind of attitude.

Why post at all, if all you add, is just another snippy comment?

And while I'm at it, how is it that I feel like a Beta Tester every time a new 5.x "stable" is released?
I truly have seen doing way better some years ago.

/rant over

saludos
Bernardo
 
sup5
Member
Member
Posts: 322
Joined: Sat Jul 10, 2010 12:37 am

Re: Database description packet has different master status

Tue Dec 27, 2011 6:40 pm

I also think, that OSPF is quite buggy!

Sometimes I need to renumber parts of my network.

So far one of the ugly things is this:
For some reason I needed to renumber the loopback-address of a router.
Hmm, sounds easy:
1) add the new loopback-ip to my lo-bridge.
2) change the loopback-ip for the ospf-instance to the new address.
3) delete the old loopback address from the lo-bridge.
4) done.

But this is just the theory.

In practice I need to reboot each affected router after altering the loopback-address, because otherwise it will stop to propagate its connected networks 30mins to 60mins AFTER the change happened!
So effectively (if you didn't reboot the router) you think you're done, everything works like it should and you go away doing other stuff.
Suddenly half an hour later the networks behind the router become inresponsible! This is inacceptable.

This behaviour is not desirable because it stops passing traffic through the router as long as the reboot needs plus the amount of time needed establishing all routes...
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: Database description packet has different master status

Thu Dec 29, 2011 11:01 pm

I also having troble with ospf. Its seems like OSPF is quite good up and running, but afte some kind of state change, (wireless link down between 2 routers etc) it has trobble getting back. Whats really wired, is that a reebot of connecting routers, always seems to work.

Simple setup:

R1-R2-R3

If link goes down between R2 and R3 ospf will not up running. ((Rb1100 MPLS/ospf/bgp ((R2))) - (RB800 NV2, plane bridge, wds mode) - (RB800 NV2, plane bridge, wds mode) - (Rb11000 Mpls,ospf/bgp (R3))

(Its the same if link is ethernet,fiber,licensed 18/23G radios etc)

I'we got wired errors in log.

From R3: (why 10M full i dont know, but its not the problem)

/02/1970 01:00:09 interface,info ether11 link down
jan/02/1970 01:00:10 interface,info ether11 link up (speed 100M, full duplex)
jan/02/1970 01:00:11 interface,info ether11 link down
jan/02/1970 01:00:13 interface,info ether11 link up (speed 10M, full duplex)
jan/02/1970 01:00:33 route,ospf,info OSPFv2 neighbor 172.31.0.11: state change from ExStart to Init
jan/02/1970 01:00:33 route,ospf,info OSPFv2 neighbor 172.31.0.13: state change from ExStart to Init
jan/02/1970 01:00:33 route,ospf,info OSPFv2 neighbor 172.31.0.13: state change from ExStart to Init
jan/02/1970 01:00:55 route,bgp,info Failed to open TCP connection: Network is unreachable
jan/02/1970 01:00:55 route,bgp,info RemoteAddress=172.31.0.13
jan/02/1970 01:00:58 route,bgp,info TCP connection established
jan/02/1970 01:00:58 route,bgp,info RemoteAddress=172.31.0.15
15:03:18 route,ospf,info Database Description packet has different master status flag
15:03:18 route,ospf,info new master flag=false
15:03:18 route,ospf,info OSPFv2 neighbor 172.31.0.13: state change from Full to 2-Way
15:03:18 route,ospf,info Database Description packet has different master status flag
15:03:18 route,ospf,info new master flag=false
15:03:18 route,ospf,info OSPFv2 neighbor 172.31.0.13: state change from Full to 2-Way
15:03:36 route,bgp,info Connection opened by remote host
15:03:36 route,bgp,info RemoteAddress=172.31.0.11

From Other side (R3)

15:02:31 route,ospf,info Invalid sequence number
15:02:31 route,ospf,info mine=381330
15:02:31 route,ospf,info received=15
15:02:31 route,ospf,info Discarding packet: MD5 authentication failed
15:02:31 route,ospf,info source=172.17.0.102
15:02:31 route,ospf,info Invalid sequence number
15:02:31 route,ospf,info mine=552049
15:02:31 route,ospf,info received=18
15:02:31 route,ospf,info Discarding packet: MD5 authentication failed
15:02:31 route,ospf,info source=172.17.0.190
15:02:32 route,bgp,info Connection opened by remote host
15:02:32 route,bgp,info RemoteAddress=172.31.0.20
15:02:33 route,ospf,info OSPFv2 neighbor 172.31.0.19: state change from Exchange to 2-Way
15:02:35 route,ospf,info OSPFv2 neighbor 172.31.0.14: state change from Init to Down
15:02:35 route,ospf,info OSPFv2 neighbor 172.31.0.14: state change from Init to Down
15:02:36 route,ospf,info Discarding Database Description packet: wrong neighbor state
15:02:36 route,ospf,info state=Down
15:02:36 route,bgp,info Failed to open TCP connection: Network is unreachable
15:02:36 route,bgp,info RemoteAddress=172.31.0.14
15:02:36 route,ospf,info Discarding packet: no neighbor with this source address
15:02:36 route,ospf,info RouterId=172.31.0.14
15:02:36 route,ospf,info source=172.17.0.190
15:02:48 route,bgp,info TCP connection established
15:02:48 route,bgp,info RemoteAddress=172.31.0.19


If this was the problem. why its not before link down? And why is everything Ok after reebooting R3?


this is a default config R2:
/routing ospf instance
set default disabled=no distribute-default=never in-filter=ospf-in metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=auto metric-rip=20 metric-static=20 name=\
    default out-filter=ospf-out redistribute-bgp=no redistribute-connected=as-type-1 redistribute-other-ospf=no redistribute-rip=no redistribute-static=no router-id=172.31.0.11
/routing ospf area
set backbone area-id=0.0.0.0 disabled=no instance=default name=backbone type=default
/routing ospf interface
add authentication=md5 authentication-key=xxxxxx authentication-key-id=1 cost=10 dead-interval=20s disabled=no hello-interval=5s instance-id=0 interface=ether1 \
    network-type=nbma passive=no priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=md5 authentication-key=xxxxxx authentication-key-id=10 cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=ether13 \
    network-type=ptmp passive=no priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=md5 authentication-key=xxxxxx authentication-key-id=10 cost=200 dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=ether6 \
    network-type=ptmp passive=no priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=md5 authentication-key=xxxxxx authentication-key-id=1 cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=ether7 \
    network-type=nbma passive=no priority=250 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=md5 authentication-key=xxxxxx authentication-key-id=1 cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=ether5 \
    network-type=nbma passive=no priority=2 retransmit-interval=5s transmit-delay=1s use-bfd=no
/routing ospf nbma-neighbor
add address=10.1.0.14 disabled=no instance=default poll-interval=5s priority=1
add address=172.17.0.81 disabled=no instance=default poll-interval=5s priority=250
add address=172.17.11.12 disabled=no instance=default poll-interval=5s priority=1
add address=172.17.11.110 disabled=no instance=default poll-interval=10s priority=1
/routing ospf network
add area=backbone disabled=no network=172.17.0.80/29
add area=backbone disabled=no network=172.17.0.96/29
add area=backbone disabled=no network=172.17.0.184/29
add area=backbone disabled=no network=172.17.0.88/29
add area=backbone disabled=no network=172.17.11.8/29
add area=backbone disabled=no network=172.17.11.104/29
add area=backbone disabled=no network=172.31.0.11/32


Default config R3:
/routing ospf instance
set default disabled=no distribute-default=never in-filter=ospf-in metric-bgp=\
    auto metric-connected=20 metric-default=1 metric-other-ospf=auto \
    metric-rip=20 metric-static=20 name=default out-filter=ospf-out \
    redistribute-bgp=no redistribute-connected=as-type-1 \
    redistribute-other-ospf=no redistribute-rip=no redistribute-static=\
    as-type-1 router-id=172.31.0.14
/routing ospf area
set backbone area-id=0.0.0.0 disabled=no instance=default name=backbone type=\
    default
/routing ospf interface
add authentication=md5 authentication-key=yyyyyyyyyyyy \
    authentication-key-id=10 cost=10 dead-interval=40s disabled=no \
    hello-interval=10s instance-id=0 interface=ether13 network-type=\
    point-to-point passive=no priority=1 retransmit-interval=5s transmit-delay=\
    1s use-bfd=no
add authentication=md5 authentication-key=yyyyyyyyyyyyyy \
    authentication-key-id=10 cost=20 dead-interval=40s disabled=no \
    hello-interval=10s instance-id=0 interface=ether11 network-type=\
    point-to-point passive=no priority=1 retransmit-interval=5s transmit-delay=\
    1s use-bfd=no
add authentication=md5 authentication-key=yyyyyyyyyyyyyyy \
    authentication-key-id=10 cost=10 dead-interval=40s disabled=no \
    hello-interval=10s instance-id=0 interface=ether6 network-type=ptmp \
    passive=no priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=md5 authentication-key=yyyyyyyyyyyyyyyyyyy \
    authentication-key-id=10 cost=20 dead-interval=40s disabled=no \
    hello-interval=10s instance-id=0 interface=ether7 network-type=ptmp \
    passive=no priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=md5 authentication-key=yyyyyyyyyyyyyyyyyyyyyy \
    authentication-key-id=10 cost=10 dead-interval=40s disabled=no \
    hello-interval=10s instance-id=0 interface=ether8 network-type=ptmp \
    passive=no priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=md5 authentication-key=yyyyyyyyyyyyyyyyyyyy \
    authentication-key-id=10 cost=20 dead-interval=40s disabled=no \
    hello-interval=10s instance-id=0 interface=ether9 network-type=ptmp \
    passive=no priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
/routing ospf network
add area=backbone disabled=no network=172.17.0.96/29
add area=backbone disabled=no network=10.1.0.184/29
add area=backbone disabled=no network=172.17.0.184/29
add area=backbone disabled=no network=172.17.0.168/29
add area=backbone disabled=no network=172.17.0.176/29
add area=backbone disabled=no network=172.17.0.192/29
add area=backbone disabled=no network=172.17.0.200/29
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: Database description packet has different master status

Mon Jan 02, 2012 11:25 pm

I have done some testing, and i see that age on LSA have really long "age (s)" Is this some kind of time out stuff, that resets when rooter is booted? May the LSA calculate a different value after a link down, and new value is not recogniced couse of a really long timeout to the old LSA? This is just a theory, but i dont know OSPF to vell (and have not goole it to much)
 
User avatar
leoservices
Trainer
Trainer
Posts: 138
Joined: Fri Jan 13, 2012 2:20 am
Location: Belo Horizonte - MG - Brazil
Contact:

Re: Database description packet has different master status

Fri Jan 13, 2012 2:39 am

Hello everybody, someone managed to solve this problem? I am using OSPF on a network that was fine, until a later add more POP and started the problem discussed here.
I try to help !

Leonardo Vieira
https://youtube.com/contractti
Like Facebook.com/contractti
 
ckgth
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Wed Jun 06, 2007 5:03 pm

Re: Database description packet has different master status

Sat Jan 14, 2012 9:56 am

currently there is no fix.
i think it cames far in future, when ros 6 comes. i think there is a kernel problem...
Can anyone says, when ROS6 cames? Roadmap?

regards
 
bobanus
just joined
Posts: 4
Joined: Fri Oct 21, 2011 4:25 pm

Re: Database description packet has different master status

Tue Feb 28, 2012 12:48 pm

Yes. This is really frustraiting. I removed all ehterchannels and must admit that this problem persists.
I mainly have such OSPF issues on couple of backbone routers that run full view BGP in addition to ospf.
Do you run BGP guys on your routers?
 
Lognet
just joined
Posts: 7
Joined: Fri Sep 09, 2011 1:19 am

Re: Database description packet has different master status

Tue Feb 28, 2012 1:55 pm

Yes, we run two Full BGP routing table on the end of each segment
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: Database description packet has different master status

Tue Feb 28, 2012 10:08 pm

yes. we run ibgp with confederation towards a full internet routing table at confederation AS.
also with MPLS
It may seems that problem may be a bit better, if switching to ptp mode instead of nbma. but i have not yet tried a full implement of this.
 
User avatar
acim
Member
Member
Posts: 424
Joined: Mon Sep 12, 2005 12:26 am
Location: Serbia
Contact:

Re: Database description packet has different master status

Sat May 12, 2012 2:01 am

Have you tried WDS PTP link? On bridge interface add WDS and use station-wds mode on another peer.
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: Database description packet has different master status

Sun May 20, 2012 1:05 am

Have you tried WDS PTP link? On bridge interface add WDS and use station-wds mode on another peer.
I dont use annything else than wds, and it also happening on fiber, ethenret etc.
 
mhugo
newbie
Posts: 48
Joined: Mon Sep 19, 2005 11:48 am

Re: Database description packet has different master status

Mon Jul 09, 2012 10:26 am

Sorry for crossposting -

I have the issue too and it seems to be originating in one router as two neighbours gets the master flag changed issue.

The router has been switched two times 732->RB1100->RB1100X2

Routerid has been checked, no visible network issues on the ethernet , etc.

Any clue?

/M
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: Database description packet has different master status

Tue Jul 10, 2012 12:21 am

I'm still sure this have someting to do with the LSA value not timeing out. Im not sure abot this, but i see that LSA does not time out, and it seems like the new LSA value after link down is not recognised. I dont know ospf, and LSA so much, so i cant say, YES!!! This is the problem, but my search for an answer, stop here. Maybe someone know more about this than me?
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: Database description packet has different master status

Tue Jul 10, 2012 12:24 am

Just to explane problem, im allmoust 3-4 times a week, reeboting a MPLS core router, due to this stuff. Im sure. I could script something to automate it, but i want to se this behavior my self when it happening. Its not good, and downtime to our customer, so a fix, hint how to prevent, or something new from mikrotik would be fine. the tip's already provided, does not help (nbma, wds)
 
bney
Frequent Visitor
Frequent Visitor
Posts: 53
Joined: Sun Jun 03, 2007 9:56 pm

Re: Database description packet has different master status

Fri Sep 14, 2012 12:27 am

I did find one case that causes this error.

I had two routers at a site connected by ethernet. OSPF would form neighbors but then started filling the logs with this message and not exchanging routes.
It turnd out that we had the same 1.1.98.1 id on the ospf instance on both routers. Once I fixed that oops, the problem cleared. Silly dup addresses.

It owuld be nice if the errors were a bit more informative.
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: Database description packet has different master status

Sat Sep 15, 2012 8:55 pm

I use my looback ip, as id in all my ospf routers, and it is not duplicated (then my routing allso would not work, an bgp etc would stop, since loopback is used for all communication between routers.)

Some places, i dont know why, is worse than other. It also seems to occur a lot more at 1200's, (together with a lot other problem with 1200) rather than 1000's and 1100's
 
mhugo
newbie
Posts: 48
Joined: Mon Sep 19, 2005 11:48 am

Re: Database description packet has different master status

Sun Sep 23, 2012 10:27 pm

We dont have any duplicate router ids since that will cause a mess :)
 
tyronzn
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Thu May 24, 2007 4:55 pm
Location: Durban,South Africa
Contact:

Re: Database description packet has different master status

Wed Oct 03, 2012 11:16 pm

I came across this problem probably mid way through last year.After many hours of problem solving and testing i came to the conclusion that there was a bug in V5 of mikrotik as i didnt experience it in V4.I then changed over to RIP which isnt ideal but it has done the job till now.Today i have moved two sites on the edge of my network back to ospf and will see if any improvements have been made.

UBNT v5.5.2 (wds)
RouterOS 5.20 with latest bootloader

so far the link looks good but this normally happens,sporadic behaviour.Once satisfied that it now works i will post and confirm the results.
 
Quicksivler
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Fri Dec 24, 2010 1:16 am

Re: Database description packet has different master status

Fri Oct 05, 2012 12:02 am

FIX THIS BUG.....

This takes down our network every day... need to stop ospf on all our routers and then restart it... sometimes that works.. sometimes it doesn't. I can't believe I'm saying this but does the RC for ROS6 have the same bug... if not I may have to switch and hope that something else isn't buggy
 
tyronzn
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Thu May 24, 2007 4:55 pm
Location: Durban,South Africa
Contact:

Re: Database description packet has different master status

Fri Oct 05, 2012 11:42 am

its been running fine on one of our links with no problem for two days now,i changed another link over to ospf and every now and again i got the common error message in the log link state down then full init etc.will continue using RIP for now
 
User avatar
theWISP
Member Candidate
Member Candidate
Posts: 111
Joined: Fri Sep 12, 2008 4:13 am
Contact:

Re: Database description packet has different master status

Sat Dec 08, 2012 1:28 am

We have a network of about 80 routers, all in the 5.15+ range. However, this has been a problem since we implemented ospf a few years ago. It does also exist in all rc6 releases. Please advise mikrotik.

Mikrotik, would you be willing to acknowledge a bug or show us that something has been seen here? Please help as this causes major issues on our network almost daily.

Thanks
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: Database description packet has different master status

Sat Dec 08, 2012 2:07 am

I dont See this problem annymore. Seems like it dissapered in 5.20 or somting around there. I also changed a lot from nbma to ptp.
 
User avatar
theWISP
Member Candidate
Member Candidate
Posts: 111
Joined: Fri Sep 12, 2008 4:13 am
Contact:

Re: Database description packet has different master status

Tue Dec 11, 2012 7:07 pm

It definitely still exists in 5.20+ and all RCs of 6.0. Switched to static routes in a couple of areas.
 
tyronzn
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Thu May 24, 2007 4:55 pm
Location: Durban,South Africa
Contact:

Re: Database description packet has different master status

Tue Dec 11, 2012 11:07 pm

My routing table is way too big for static routes so still using RIP.Very limited as compared to ospf.i pray day and night for the day to come once it is fixed.Although I have also read that it is a multicast issue between MikroTik and ubiquiti radios,can anyone confirm or deny?
 
User avatar
theWISP
Member Candidate
Member Candidate
Posts: 111
Joined: Fri Sep 12, 2008 4:13 am
Contact:

Re: Database description packet has different master status

Wed Dec 12, 2012 7:55 pm

We have had the issue exist on eth links. Usually on bridged interfaces.

Our network is the same way, we just have the adjacent router redistrubed static routes via OSPF. So only a few routers with the problem are statically assigned. and they are on the ends of the network so all they need is a default route.
 
tyronzn
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Thu May 24, 2007 4:55 pm
Location: Durban,South Africa
Contact:

Re: Database description packet has different master status

Wed Dec 12, 2012 11:56 pm

What puzzles me is I enable ospf on one link with no problem,but on another link routes periodically disappear with the log file showing the usual errors init down etc.All same hardware and network topology with the obvious differences of subnets on the radios and routers.it really baffles me,anyway I have now ordered radwin links for some of my p2p links.i will update next week on any progress with ospf.

Things I have tried...
Nbma neighbors
Broadcast on/off as well as point to point
Wds on/off
Multicast on/off
AirMax on/off
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: Database description packet has different master status

Sun Dec 16, 2012 10:24 am

I have been strugling a lot With this issue. But after 5.20 or 5.21, and some change to ptp from nmba (i now have mixed), i never have the problem annymore. Today i have about 50 ospf routers, and never see this problem. Ubnt, i dont use, couse of the mtu issue in mpls network. I use mt radio cards + mainboard, and ubnt antennas. Also mixed With fiber and dragonwave licenced links. I have also changed from 1200 (a really bad Product), to 1100, and it have been like going to heaven. :D
 
xyyx
just joined
Posts: 3
Joined: Fri Dec 21, 2012 6:54 am

Re: Database description packet has different master status

Mon Jan 14, 2013 2:28 am

I have been strugling a lot With this issue. But after 5.20 or 5.21, and some change to ptp from nmba (i now have mixed), i never have the problem annymore. Today i have about 50 ospf routers, and never see this problem. Ubnt, i dont use, couse of the mtu issue in mpls network. I use mt radio cards + mainboard, and ubnt antennas. Also mixed With fiber and dragonwave licenced links. I have also changed from 1200 (a really bad Product), to 1100, and it have been like going to heaven. :D
After upgrade to 5.22 I have this bug but mikrotik without message in log choose the route with the most cost in backbone. Main tunnel is up, and if I turn off backup tunnel mikrotik change route to min cost. After turn on backup tunnel, route is change to long way with max cost. Its very f...g bug. I downgrade to 5.19, because in this version bug as for my region only.
 
lambert
Long time Member
Long time Member
Posts: 529
Joined: Fri Jul 23, 2010 1:09 am

Re: Database description packet has different master status

Tue Jan 15, 2013 9:14 am

What puzzles me is I enable ospf on one link with no problem,but on another link routes periodically disappear with the log file showing the usual errors init down etc.All same hardware and network topology with the obvious differences of subnets on the radios and routers.it really baffles me,anyway I have now ordered radwin links for some of my p2p links.i will update next week on any progress with ospf.

Things I have tried...
Nbma neighbors
Broadcast on/off as well as point to point
Wds on/off
Multicast on/off
AirMax on/off
Which firmware on the UBNT equipment? I've had a few UBNT RocketM5 5.3.x links which just could not keep an OSPF neighbor association for more than a few hours. At least two of those links are now running smoothly with recent versions of the 5.5 release series. The link I checked just now has been solid for more than 18 days now with a beta version of the UBNT firmware. WDS on, Multicast allow all, distance auto, airmax off, 40MHz channel.

Other UBNT 5.3.x firmware links have worked well. The links with trouble are generally on paths with more noise.
 
axelmm
just joined
Posts: 4
Joined: Thu Jan 31, 2013 10:54 am

Re: Database description packet has different master status

Thu Jan 31, 2013 11:32 am

hi,

similar problem, but infrequent issue on one wireless link, -55/-56 94/99 ccq ap/station bridge nv2 (omni/711)
v.5.21 everywhere, ospf ptmp (for unicast), was stable, but recently has problem once a week to once a hour

some observations:
- on AP logs: state change Full to 2-Way followed different master status and flag=flase
- on client: only state Full to Down

while "locking" on client:
- link/registration looks ok, but no traffic
- no AP arp entry
- no ping answer, even with static routes set on both sides directly to neighbor (set bigger distance than distributed routes/ activated on loosing externals)

it look's like not only routing problem (static routes/arp-ping should work) but some kind of locking interface/link, it works again when on client/winbox I remove link registration (kick out link/ reconnect), the same with watchdog-script but with different way (ping check, disable/enable wlan1)
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: Database description packet has different master status

Thu Jan 31, 2013 11:16 pm

hi,

similar problem, but infrequent issue on one wireless link, -55/-56 94/99 ccq ap/station bridge nv2 (omni/711)
v.5.21 everywhere, ospf ptmp (for unicast), was stable, but recently has problem once a week to once a hour

some observations:
- on AP logs: state change Full to 2-Way followed different master status and flag=flase
- on client: only state Full to Down

while "locking" on client:
- link/registration looks ok, but no traffic
- no AP arp entry
- no ping answer, even with static routes set on both sides directly to neighbor (set bigger distance than distributed routes/ activated on loosing externals)

it look's like not only routing problem (static routes/arp-ping should work) but some kind of locking interface/link, it works again when on client/winbox I remove link registration (kick out link/ reconnect), the same with watchdog-script but with different way (ping check, disable/enable wlan1)

Problem come if a link between 2 Devices are dissconected, flapping, or just dropping traffic. could be Ethernet, Wireless, or fiber (etc etc). It seems like the ospf dont update the New LSA status after a dropout from link. Seems like NBMA and ptmp have the problem, but not (at least not that common) in ptp ospf links.
 
axelmm
just joined
Posts: 4
Joined: Thu Jan 31, 2013 10:54 am

Re: Database description packet has different master status

Fri Feb 01, 2013 10:19 pm

while "locking" on client:
- link/registration looks ok, but no traffic
- no AP arp entry
- no ping answer, even with static routes set on both sides directly to neighbor (set bigger distance than distributed routes/ activated on loosing externals)
Problem come if a link between 2 Devices are dissconected, flapping, or just dropping traffic. could be Ethernet, Wireless, or fiber (etc etc). It seems like the ospf dont update the New LSA status after a dropout from link. Seems like NBMA and ptmp have the problem, but not (at least not that common) in ptp ospf links.
but it looks like deeper, level2 problem: link looks ok, arp should work - ospf isn't needed for this
even if it loose LSA static route should work

i choosed ptmp as safer than broadcast and ptp ;)

maybe some interface status isn't properly updated/propagated - like no trafic/beacons should remove from registration - reconnecting repairs OR in opposite direction some LSA states changes results in bad interface state=low-level locking - undefined state
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: Database description packet has different master status

Sat Feb 23, 2013 2:19 am

I have not tried static routes. I have 100% ospf routing in backbone/management and bgp to internet vrf.

still, the second router, in same l2 net, would respond to a ping (in same broadcast domain). I have just problem with the establishment of the ospf. Some traffic is sendt between routers, but with an error. So traffic is passed in l2. Im still sure there are something about OSPF, that change if link goes down, and is not updated after reconnect, so things don't work.
 
mhugo
newbie
Posts: 48
Joined: Mon Sep 19, 2005 11:48 am

Re: Database description packet has different master status

Mon Feb 25, 2013 8:32 pm

Hi,

We are having the issue sometimes - Our observation is that this only happens on routers with one ospf uplink but on all kinds of routers.

Right now we have managed to reproduce this error on a router not carrying any traffic and the ospf has been cycling for 2 days.

The routers are connected on ethernet.

Im not seeing anything wierd in wireshark.

/Mikael
 
User avatar
jspool
Member
Member
Posts: 390
Joined: Sun Oct 04, 2009 4:06 am
Location: Oregon

Re: Database description packet has different master status

Tue Feb 26, 2013 5:53 am

NBMA works fine for me. 1000+ Mikrotik routers running OSPF just fine. of course everyone's network varies greatly but I am confident you can get it to work just fine. But make sure you are running a fairly recent firmware. I am amused by some that use V3 firmware and whine about features not working.
 
jovanislija
just joined
Posts: 1
Joined: Fri Aug 13, 2010 4:05 pm

Re: Database description packet has different master status

Tue Mar 12, 2013 1:35 am

hi,

similar problem, but infrequent issue on one wireless link, -55/-56 94/99 ccq ap/station bridge nv2 (omni/711)
v.5.21 everywhere, ospf ptmp (for unicast), was stable, but recently has problem once a week to once a hour

some observations:
- on AP logs: state change Full to 2-Way followed different master status and flag=flase
- on client: only state Full to Down

while "locking" on client:
- link/registration looks ok, but no traffic
- no AP arp entry
- no ping answer, even with static routes set on both sides directly to neighbor (set bigger distance than distributed routes/ activated on loosing externals)

it look's like not only routing problem (static routes/arp-ping should work) but some kind of locking interface/link, it works again when on client/winbox I remove link registration (kick out link/ reconnect), the same with watchdog-script but with different way (ping check, disable/enable wlan1)
This is most accurate description of problem. I tried:
- removed all devices from ethernet
- changed power supply

For me problem started after replacing one of mini-pci card with Mikrotik R52n (for AP) and upgraded router to 6.11rc. cm9 is still operating for simple wireless link. So link is there, clients are connected for long time to AP, but i have occasionally link hiccup to that router. I downgraded to 5.24 and problem still exists also after firmware upgrade to 3.0.

Well, I noticed that this phenomenon occurs more frequently at night or when the router is used more by the client. After midnight until morning router is responsive all the time. Router is not overloaded, cpu is 1-10% most of the time.

I plan to do full re-flash of a router, i hope formatting will do something good
Board is older 433 mips.
ANY SOLUTION? ANY IDEAS?
 
User avatar
mistiq
newbie
Posts: 37
Joined: Wed Oct 19, 2011 3:13 am
Location: Outside

Re: Database description packet has different master status

Thu Mar 28, 2013 8:02 am

Perhaps i find the way to fix this problem.
Some explanations: http://permalink.gmane.org/gmane.network.zebra/1913

When i disable md5 auth and change type ospf links from broadcast to p2p, i can`t see this error any more
K.i.s.S.
 
Painter
just joined
Posts: 1
Joined: Mon Apr 15, 2013 7:53 pm

Re: Database description packet has different master status

Mon Apr 15, 2013 8:03 pm

We had two problems with OSPF in latest RouterOS 5:
1. route,ospf,info Database Description packet has different master status flag
2. 3 default routes exists in LSA database with different metrics. Mikrotik add route with higher metric to route table?!

All these problems were solved by replacing OSPF by iBGP :(
 
O1DMBFan
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Fri Dec 05, 2008 11:08 pm

Re: Database description packet has different master status

Fri Apr 19, 2013 2:53 am

Wow, another forum post that is 2 pages long, several firmware revisions later and the problem still exists. The really frustrating part is that in all of this time and all of the reports/results/findings that have been posted; we only get one very broad, almost snide, response from a Mikrotik rep. This OSPF problem is still very much alive and needs to be addressed. If anything, at least acknowledged.

I'll have a serious conversation with my colleagues tomorrow about removing OSPF and implementing RIP again. So sad but can't afford any more outages without any indication of a solution to come.
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: Database description packet has different master status

Tue Apr 23, 2013 1:22 am

I Don't se this anymore. I have changed from NBMA to ptp, and it solved the issue.
 
jmorby
just joined
Posts: 13
Joined: Sat Jan 04, 2014 6:06 pm

Re: Database description packet has different master status

Thu Nov 27, 2014 1:21 am

Sad to say that even with the latest firmware (6.22) this problem persists

I've raised it directly with Mikrotik support and they've admitted that they know about it, but say don't expect it to be fixed any time soon (that was 6 months ago)

This is somewhat disappointing as this is preventing us from adopting devices like the CCR in a number of places (potentially thousands of devices)

There just seem to be so many "almost finished" modules and functions. After 5 years you think they'd have had the time to devote to fixing this .. OSPF is fairly fundamentally essential for large scale MPLS roll outs ... and yet this still fundamentally broken :(
 
und3ath
Frequent Visitor
Frequent Visitor
Posts: 54
Joined: Mon Mar 23, 2009 7:01 pm

Re: Database description packet has different master status

Sat Dec 13, 2014 3:19 am

Same here. :( I bought new ccr1036. I replaced the my old ccr1016. I Just copied the config from one router to another and now this is 5th day, I can not properly work with OSPF.... Tried every single firmware from 6.5 to 6.23 and the issue still exists.
 
orlov
just joined
Posts: 8
Joined: Wed Oct 30, 2013 2:31 pm

Re: Database description packet has different master status flag

Mon Mar 02, 2015 10:33 pm

I believe we are having this problem as well. We run ospf/mpls network with 20 mikrotik routers (ccr, 2011, 951). It all started when we established a wireless p2p link to a remote location. This link was not 100% reliable and keep failing from time to time. That's when we started to get this errors "Database description packet has different master status flag" "state change from Exchange to 2-Way " etc. We have managed to fix this issue for couple of month by moving the entire network from default broadcast ospf type to point-to-point.
But today it happened again - our core router (CCR1036) lost all its ospf connections with all kinds of errors in log, when one of its sfp interfaces had a problem with optical link budget - the device it is connected to showed in log low rx power on sfp interface, link blinked about 10 times and then got back to normal. Rebooting the core router solved the problem (it helped before all the time).
So again, we believe that unreliable links sometimes breaks ospf in a very odd way.
Any help would be greatly appreciated. Thank you.
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: Database description packet has different master status flag

Sun Mar 08, 2015 3:32 am

I think the problem is that on unstable links - one of the ends dont recognise the other ends DD sequence number - and mikrotik have chosen to make an error telling about "database flag" . I think this might actually be a bug


Database Description packets are OSPF packet type 2. These packets are exchanged when an adjacency is being initialized. They describe the contents of the topological database. Multiple packets may be used to describe the database. For this purpose a poll-response procedure is used. One of the routers is designated to be master, the other a slave. The master sends Database Description packets (polls) which are acknowledged by Database Description packets sent by the slave (responses). The responses are linked to the polls via the packets' DD sequence numbers.

0 1 2 3
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Version # | 2 | Packet length |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Router ID |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Area ID |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Checksum | AuType |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Authentication |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Authentication |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| 0 | 0 | Options |0|0|0|0|0|I|M|MS
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| DD sequence number |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| |
+- -+
| A |
+- Link State Advertisement -+
| Header |
+- -+
| |
+- -+
| |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| ... |
The format of the Database Description packet is very similar to both the Link State Request and Link State Acknowledgment packets. The main part of all three is a list of items, each item describing a piece of the topological database. The sending of Database Description Packets is documented in Section 10.8. The reception of Database Description packets is documented in Section 10.6.

0
These fields are reserved. They must be 0.

Options
The optional capabilities supported by the router, as documented in Section A.2.

I-bit
The Init bit. When set to 1, this packet is the first in the sequence of Database Description Packets.

M-bit
The More bit. When set to 1, it indicates that more Database Description Packets are to follow.

MS-bit
The Master/Slave bit. When set to 1, it indicates that the router is the master during the Database Exchange process. Otherwise, the router is the slave.

DD sequence number
Used to sequence the collection of Database Description Packets. The initial value (indicated by the Init bit being set) should be unique. The DD sequence number then increments until the complete database description has been sent.

The rest of the packet consists of a (possibly partial) list of the topological database's pieces. Each link state advertisement in the database is described by its link state advertisement header. The link state advertisement header is documented in Section A.4.1. It contains all the information required to uniquely identify both the advertisement and the advertisement's current instance.
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: Database description packet has different master status flag

Sun Mar 08, 2015 3:34 am

 
cegner
just joined
Posts: 15
Joined: Thu Sep 22, 2005 2:34 pm

Re: Database description packet has different master status flag

Mon Mar 09, 2015 11:13 am

Same problem here - but over reliable ethernet link.
Ticket#2014091666000304
 
vchrizz
just joined
Posts: 11
Joined: Sun Jul 10, 2016 11:07 am
Location: Austria, Vienna
Contact:

Re: Database description packet has different master status flag

Thu Nov 22, 2018 2:22 pm

we had this problem too with ros 6.43.4, but it was on just two links in our network where one connects over ubnt airmax and the other over mikrotik lhg.
interesting is the fact that we use mpls and it looks like ospf has problems, we noticed, mpls ips are not reachable when this error happens, but if you check link-local ips on this link, there never is a packet lost..
so i would not say its ubnt/tik fault at first, first compare your configuration and check that for both sides of the failing link the configuration is really exact same!
generally we could solve this by:
1. find out on which link(s) this is happening, then compare carefully both sides of this link for any differences:
2. the most important, check l2 (wifi) connection, in our case one of the failed link was disturbed a little bit by a new building so we had do move antenna for better sight (and change channel where less noise is).
3. if the link is wireless, try using nbma for ospf. see: https://wiki.mikrotik.com/wiki/Manual:O ... A_networks
4. checking mtu on tik router, then check mtu on ubnt antennas (use tools-ping with packet size you would expect to verify correct mtu is going through, eg for us it is 1500)
5. compare ospf timings (we had different timing on one side, bad typo) - make sure to use "Hello Interval: 10s" and "Router Dead Interval: 40s"
6. compare other protocol settings (as we use mpls, one side propagated mpls ttl, the other not).
7. just to outrule compatibility problems: check if both sides have same mikrotik firmware. check if both sides have same ubnt firmware. (maybe even better try to use same hardware on both sides too)

learning: before crying, triple make sure layer8 (pebkac - or something obvious you didnt think of yet) is not the problem ;)

Who is online

Users browsing this forum: No registered users and 6 guests