Community discussions

MikroTik App
 
Mapik
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 90
Joined: Tue Nov 29, 2005 11:08 am

IGP - BGP aggregation problems 3.30

Tue Sep 22, 2009 12:51 pm

We want to try new IGP routes aggregation in BGP, but with no success. If we look at "/routing bgp advertisements print" routes are agregated OK here (only 3x /24 per peer). But on peering routers there are ALL routes ... both agregates and original .... (about 250x /32 + 1x /27 + 3x /24)

Our configuration is:
/routing bgp instance
set default as=65408 client-to-client-reflection=no comment="" disabled=no ignore-as-path-len=no name=default out-filter=bgp-networks redistribute-connected=yes redistribute-ospf=yes redistribute-other-bgp=no redistribute-rip=no redistribute-static=yes router-id=\
    10.0.18.8
/routing bgp aggregate
add advertise-filter="" attribute-filter="" comment="" disabled=no include-igp=yes inherit-attributes=yes instance=default prefix=172.30.1.0/24 summary-only=yes suppress-filter=""
add advertise-filter="" attribute-filter="" comment="" disabled=no include-igp=yes inherit-attributes=yes instance=default prefix=172.30.101.0/24 summary-only=yes suppress-filter=""
add advertise-filter="" attribute-filter="" comment="" disabled=no include-igp=yes inherit-attributes=yes instance=default prefix=172.30.2.0/24 summary-only=yes suppress-filter=""
/routing bgp peer
add address-families=ip comment="" default-originate=if-installed disabled=no hold-time=3m in-filter="" instance=default multihop=no name=roudnice-esus nexthop-choice=force-self out-filter=to-esus remote-address=XXX remote-as=65400 remove-private-as=no \
    route-reflect=no tcp-md5-key="" ttl=255
add address-families=ip comment="" default-originate=if-installed disabled=no hold-time=3m in-filter="" instance=default multihop=no name=benecko-lugos nexthop-choice=force-self out-filter=to-benecko remote-address=XXX remote-as=65424 remove-private-as=no \
    route-reflect=no tcp-md5-key="" ttl=255
add address-families=ip comment="" default-originate=if-installed disabled=no hold-time=3m in-filter=from-tamesis instance=default multihop=no name=bratrouchov-tamesis nexthop-choice=force-self out-filter=to-tamesis remote-address=XXX remote-as=65432 \
    remove-private-as=no route-reflect=no tcp-md5-key="" ttl=255
Is it some BUG or bad configuration ?

Thank you
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8486
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: IGP - BGP aggregation problems 3.30

Wed Sep 23, 2009 12:46 am

since 'summary-only=yes' - seems like a bug... as a workaround, you may use out-filter to filter masks with length 25-32
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
sdischer
Trainer
Trainer
Posts: 128
Joined: Wed Jan 26, 2005 4:58 pm

Re: IGP - BGP aggregation problems 3.30

Fri Oct 16, 2009 3:51 am

Im seeing the same thing on 3.28. I tried using an out filter and aggregation and it drops the entire network, the aggregate is not being advertised.
Steve Discher
LearnMikroTik.com, USA
RouterOS Training and Consulting
Get Certified!
http://www.LearnMikroTik.com
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8486
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: IGP - BGP aggregation problems 3.30

Fri Oct 16, 2009 1:57 pm

in v3.28, for aggregation to be advertised, you need to have an aggregated route in routing table. either add it statically (with type 'unreachable'), or upgrade to v3.30 - where 'Synchronize' option was returned back to 'Networks' again and should solve your problem.

if not - please post your aggregation and filtering rules
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
sdischer
Trainer
Trainer
Posts: 128
Joined: Wed Jan 26, 2005 4:58 pm

Re: IGP - BGP aggregation problems 3.30

Fri Oct 16, 2009 3:36 pm

Thanks for the tip I will give it a whirl. I found very little documentation and only some really old posts about route aggregation. Even the wiki was lacking any real detail.
Steve Discher
LearnMikroTik.com, USA
RouterOS Training and Consulting
Get Certified!
http://www.LearnMikroTik.com
 
User avatar
sdischer
Trainer
Trainer
Posts: 128
Joined: Wed Jan 26, 2005 4:58 pm

Re: IGP - BGP aggregation problems 3.30

Fri Oct 16, 2009 3:43 pm

You were spot on. With 3.28 I entered a dummy route unreachable for the /22 and filtered the /32's out and it worked fine.

On 3.30:
I used a filter to discard the /32's advertised then used BGP NETWORKS and synchronize setting to push the aggregate out without the dummy route. Thanks for the tips!

steve
Steve Discher
LearnMikroTik.com, USA
RouterOS Training and Consulting
Get Certified!
http://www.LearnMikroTik.com
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8486
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: IGP - BGP aggregation problems 3.30

Fri Oct 16, 2009 4:54 pm

are /32 routes still advertised in 3.30 w/o filtering and with 'summary-only=yes'?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
sdischer
Trainer
Trainer
Posts: 128
Joined: Wed Jan 26, 2005 4:58 pm

Re: IGP - BGP aggregation problems 3.30

Wed Oct 21, 2009 5:32 am

Yep, need filters, that is unless I configured it wrong.

Router C
[admin@RouterC] /routing bgp network> pr
Flags: X - disabled, A - active
# NETWORK SYNCHRONIZE
0 A 208.91.8.0/22 yes

[admin@RouterC] /routing bgp aggregate> pr
Flags: X - disabled
0 instance=default prefix=208.91.8.0/22 summary-only=yes
inherit-attributes=yes attribute-filter="" suppress-filter=""
advertise-filter=""

Router B
[admin@RouterB] /ip route> pr
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC G GATEWAY DISTANCE IN..
4 ADC 10.9.9.2/32 10.9.9.2 0 lo..
5 A S 10.9.9.3/32 r 10.2.2.3 1 et..
6 A S 10.9.9.4/32 r 10.2.2.3 1 et..
9 ADb 208.91.8.0/22 r 10.9.9.3 200 et..
[admin@RouterB] /ip route>

The aggregate is there but so are the /32's...
Steve Discher
LearnMikroTik.com, USA
RouterOS Training and Consulting
Get Certified!
http://www.LearnMikroTik.com

Who is online

Users browsing this forum: babelmonk, Bing [Bot] and 49 guests