Community discussions

MUM Europe 2020
 
User avatar
omidkosari
Trainer
Trainer
Topic Author
Posts: 617
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

VPLS tx error / not Running state

Sat May 29, 2010 2:14 pm

Router1
# may/29/2010 11:57:36 by RouterOS 4.9
# software id = BPHC-897R
#
/mpls
set dynamic-label-range=16-1048575 propagate-ttl=yes
/mpls interface
add comment="" disabled=no interface=all mpls-mtu=1508
/mpls ldp
set distribute-for-default-route=no enabled=yes hop-limit=255 loop-detect=no lsr-id=10.51.116.13 \
    path-vector-limit=255 transport-address=10.51.116.13 use-explicit-null=no
/mpls ldp interface
add accept-dynamic-neighbors=yes comment="" disabled=no hello-interval=5s hold-time=15s interface=\
    ether1 transport-address=0.0.0.0
/interface vpls
add advertised-l2mtu=1500 arp=enabled cisco-style=no cisco-style-id=0 comment="" \
    disable-running-check=no disabled=no l2mtu=1500 mac-address=02:BB:E7:6F:13:FB mtu=1500 name=\
    vpls1 pw-type=raw-ethernet remote-peer=10.51.246.2 vpls-id=100:111
/mpls ldp neighbor print 
Flags: X - disabled, D - dynamic, O - operational, T - sending-targeted-hello, V - vpls 
 #      TRANSPORT       LOCAL-TRANSPORT PEER                       SEND-TARGETED ADDRESSES      
 0 DOTV 10.51.246.2     10.51.116.13    10.51.246.2:0              yes           1.1.1.146      
                                                                                 10.51.246.2    
                                                                                 10.51.246.5    
/interface vpls monitor vpls1 once 
   remote-label: 45
    local-label: 16
  remote-status: 
/interface vpls print             
Flags: X - disabled, R - running, D - dynamic, B - bgp-signaled, C - cisco-bgp-signaled 
 0     name="vpls1" mtu=1500 l2mtu=1500 mac-address=02:BB:E7:6F:13:FB arp=enabled 
       disable-running-check=no remote-peer=10.51.246.2 vpls-id=100:111 cisco-style=no 
       cisco-style-id=0 advertised-l2mtu=1500 pw-type=raw-ethernet 




Router2
# jan/02/1970 04:54:42 by RouterOS 4.9
# software id = V68Y-G2D0
#
/mpls
set dynamic-label-range=16-1048575 propagate-ttl=yes
/mpls interface
add comment="" disabled=no interface=all mpls-mtu=1508
/mpls ldp
set distribute-for-default-route=no enabled=yes hop-limit=255 loop-detect=no \
    lsr-id=10.51.246.2 path-vector-limit=255 transport-address=10.51.246.2 \
    use-explicit-null=no
/mpls ldp interface
add accept-dynamic-neighbors=yes comment="" disabled=no hello-interval=5s \
    hold-time=15s interface=ether1 transport-address=0.0.0.0
/interface vpls
add advertised-l2mtu=1500 arp=enabled cisco-style=no cisco-style-id=0 \
    comment="" disable-running-check=no disabled=no l2mtu=1500 mac-address=\
    02:86:A4:FF:27:57 mtu=1500 name=vpls1 pw-type=raw-ethernet remote-peer=\
    10.51.116.13 vpls-id=100:111
/mpls ldp neighbor print 
Flags: X - disabled, D - dynamic, O - operational, T - sending-targeted-hello, 
V - vpls 
 #      TRANSPORT       LOCAL-TRANSPORT PEER                       SEN
 0 DOTV 10.51.116.13    10.51.246.2     10.51.116.13:0             yes
/interface vpls monitor vpls1 once
   remote-label: 16
    local-label: 45
  remote-status: 
/interface vpls print  
Flags: X - disabled, R - running, D - dynamic, 
B - bgp-signaled, C - cisco-bgp-signaled 
 0     name="vpls1" mtu=1500 l2mtu=1500 mac-address=02:86:A4:FF:27:57 
       arp=enabled disable-running-check=no remote-peer=10.51.116.13 
       vpls-id=100:111 cisco-style=no cisco-style-id=0 advertised-l2mtu=1500 
       pw-type=raw-ethernet 

As you see the state of vpls interface is not running and every packets which should go through vpls , counts Tx error of vpls .
 
User avatar
omidkosari
Trainer
Trainer
Topic Author
Posts: 617
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re: VPLS tx error / not Running state

Sun May 30, 2010 10:05 am

Router1
/ip address print
Flags: X - disabled, I - invalid, D - dynamic 
 #   ADDRESS            NETWORK         BROADCAST       INTERFACE                                                                                       
 0   10.51.116.13/24    10.51.116.0     10.51.116.255   ether1                                                                                          
 1   1.1.1.145/30       1.1.1.144       1.1.1.147       vpls1     
/ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 A S  0.0.0.0/0          10.51.116.13    10.51.116.1        1       
 1 ADC  1.1.1.144/30       1.1.1.145       vpls1              0       
 2 ADC  10.51.116.0/24     10.51.116.13    ether1             0       
/mpls ldp interface print
Flags: X - disabled, I - invalid 
 #   INTERFACE                                                                                                 HELLO-INTERVAL       HOLD-TIME           
 0   ether1                                                                                                    5s                   15s                 

/mpls ldp neighbor print
Flags: X - disabled, D - dynamic, O - operational, T - sending-targeted-hello, V - vpls 
 #      TRANSPORT       LOCAL-TRANSPORT PEER                       SEND-TARGETED ADDRESSES      
 0 DOTV 10.51.246.2     10.51.116.13    10.51.246.2:0              yes           1.1.1.146      
                                                                                 10.51.246.2    
                                                                                 10.51.246.5    
/mpls local-binding print
Flags: X - disabled, A - advertised, D - dynamic, L - local-route, G - gateway-route, e - egress 
 #      DST-ADDRESS        LABEL                                                                                              PEERS                     
 0 ADLe 10.51.116.0/24     impl-null                                                                                          10.51.246.2:0             
 1 ADG  0.0.0.0/0          impl-null                                                                                          10.51.246.2:0             
 2 ADLe 1.1.1.144/30       impl-null                                                                                          10.51.246.2:0            
/mpls remote-binding print
Flags: X - disabled, A - active, D - dynamic 
 #    DST-ADDRESS        NEXTHOP         LABEL                                                                                PEER                      
 0  D 10.51.246.0/30                     impl-null                                                                            10.51.246.2:0             
 1  D 1.1.1.144/30                       impl-null                                                                            10.51.246.2:0             
 2  D 0.0.0.0/0                          impl-null                                                                            10.51.246.2:0             
 3  D 10.51.246.4/30                     impl-null                                                                            10.51.246.2:0             
 4  D 10.0.0.0/8                         84                                                                                   10.51.246.2:0     

Router2
/ip address print
Flags: X - disabled, I - invalid, D - dynamic 
 #   ADDRESS            NETWORK         BROADCAST       INTERFACE                                                                                  
 0   10.51.246.2/30     10.51.246.0     10.51.246.3     ether1                                                                                     
 1   10.51.246.5/30     10.51.246.4     10.51.246.7     ether2                                                                                     
 2   1.1.1.146/30       1.1.1.144       1.1.1.147       vpls1              
/ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 A S  0.0.0.0/0          10.51.246.2     10.51.246.1        1       
 1 ADC  1.1.1.144/30       1.1.1.146       vpls1              0       
 2 A S  10.0.0.0/8         10.51.246.2     10.51.246.1        1       
 3 ADC  10.51.246.0/30     10.51.246.2     ether1             0       
 4 ADC  10.51.246.4/30     10.51.246.5     bridge1     0       
/mpls ldp interface print
Flags: X - disabled, I - invalid 
 #   INTERFACE                                                                                            HELLO-INTERVAL       HOLD-TIME           
 0   ether1                                                                                               5s                   15s             
/mpls ldp neighbor print
Flags: X - disabled, D - dynamic, O - operational, T - sending-targeted-hello, V - vpls 
 #      TRANSPORT       LOCAL-TRANSPORT PEER                       SEND-TARGETED ADDRESSES      
 0 DOTV 10.51.116.13    10.51.246.2     10.51.116.13:0             yes           1.1.1.145      
                                                                                 10.51.116.13   

/mpls local-binding print
Flags: X - disabled, A - advertised, D - dynamic, L - local-route, G - gateway-route, e - egress 
 #      DST-ADDRESS        LABEL                                                                                         PEERS                     
 0 ADLe 10.51.246.0/30     impl-null                                                                                     10.51.116.13:0            
 1 ADLe 1.1.1.144/30       impl-null                                                                                     10.51.116.13:0            
 2 ADG  0.0.0.0/0          impl-null                                                                                     10.51.116.13:0            
 3 ADLe 10.51.246.4/30     impl-null                                                                                     10.51.116.13:0            
 4 ADG  10.0.0.0/8         84                                                                                            10.51.116.13:0       
/mpls remote-binding print
Flags: X - disabled, A - active, D - dynamic 
 #    DST-ADDRESS        NEXTHOP         LABEL                                                                           PEER                      
 0  D 10.51.116.0/24                     impl-null                                                                       10.51.116.13:0            
 1  D 0.0.0.0/0                          impl-null                                                                       10.51.116.13:0            
 2  D 1.1.1.144/30                       impl-null                                                                       10.51.116.13:0      

 
User avatar
omidkosari
Trainer
Trainer
Topic Author
Posts: 617
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re: VPLS tx error / not Running state

Mon May 31, 2010 10:30 am

Any idea ? Does informations incomplete ?
 
User avatar
omidkosari
Trainer
Trainer
Topic Author
Posts: 617
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re: VPLS tx error / not Running state

Tue Jun 01, 2010 9:53 am

Bump
 
User avatar
omidkosari
Trainer
Trainer
Topic Author
Posts: 617
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re: VPLS tx error / not Running state

Wed Jun 02, 2010 8:47 am

Is it so hard problem ? anybody heard something about VPLS ? :-x
 
Mplsguy
MikroTik Support
MikroTik Support
Posts: 226
Joined: Fri Jun 06, 2008 5:06 pm

Re: VPLS tx error / not Running state

Wed Jun 02, 2010 4:16 pm

From your config I understand that your VPLS endpoints are not on the same subnet (are not directly connected). In order for such a tunnel to work you need MPLS LSP between both endpoints that would transport VPLS packets. There clearly is no such LSP in your setup, because the only LDP neighbour you have is remote VPLS peer. So as minimum you must enable LDP on all routers between VPLS endpoints.

I suggest you carefully study MPLS/VPLS related docs here:
http://wiki.mikrotik.com/wiki/MPLS
 
anpena
just joined
Posts: 15
Joined: Wed Apr 29, 2009 5:46 am

Re: VPLS tx error / not Running state

Thu Jul 12, 2012 4:47 pm

Hello Mplsguy

Just want to ask similar question related with this configuration reported above, In my understanding is possible to transport VPLS using BGP and L2vpn to transport the VPLS information and create dynamic VPLS tunnels, in the above scenario where network is not continuos and crossing multiple IP backbone routers Non-MPLS could be possible to set such VPLS and have it running state? I tried such configuration, have VPLS Tunnels stablished dynamically created and BGP signaled but not running state as well; there is anyway to make this works over the IP backbone? I know this RFC4364 mentioned the possibility and I know Mikrotik support it.

I followed below instructions where LDP is no needed because BGP L2VPN family does the transport:
http://wiki.mikrotik.com/wiki/BGP_based_VPLS

Thank you!

Who is online

Users browsing this forum: No registered users and 10 guests