Community discussions

 
bda
Member Candidate
Member Candidate
Topic Author
Posts: 126
Joined: Fri Sep 03, 2010 11:07 am
Location: Russia,Moscow

ijecting local generated routes to some vrf [solved]

Fri Sep 03, 2010 11:35 am

Need help.
The situation is: I cannot install local generated routes in some vrf, if this vrf is advertised to bgp-ce peer. Routes form that peer are successfully installed to target vrf, but my routes does not.

The CE-router is cisco 2801 router this simply config and no input filter. The Cisco debug says that no incomicg updates with routing onformation. So we have 0 prefixes in session with MT-router on Cisco side.

The MT-config is:
/routing bgp instance
set default as=65000 client-to-client-reflection=yes comment=DEFAULT-instance disabled=no ignore-as-path-len=no name=\
    default out-filter="" redistribute-connected=no redistribute-ospf=no redistribute-other-bgp=no redistribute-rip=no \
    redistribute-static=no router-id=0.0.0.0 routing-table=""
add as=65003 client-to-client-reflection=yes disabled=no ignore-as-path-len=no name=AS65003-LAB out-filter="" \
    redistribute-connected=no redistribute-ospf=no redistribute-other-bgp=no redistribute-rip=no redistribute-static=no \
    router-id=10.2.0.1 routing-table=vrf-lab
/routing bgp instance vrf
add disabled=no in-filter="" instance=default out-filter="" redistribute-connected=yes redistribute-ospf=no \
    redistribute-other-bgp=yes redistribute-rip=no redistribute-static=yes routing-mark=vrf-lab
/routing bgp peer
add address-families=ip as-override=no default-originate=never disabled=no hold-time=3m in-filter="" instance=AS65003-LAB \
    interface=ether1.501 max-prefix-limit=100 multihop=yes name=rtr11 nexthop-choice=default out-filter=as65003-out \
    passive=no remote-address=10.0.2.1 remote-as=65002 remove-private-as=no route-reflect=no tcp-md5-key="" ttl=default \
    update-source=ether1.501 use-bfd=no
add address-families=ip as-override=no default-originate=never disabled=yes hold-time=3m in-filter="" instance=AS65003-LAB \
    interface=ether1.502 max-prefix-limit=100 multihop=yes name=rtr12 nexthop-choice=default out-filter=as65003-out \
    passive=no remote-address=10.0.5.1 remote-as=65002 remove-private-as=no route-reflect=no tcp-md5-key="" ttl=default \
    update-source=ether1.502 use-bfd=no
add address-families=ip as-override=no default-originate=never disabled=yes hold-time=3m in-filter="" instance=AS65003-LAB \
    interface=ether1.503 max-prefix-limit=100 multihop=yes name=rtr02 nexthop-choice=default out-filter=as65003-out \
    passive=no remote-address=10.1.4.1 remote-as=65001 remove-private-as=no route-reflect=no tcp-md5-key="" ttl=default \
    update-source=ether1.503 use-bfd=no
[bda@rtr22] > ip address print 
Flags: X - disabled, I - invalid, D - dynamic 
 #   ADDRESS            NETWORK         BROADCAST       INTERFACE                                                            
 0   10.13.28.160/26    10.13.28.128    10.13.28.191    ether2.34                                                            
 1   10.0.2.3/24        10.0.2.0        10.0.2.255      ether1.501                                                           
 2   10.0.5.3/24        10.0.5.0        10.0.5.255      ether1.502                                                           
 3   10.1.4.3/24        10.1.4.0        10.1.4.255      ether1.503                                                           
 4   10.13.28.170/32    10.13.28.170    10.13.28.170    lobr10                                                               
 5   10.2.0.1/32        10.2.0.1        10.2.0.1        lobr10-02                                                            
 6   10.100.100.1/32    10.100.100.1    10.100.100.1    lobr10-100-100                                                       
 7   10.100.150.1/32    10.100.150.1    10.100.150.1    lobr10-100-150                                                       
 8   10.100.200.1/32    10.100.200.1    10.100.200.1    lobr10-100-200                                                       
 9   10.100.250.1/32    10.100.250.1    10.100.250.1    lobr10-100-250        
Last edited by bda on Sat Sep 04, 2010 8:47 am, edited 1 time in total.
God bless UNIX!
 
User avatar
Eising
Member Candidate
Member Candidate
Posts: 272
Joined: Mon Oct 27, 2008 10:21 am
Location: Copenhagen, Denmark

Re: ijecting local generated routes to some vrf

Fri Sep 03, 2010 12:05 pm

Could you paste the configuration from /ip route vrf export?
The road to hell is paved with good intentions.
 
bda
Member Candidate
Member Candidate
Topic Author
Posts: 126
Joined: Fri Sep 03, 2010 11:07 am
Location: Russia,Moscow

Re: ijecting local generated routes to some vrf

Sat Sep 04, 2010 8:44 am

I've track an error! Thanks. The problem was in absence static redistribution in vrf configuration.
God bless UNIX!

Who is online

Users browsing this forum: No registered users and 10 guests