Community discussions

MikroTik App
 
Cris@usai.net
newbie
Topic Author
Posts: 34
Joined: Fri Jun 17, 2005 8:25 pm

BGP Peer-groups with Cisco

Wed May 18, 2011 11:13 pm

Is their a way to setup peering groups like in cisco's?
Below is what I usually have setup in my cisco routers.

neighbor ibgp peer-group
neighbor ibgp remote-as 11111
neighbor ibgp update-source Loopback0
neighbor ibgp send-community
neighbor ibgp route-map internal-only out
neighbor ibgpfull peer-group
neighbor ibgpfull remote-as 11111
neighbor ibgpfull update-source Loopback0
neighbor ibgpfull next-hop-self
neighbor ibgpfull send-community
neighbor ibgpfull default-originate

neighbor 192.168.1.10 peer-group ibgp
neighbor 192.168.1.10 description PEER1
neighbor 192.168.1.10 password 7 lakjdalskdjalsdkjaslkdjasl
 
blake
Member
Member
Posts: 426
Joined: Mon May 31, 2010 10:46 pm
Location: Arizona

Re: BGP Peer-groups with Cisco

Thu May 19, 2011 2:19 am

Syntactically there is no equivalent in MikroTik. If you at least want to create peers with a standard config you could probably do something like this.
/routing bgp peer

# Templates
add disabled=yes remote-address=127.0.0.1 remote-as=11111 update-source=loopback0 name=ibgp-template out-filter=internal-only
add disabled=yes remote-address=127.0.0.1 remote-as=11111 update-source=loopback0 name=ibgp-template-full default-originate=if-installed nexthop-choice=force-self

# Peer creation
add copy-from=ibgp-template disabled=no remote-address=192.168.1.10 password="lakjdalskdjalsdkjaslkdjasl" comment="peer1"
This only helps with peer creation. You will not be able to modify the template and have the changes propagate to the peers.

Performance wise, Cisco peer groups have been superseded by BGP Dynamic Update Peer-Groups. Cisco recommends using peer templates to group configs. Regarding MikroTik BGP performance, I'm not sure if it uses a method like Dynamic Peer Groups. Someone from MT can probably comment.
IT consultant. Network manager. Packet junkie.
1-928-328-1509
 
sophal
newbie
Posts: 34
Joined: Thu Aug 07, 2008 6:09 am
Location: Cambodia

Re: BGP Peer-groups with Cisco

Fri May 27, 2011 6:04 am

i have problem too, my upstream complain error from Mikrotik BGP below:

May 25 10:55:19 HCM-MP05 rpd[1816]: bgp_nexthop_sanity: peer x.x.x.x (External AS xxxx) next hop x.x.x.x unexpectedly remote, ignoring routes in this update
May 25 10:03:55.760847 BGP RECV x.x.x.x+179 -> x.x.x.x+49829
May 25 10:03:55.760879 BGP RECV message type 2 (Update) length 95
May 25 10:03:55.760885 BGP RECV Update PDU length 95
May 25 10:03:55.760891 BGP RECV flags 0x40 code Origin(1): IGP
May 25 10:03:55.760904 BGP RECV flags 0x40 code ASPath(2) length 54: 38579 38579 38579 17726 9304 6453 3257 12880 12880 12880 12880 12880 197343
May 25 10:03:55.760910 BGP RECV flags 0x40 code NextHop(3): x.x.x.x
May 25 10:03:55.760922 BGP RECV 178.239.144.0/20
May 25 10:03:55.761384 bgp_nexthop_sanity: peer x.x.x.x (External AS xxxx) next hop 203.223.36.173 unexpectedly remote, ignoring routes in this update
May 25 10:03:55.761408 bgp_rcv_nlri: x.x.x.x/20
May 25 10:03:55.761431 bgp_read_v4_message: done with x.x.x.x (External AS xxxx) received 95 octets 1 update 1 route


what is problem cisco and mikrotik?
Regards
Lor Sophal
lor.sophal@gmail.com
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: BGP Peer-groups with Cisco

Fri May 27, 2011 6:10 am

That isn't output from a Cisco router, that is output from a Juniper. It's ignoring updates because they aren't sane, either because the next hop advertised isn't resolvable, or because it is listed as a next hop itself.
Specific answers require specific questions. When in doubt, post the output of "/ip address print detail", "/ip route print detail", "/interface print detail", "/ip firewall export", and an accurate network diagram.
 
sophal
newbie
Posts: 34
Joined: Thu Aug 07, 2008 6:09 am
Location: Cambodia

Re: BGP Peer-groups with Cisco

Thu Jun 02, 2011 9:53 am

Thanks fewi,

The problem error message to upstream cus I'm do iBGP and eBGP.
Problem on iBGP i take enable route-reflect=yes in peering to local game online just change back
route-reflect=no now my upstream no more get error message from BGP mikrotik.
Regards
Lor Sophal
lor.sophal@gmail.com

Who is online

Users browsing this forum: Google [Bot] and 15 guests