Page 1 of 1

3G problems

Posted: Mon Nov 28, 2011 2:29 pm
by saintofinternet
hi,
**********************************************************************
ip route print
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0 ADS 0.0.0.0/0 10.112.112.118 1
1 ADC 10.0.0.0/8 10.10.1.201 ether1 0
2 ADC 10.112.112.118/32 112.110.184.231 ppp-out1 0
**********************************************************************
ip address print
Flags: X - disabled, I - invalid, D - dynamic
# ADDRESS NETWORK INTERFACE
0 D 112.110.184.231/32 10.112.112.118 ppp-out1
1 10.10.1.201/8 10.0.0.0 ether1
**********************************************************************
above i have given print out of the status of my routeros after connecting to the internet over a 3G HSPDA stick.

i can ping the internet website from terminal window in Winbox. but when i try to access the internet over laptop connected via ethernet i just cannot.

help appreciated....

Re: 3G problems

Posted: Mon Nov 28, 2011 6:11 pm
by saintofinternet
anyone out there who can help me??

Re: 3G problems

Posted: Mon Nov 28, 2011 6:23 pm
by dasiu
1. Is it ether1 or another? You need IP config on the ether interface :). Can the computer ping MikroTik? Is MikroTik the default gateway for the computer? Does tracert from computer show first step as MikroTik - and then (steps 2 and following) nothing?
2. You need to have masquerading (/ip firewall nat) on out-interface=ppp-out1
3. Maybe you need to modify each forwarded IP packet adding +1 to TTL (in /ip firewall mangle) :).

That should be it :).

Re: 3G problems

Posted: Mon Nov 28, 2011 7:05 pm
by saintofinternet
will NAT help or Static Routes help?

anywhere on forum where i can read about this 3G USB data forwarding to Ether1 and WLAN1 ??

Re: 3G problems

Posted: Mon Nov 28, 2011 9:16 pm
by dasiu
will NAT help or Static Routes help?

anywhere on forum where i can read about this 3G USB data forwarding to Ether1 and WLAN1 ??
Have you read my last post? Well, I will try to put it in simple words. Just add:
/ip firewall nat add chain=srcnat action=masquerade out-interface=ppp-out1

Re: 3G problems

Posted: Tue Nov 29, 2011 5:28 am
by saintofinternet
tried it but still not working... :(

following are my settings....
error.png

Re: 3G problems

Posted: Tue Nov 29, 2011 11:44 am
by saintofinternet
normis.... yelp!!!

Re: 3G problems

Posted: Tue Nov 29, 2011 1:32 pm
by saintofinternet
these are my settings below....

*******************************************************************
*******************************************************************
[admin@MikroTik] > ip route print
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0 ADS 0.0.0.0/0 10.112.112.123 1
1 ADC 10.112.112.123/32 27.97.194.251 ppp-out1 0
2 ADC 192.0.0.0/8 192.168.1.10 ether1 0
*******************************************************************
*******************************************************************
[admin@MikroTik] > ip address print
Flags: X - disabled, I - invalid, D - dynamic
# ADDRESS NETWORK INTERFACE
0 192.168.1.10/8 192.0.0.0 ether1
1 D 27.97.194.251/32 10.112.112.123 ppp-out1
*******************************************************************
*******************************************************************
[admin@MikroTik] > ip firewall nat print
Flags: X - disabled, I - invalid, D - dynamic
0 chain=srcnat action=masquerade out-interface=ppp-out1
*******************************************************************
*******************************************************************
still not working :(

although i can ping any website from the Winbox Terminal window.... i cannot browse or ping from the laptop connected to this Routerboard on Ether1.

Laptop IP Config

IP: 192.168.1.1
Subnet: 255.0.0.0
Gateway: 192.168.1.10
DNS: 192.168.1.10

[flash=]HELP!!!!![/flash]