Page 1 of 1

Help with OSPF

Posted: Tue Feb 21, 2012 1:36 am
by SenorJJ
Help please.

I have a network of approx 30 mikrotik routers.

The main core router advertises BGP and routes ospf.

I have ospf set to type 2 on all routers but unless I add a default route on each router I cannot route past the BGP gateway. Then if I do that and a link goes down it won't route the other way.

BGP set to redistribute connected
OSPF set to redistribute default, connected, static and other ospf. All as type 2.

I must be missing something.

Re: Help with OSPF

Posted: Tue Feb 21, 2012 10:43 am
by dasiu
BGP with "redistribute connected"?? wow...

Could you show us the "/routing export" output from the core router? It will cover the BGP, OSPF and filters configuration - and will show us what is the configuration idea and what can be missing :).

Re: Help with OSPF

Posted: Wed Feb 22, 2012 1:23 am
by SenorJJ
Hi, thanks for getting back to me.

/routing bgp instance
set default as=65530 client-to-client-reflection=no disabled=no \
ignore-as-path-len=no name=default out-filter="" redistribute-connected=no \
redistribute-ospf=no redistribute-other-bgp=no redistribute-rip=no \
redistribute-static=no router-id=0.0.0.0 routing-table=""
add as=***** client-to-client-reflection=yes disabled=no ignore-as-path-len=no \
name="BL - VM" out-filter="" redistribute-connected=yes \
redistribute-ospf=no redistribute-other-bgp=no redistribute-rip=no \
redistribute-static=no router-id=94.***.***.*** routing-table=""
/routing ospf instance
set default disabled=no distribute-default=always-as-type-2 in-filter=ospf-in \
metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=auto \
metric-rip=20 metric-static=20 name=default out-filter=ospf-out \
redistribute-bgp=no redistribute-connected=as-type-2 \
redistribute-other-ospf=as-type-2 redistribute-rip=no redistribute-static=\
as-type-2 router-id=0.0.0.0
/routing ospf area
set backbone area-id=0.0.0.0 disabled=no instance=default name=backbone type=\
default
/routing ospf-v3 instance
set default disabled=no distribute-default=never metric-bgp=auto \
metric-connected=20 metric-default=1 metric-other-ospf=auto metric-rip=20 \
metric-static=20 name=default redistribute-bgp=no redistribute-connected=no \
redistribute-other-ospf=no redistribute-rip=no redistribute-static=no \
router-id=0.0.0.0
/routing ospf-v3 area
set backbone area-id=0.0.0.0 disabled=no instance=default name=backbone type=\
default
/routing bfd interface
set all disabled=no interface=all interval=0.2sec min-rx=0.2sec multiplier=5
/routing bgp network
add disabled=no network=***.***.***.0/21 synchronize=yes
/routing bgp peer
add address-families=ip as-override=no default-originate=always disabled=no \
hold-time=infinity in-filter="" instance="BL - VM" multihop=no \
name="Virgin Media" nexthop-choice=default out-filter="" passive=no \
remote-address=94.***.***.*** remote-as=**** remove-private-as=no \
route-reflect=no tcp-md5-key="" ttl=default update-source=VM use-bfd=no
/routing mme
set bidirectional-timeout=2 gateway-class=none gateway-keepalive=1m \
gateway-selection=no-gateway origination-interval=5s preferred-gateway=\
0.0.0.0 timeout=1m ttl=50
/routing ospf interface
add authentication=md5 authentication-key=******** authentication-key-id=2 \
cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 \
interface=all network-type=broadcast passive=no priority=1 \
retransmit-interval=5s transmit-delay=1s use-bfd=no
/routing ospf network
add area=backbone disabled=no network=0.0.0.0/0
/routing rip
set distribute-default=never garbage-timer=2m metric-bgp=1 metric-connected=1 \
metric-default=1 metric-ospf=1 metric-static=1 redistribute-bgp=no \
redistribute-connected=no redistribute-ospf=no redistribute-static=no \
routing-table=main timeout-timer=3m update-timer=30s
/routing ripng
set distribute-default=never garbage-timer=2m metric-bgp=1 metric-connected=1 \
metric-default=1 metric-ospf=1 metric-static=1 redistribute-bgp=no \
redistribute-connected=no redistribute-ospf=no redistribute-static=no \
timeout-timer=3m update-timer=30s

Re: Help with OSPF

Posted: Thu Feb 23, 2012 11:59 am
by dasiu
Try changing default-distribute on every router to "if-installed-as-type-1" and remove all static routes to 0.0.0.0/0 :). Then check if it works. With "if-installed" router will not advertise a route it doesn't have, and with "type 1" the distance will change with every single hop - so the best path (shortest total distance) will be selected.
If it works - it's fine.
If not - then start debugging. Check a router, which cannot connect to the internet, try using "traceroute" to determine, where the packets go and where they are lost. Then check "ip route" on the router that "looses" the packets, or makes a loop, or whatever - and check what route to 0.0.0.0/0 it has (and what distance it has).
And - of course - let us know! :)

And I still don't understand, why "redistribute connected" to BGP... :)