Community discussions

MUM Europe 2020
 
User avatar
mistiq
newbie
Topic Author
Posts: 37
Joined: Wed Oct 19, 2011 3:13 am
Location: Outside

Problem with OSPF injecting to internal area.

Wed Apr 25, 2012 6:54 am

I have a next scheme - See attached picture:

Image

In scheme i have 2 OSPF Area which connected over IPIP Tunnel And OSFP Backbone.

Each Mikrotik router have own ISP connection.

RA-RB and RA1-RB1 is Mikrotik RB1100AHx2 (ROS 5.14)
RC - cisco 4948 cat4500-entservicesk9-mz.122-50.SG1.bin
RC1 - cisco 3550 c3550-ipservicesk9-mz.122-44.SE6.bin

OSPF configuration:

RA:
 > routing ospf area print detail 
Flags: X - disabled, I - invalid, * - default 
 0  * name="backbone" instance=default type=default area-id=0.0.0.0 

 1    name="VL" instance=VL type=default area-id=10.0.1.0
===================================

> routing ospf interface print detail
Flags: X - disabled, I - inactive, D - dynamic, P - passive 
 0    interface=vlan_66_mgm cost=10 priority=255 authentication=none authentication-key="" authentication-key-id=1 network-type=broadcast instance-id=0 retransmit-interval=5s transmit-delay=1s 
      hello-interval=5s dead-interval=10s use-bfd=no 

 2    interface=ether2 cost=10 priority=255 authentication=none authentication-key="" authentication-key-id=1 network-type=broadcast instance-id=0 retransmit-interval=5s transmit-delay=1s hello-interval=5s 
      dead-interval=10s use-bfd=yes 

 5    interface=ipip_vladlink_msk00_mastertel cost=40 priority=255 authentication=md5 authentication-key="109" authentication-key-id=1 network-type=point-to-point instance-id=0 retransmit-interval=5s 
      transmit-delay=1s hello-interval=5s dead-interval=10s use-bfd=no 
==================================

> routing ospf instance print detail
Flags: X - disabled, * - default 
 0  * name="default" router-id=255.255.255.1 distribute-default=never redistribute-connected=no redistribute-static=no redistribute-rip=no redistribute-bgp=no redistribute-other-ospf=as-type-2 metric-default=1 
      metric-connected=20 metric-static=20 metric-rip=20 metric-bgp=auto metric-other-ospf=auto in-filter=ospf-in out-filter=DNS-OUT 

 1    name="VL" router-id=200.0.3.1 distribute-default=if-installed-as-type-1 redistribute-connected=no redistribute-static=no redistribute-rip=no redistribute-bgp=no redistribute-other-ospf=as-type-1 
      metric-default=2 metric-connected=20 metric-static=20 metric-rip=20 metric-bgp=auto metric-other-ospf=auto in-filter="" out-filter=""


================================

> routing ospf network print detail
Flags: X - disabled, I - invalid 
 0   network=172.20.3.96/30 area=VL (Transit MT-Cisco vlan_66)   

 2   network=172.20.3.104/30 area=VL (Transit MT-MT ether2)

 5   ;;; Backbone Network MSK
     network=172.23.0.0/30 area=backbone
================================

> routing filter print detail
Flags: X - disabled 
 0   chain=DNS-OUT prefix=10.0.0.0/19 invert-match=no action=accept set-bgp-prepend-path="" 

 1   chain=DNS-OUT prefix=172.20.0.0/19 invert-match=no action=accept set-bgp-prepend-path="" 

 2   chain=DNS-OUT invert-match=no action=discard set-bgp-prepend-path="" 
Another Mikrotik routers have same mirrored configurations (excluded OSPF RID AID etc)!!

===============================

Cisco 4948:
interface Vlan66
 description # MGM 1 VLAN #
 ip address 172.20.3.98 255.255.255.252
 ip ospf cost 10
 ip ospf hello-interval 5
 ip ospf dead-interval 10
 ip ospf priority 50
!
interface Vlan67
 description # MGM 2 VLAN #
 ip address 172.20.3.102 255.255.255.252
 ip ospf cost 10
 ip ospf hello-interval 5
 ip ospf dead-interval 10
 ip ospf priority 50
!
router ospf 100
 router-id 172.20.3.98
 log-adjacency-changes
 redistribute connected subnets
 redistribute static subnets
 network 172.20.3.96 0.0.0.3 area 10.0.1.0
 network 172.20.3.100 0.0.0.3 area 10.0.1.0

ip route 10.0.0.0 255.255.224.0 Null0 254
ip route 172.20.0.0 255.255.224.0 Null0 254
===============================

So when i bring up both of tunnel, i see very strange routing tables on mikrotik routers. For examle:

On RA:

> ip route print detail
29 ADo  dst-address=10.3.0.0/19 gateway=172.23.0.2 gateway-status=172.23.0.2 reachable via  ipip_vladlink_msk00_mastertel distance=110 scope=20 target-scope=10 ospf-metric=50 ospf-type=external-type-1
88 ADo  dst-address=172.23.0.0/19 gateway=172.23.0.2 gateway-status=172.23.0.2 reachable via  ipip_vladlink_msk00_mastertel distance=110 scope=20 target-scope=10 ospf-metric=50 ospf-type=external-type-1 
==========================================

> routing ospf print detail
27 instance=VL dst-address=10.3.0.0/19 state=imported-ext-1 gateway="" interface="" cost=50 area=external
82 instance=VL dst-address=172.23.0.0/19 state=imported-ext-1 gateway="" interface="" cost=50 area=external
94 instance=default dst-address=10.3.0.0/19 state=ext-1 gateway=172.23.0.2 interface=ipip_vladlink_msk00_mastertel cost=50 area=external
98 instance=default dst-address=172.23.0.0/19 state=ext-1 gateway=172.23.0.2 interface=ipip_vladlink_msk00_mastertel cost=50 area=external
99 instance=default dst-address=172.23.0.0/30 state=intra-area gateway=0.0.0.0 interface=ipip_vladlink_msk00_mastertel cost=40 area=backbone
Possible it is correct FIB
=========================================

On RB:
> ip route print detail
29 ADo  dst-address=10.3.0.0/19 gateway=172.20.3.105 gateway-status=172.20.3.105 reachable via  ether2 distance=110 scope=20 target-scope=10 ospf-metric=60 ospf-type=external-type-1 
30  Do  dst-address=10.3.0.0/19 gateway=172.23.0.6 gateway-status=172.23.0.6 reachable via  ipip_vladlink_temp_msk00_centertel distance=110 scope=20 target-scope=10 ospf-metric=20 ospf-type=external-type-1 
89 ADo  dst-address=172.23.0.0/19 gateway=172.23.0.6 gateway-status=172.23.0.6 reachable via  ipip_vladlink_temp_msk00_centertel distance=110 scope=20 target-scope=10 ospf-metric=20 ospf-type=external-type-1
==========================================

> routing ospf print detail
34 instance=VL dst-address=10.3.0.0/19 state=ext-1 gateway=172.20.3.105 interface=ether2 cost=60 area=external 
89 instance=VL dst-address=172.23.0.0/19 state=imported-ext-1 gateway="" interface="" cost=20 area=external
1 instance=default dst-address=10.3.0.0/19 state=ext-1 gateway=172.23.0.6 interface=ipip_vladlink_temp_msk00_centertel cost=20 area=external
5 instance=default dst-address=172.23.0.0/19 state=ext-1 gateway=172.23.0.6 interface=ipip_vladlink_temp_msk00_centertel cost=20 area=external
1) RB takes two route to 10.3.0.0/19 from other sources (Over TunB and contiguous ether2 interface). First route have metric 60 (ospf cost 60), second - metric 20 (ospf cost 60).
But both of routes are installed to FIB (!!!) and RB send packet to 10.3.0.0/19 over ether2. I think it is not correct behavior.

2)Route to 172.23.0.0/19 have cost=20 in instance=VL and i can not see this route received from backbone.

I try inject external route to internal area with option "other ospf metric = 40" from RA and "other ospf metric = 10" from RB and get same results.
K.i.s.S.

Who is online

Users browsing this forum: No registered users and 11 guests