Community discussions

MUM Europe 2020
 
braidiano
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 85
Joined: Sat Dec 11, 2010 1:29 am

[SOLVED] OSPF and strange locally generated route

Mon May 07, 2012 5:54 pm

hi,

I have this OSPF configuration:
/routing ospf instance
set [ find default=yes ] disabled=no distribute-default=never in-filter=ospf-in metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=auto metric-rip=20 \
    metric-static=20 name=default out-filter=ospf-out redistribute-bgp=no redistribute-connected=as-type-1 redistribute-other-ospf=no redistribute-rip=no \
    redistribute-static=as-type-1 router-id=10.250.1.1
/routing ospf area
set [ find default=yes ] area-id=0.0.0.0 disabled=no instance=default name=backbone type=default
add area-id=0.0.0.1 disabled=no instance=default name=pppoe-area type=default
/routing ospf area range
add advertise=no area=pppoe-area cost=calculated disabled=no range=178.xx.xx.128/25
/routing ospf interface
add authentication=none authentication-key="" authentication-key-id=1 cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=ether6-ptp-A \
    network-type=broadcast passive=no priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=none authentication-key="" authentication-key-id=1 cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=all network-type=\
    default passive=yes priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=none authentication-key="" authentication-key-id=1 cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=ether7-ptp-B \
    network-type=broadcast passive=no priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
/routing ospf network
add area=pppoe-area disabled=no network=178.xx.xx.128/25
add area=backbone  disabled=no network=172.23.0.4/30
add area=backbone  disabled=no network=172.23.0.8/29
I configured the pppoe-area and the area rage to summarize the public network 178.xx.xx.128/25 and not distribute all the /32 pppoe client routes to the backbone area.

But i have a dynamic ospf unreacheable route generated on the same router locally:
[admin@XXXXX] > /ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE

[...]

18  DoU 178.xx.xx.128/25                                           109

[...]
why is there this route and how can I remove it?
Last edited by braidiano on Thu May 10, 2012 1:16 pm, edited 1 time in total.
 
braidiano
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 85
Joined: Sat Dec 11, 2010 1:29 am

Re: OSPF and strange locally generated route

Thu May 10, 2012 1:16 pm

solved using this filter:
/routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix=178.xx.xx.128/25 protocol=\
    ospf set-bgp-prepend-path="

Who is online

Users browsing this forum: No registered users and 3 guests