Community discussions

MikroTik App
 
Sourav
just joined
Topic Author
Posts: 10
Joined: Mon Sep 24, 2012 1:41 pm
Location: Bangladesh

Problem with giving public IP

Mon Sep 24, 2012 2:09 pm

How Cani Do this? Please Help me with command details.
You do not have the required permissions to view the files attached to this post.
 
sabueso
just joined
Posts: 3
Joined: Mon Mar 14, 2011 1:49 pm

Re: Problem with giving public IP

Mon Oct 01, 2012 2:31 am

L2TP to the RB450 ? ;)
 
MikroTikIQ
Trainer
Trainer
Posts: 44
Joined: Sat Jun 16, 2012 1:42 pm

Re: Problem with giving public IP

Tue Oct 02, 2012 11:09 pm

Hi..

At this case there is several thing need to take in consider..

If the customer have its own IP range.. mean its should be routed some how... from internet to your network..

BGP connection need to be established between you and you customer ..

Also you should have BGP connection with at least one ISP..

And then you need to advertise you customer ip address to the internet..

Please let me know if all are clear..

If you would like to have some more help in configuration just need more info about

-Your ASN number
-your IP range
-Customer ASN number
-Customer IP range

Also you need to have some access to IR like RIPE.. to create new route object

Best regards
Ali Sami
__________________
MikroTik trainer
 
User avatar
satman1w
Member Candidate
Member Candidate
Posts: 128
Joined: Mon Oct 02, 2006 11:47 am
Location: Croatia

Re: Problem with giving public IP

Wed Oct 03, 2012 12:23 pm

How Can I Do this? Please Help me with command details.
You can src-nat user's private address (ports 0-65535) to one public address (ports 0-65535) and dst-nat the same address back to his private address.
Customer will be accessible by the public address and all his outgoing traffic will be "signed" by the same address.

I have just tried it on my test router and it works perfectly
add action=dst-nat chain=dstnat disabled=no dst-address="public IP" dst-port=0-65535 port="" protocol=tcp src-port="" to-addresses="private IP" to-ports=0-65535
add action=src-nat chain=srcnat disabled=no dst-port=0-65535 protocol=tcp src-address="private IP" to-addresses="public IP" to-ports=0-65535
Does this solve your problem?

Regards

Who is online

Users browsing this forum: No registered users and 40 guests