Community discussions

 
User avatar
mrz
MikroTik Support
MikroTik Support
Topic Author
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

BGP and routing filter improvement suggestions

Wed Oct 03, 2012 6:21 pm

Please post any missing BGP and Routing filter functionality or new features that you would like to see in future routing implementations.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1819
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: BGP and routing filter improvement suggestions

Wed Oct 03, 2012 9:24 pm

I would like to see VRF's working better.
At the moment when you add a loopback bridge to a vrf, you are still able to ping the ip of that bridge from the main table on that router.

Also. Being able to use services inside a vrf e.g. PPP/ssh/telnet/winbox/btest/dns

Oh and the ability in a routing filter to send received/sent prefixes to an address list
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
ambo
just joined
Posts: 5
Joined: Wed Oct 22, 2008 9:50 am

Re: BGP and routing filter improvement suggestions

Thu Oct 04, 2012 10:25 am

We have regular issues where IPv4 and IPv6 BGP announces are withdrawn on once side of the network but the Mikrotik continues to onward announce the prefix on the other side of the network and forward traffic over the withdrawn path. I fix for that is important.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1819
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: BGP and routing filter improvement suggestions

Thu Oct 04, 2012 11:07 am

We have regular issues where IPv4 and IPv6 BGP announces are withdrawn on once side of the network but the Mikrotik continues to onward announce the prefix on the other side of the network and forward traffic over the withdrawn path. I fix for that is important.
This is a common fault. We also experience it regularly. I believe Mikrotik are going to fix this in the new routing (was told this in an response to a support ticket)
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
mrz
MikroTik Support
MikroTik Support
Topic Author
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: BGP and routing filter improvement suggestions

Thu Oct 04, 2012 11:08 am

All existing problems will be addressed. Please list improvements that are currently missing and you would like to see.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1819
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: BGP and routing filter improvement suggestions

Thu Oct 04, 2012 12:59 pm

In that case:
The ability in a routing filter to send received/sent prefixes to an address list
The ability in Winbox/CLI to see all prefixes received from a peer, that also indicates the last filter policy they passed through, and if they have been inserted in to the routing table, and if so which one. This will allow you to easily see prefixes that were received but blocked by a filter, and identify which filter it was. Or, which filter allowed a prefix that you want to block. You can then adjust that filter.

BGP Peer Groups would be good too. When you have say 10 peers with common settings, the only thing thats different is the peer IP and remote AS, have them belong to a parent group that defines all the other settings, then when you need to change a setting you only need to change it in one place instead of 10.


:)
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
eflanery
Member
Member
Posts: 382
Joined: Fri May 28, 2004 10:11 pm
Location: Moscow, ID
Contact:

Re: BGP and routing filter improvement suggestions

Fri Oct 05, 2012 6:15 pm

In that case:

BGP Peer Groups would be good too. When you have say 10 peers with common settings, the only thing thats different is the peer IP and remote AS, have them belong to a parent group that defines all the other settings, then when you need to change a setting you only need to change it in one place instead of 10.


:)
+1

My reflectors have >200 sessions configured, identical in all respects except for the peer address. Any simplification of that would be welcome.

--Eric
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1819
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: BGP and routing filter improvement suggestions

Sat Oct 06, 2012 12:44 am


+1

My reflectors have >200 sessions configured, identical in all respects except for the peer address. Any simplification of that would be welcome.

--Eric
This is why we need it too. Route reflectors for L2VPN and L3VPN. It would make it a lot cleaner and easier and reduce human error
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1819
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: BGP and routing filter improvement suggestions

Sat Oct 06, 2012 2:12 am

Not directly related but MPLS Fast Re-Route pleeeease !
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
mrz
MikroTik Support
MikroTik Support
Topic Author
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: BGP and routing filter improvement suggestions

Mon Oct 08, 2012 1:18 pm

the ability in a routing filter to send received/sent prefixes to an address list
This is a good request and we were thinking about it previously. Most likely it will be it implemented.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Topic Author
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: BGP and routing filter improvement suggestions

Mon Oct 08, 2012 1:22 pm

The ability in Winbox/CLI to see all prefixes received from a peer, that also indicates the last filter policy they passed through, and if they have been inserted in to the routing table, and if so which one. This will allow you to easily see prefixes that were received but blocked by a filter, and identify which filter it was. Or, which filter allowed a prefix that you want to block. You can then adjust that filter.
I'm not sure if what you ask is possible without complicated coding. Currently you can add routing filter rule with log action and see where prefix is matched, similar as it is in firewall rules.
BGP Peer Groups would be good too. When you have say 10 peers with common settings, the only thing thats different is the peer IP and remote AS, have them belong to a parent group that defines all the other settings, then when you need to change a setting you only need to change it in one place instead of 10.
BGP groups most likely will not be implemented, but we will think of some way to make configuration easy if you have peers with common settings. Some of common parameters can be set in instance.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Topic Author
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: BGP and routing filter improvement suggestions

Mon Oct 08, 2012 1:23 pm

Anything else?
 
User avatar
mrz
MikroTik Support
MikroTik Support
Topic Author
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: BGP and routing filter improvement suggestions

Mon Oct 08, 2012 1:25 pm

I will add one myself:

BGP origin validation
https://www.ripe.net/lir-services/resou ... validation

This feature is considered.
 
riggerman
newbie
Posts: 33
Joined: Sun Jun 03, 2007 10:27 pm
Location: Johannesburg, South Africa
Contact:

Re: BGP and routing filter improvement suggestions

Tue Oct 09, 2012 12:41 am

Hi mrz,

If we are able to do some pie in the sky 'nice to have one day stuff' for your list:

(if any of this is already doable plz point me in the right direction ;-) )
1) BGP default propagate
- Likely my biggest request other than not having routes stuck in the cache ;-)
- If I receive a default from a peer allow me to actually correctly propagate it instead of only having the option to originate


2) BGP Replace private AS
- We can already remove a private AS, but I want to specifically be able to overwrite a specific private AS with another AS of my choosing. This is sometimes an issue when multiple private peers interact at one peering point.

3) BGP Link Bandwidth Extended Community:
- http://tools.ietf.org/html/draft-ietf-i ... ndwidth-03
- http://www.cisco.com/en/US/docs/ios/12_ ... bgplb.html
- This has a lot of downstream implications on path selection etc so I'm guessing this would not be high on the list. Its a nice cisco feature however that would be useful as we are all using the Mikrotik's more and more in SP environments
-- to contact me rather use my other account: "regardtv"
 
User avatar
mrz
MikroTik Support
MikroTik Support
Topic Author
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: BGP and routing filter improvement suggestions

Tue Oct 09, 2012 10:30 am

Hi mrz,

If we are able to do some pie in the sky 'nice to have one day stuff' for your list:

(if any of this is already doable plz point me in the right direction ;-) )
1) BGP default propagate
- Likely my biggest request other than not having routes stuck in the cache ;-)
- If I receive a default from a peer allow me to actually correctly propagate it instead of only having the option to originate
This is already in our TODO list :)
2) BGP Replace private AS
- We can already remove a private AS, but I want to specifically be able to overwrite a specific private AS with another AS of my choosing. This is sometimes an issue when multiple private peers interact at one peering point.
What if you remove private AS and then add set-bgp-prepend-path=<other_private_as> in output routing filters?
3) BGP Link Bandwidth Extended Community:
- http://tools.ietf.org/html/draft-ietf-i ... ndwidth-03
- http://www.cisco.com/en/US/docs/ios/12_ ... bgplb.html
- This has a lot of downstream implications on path selection etc so I'm guessing this would not be high on the list. Its a nice cisco feature however that would be useful as we are all using the Mikrotik's more and more in SP environments
We will look into and consider adding it.
 
TKITFrank
Member Candidate
Member Candidate
Posts: 236
Joined: Tue Jul 07, 2009 2:55 pm
Location: Sweden

Re: BGP and routing filter improvement suggestions

Tue Oct 09, 2012 12:02 pm

Hi,

Just out of curiosity..
Is BGP Route Flap Damping (RFC 2439) implemented?

And also I'm in the process of stating a project with Anycast based BGP for our external services.
I have not done any deeper studies right now on the requirements in BGP but it stands between Cisco vs Mikrotik right now.
If both can do it then price will decide brand. :)
MTCNA

"I don't believe UNIX is Utopia. It's just the best set of tools around."
 
hedele
Member
Member
Posts: 338
Joined: Tue Feb 24, 2009 11:23 pm

Re: BGP and routing filter improvement suggestions

Tue Oct 09, 2012 12:22 pm

BGP Peer Groups would be good too. When you have say 10 peers with common settings, the only thing thats different is the peer IP and remote AS, have them belong to a parent group that defines all the other settings, then when you need to change a setting you only need to change it in one place instead of 10.
BGP groups most likely will not be implemented, but we will think of some way to make configuration easy if you have peers with common settings. Some of common parameters can be set in instance.
That's a shame :( BGP groups are a very very important feature if you're taking part at large IXes, like AMSIX in the Netherlands or DECIX in Germany... It just makes a lot of configuration a lot easier.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1819
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: BGP and routing filter improvement suggestions

Tue Oct 09, 2012 12:33 pm


BGP groups most likely will not be implemented, but we will think of some way to make configuration easy if you have peers with common settings. Some of common parameters can be set in instance.
That's a shame :( BGP groups are a very very important feature if you're taking part at large IXes, like AMSIX in the Netherlands or DECIX in Germany... It just makes a lot of configuration a lot easier.
Yes I am disappointed as well. It would save us a lot of time, and reduce human error.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
mrz
MikroTik Support
MikroTik Support
Topic Author
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: BGP and routing filter improvement suggestions

Tue Oct 09, 2012 1:43 pm

As I mentioned we will think of something but not in the way you have groups in, for example cisco.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Topic Author
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: BGP and routing filter improvement suggestions

Tue Oct 09, 2012 1:51 pm

Is BGP Route Flap Damping (RFC 2439) implemented?
As far as I know not supported. But it is a good feature request.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1819
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: BGP and routing filter improvement suggestions

Tue Oct 09, 2012 2:00 pm

As I mentioned we will think of something but not in the way you have groups in, for example cisco.
Like JunOS ? :)

http://www.juniper.net/techpubs/en_US/j ... peers.html
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
riggerman
newbie
Posts: 33
Joined: Sun Jun 03, 2007 10:27 pm
Location: Johannesburg, South Africa
Contact:

Re: BGP and routing filter improvement suggestions

Tue Oct 09, 2012 9:45 pm


BGP groups most likely will not be implemented, but we will think of some way to make configuration easy if you have peers with common settings. Some of common parameters can be set in instance.
That's a shame :( BGP groups are a very very important feature if you're taking part at large IXes, like AMSIX in the Netherlands or DECIX in Germany... It just makes a lot of configuration a lot easier.
Yes I am disappointed as well. It would save us a lot of time, and reduce human error.
Maybe something similar to the way ppp profiles are implemented atm - that could work nicely.

hedele - agreed. Some scripting here could be rather useful tho ;-) - If you already have a peer db internally maybe get your system to automagically generate the appropriate peer statements. Cuts down on human error even further ;-)
-- to contact me rather use my other account: "regardtv"
 
lyma
just joined
Posts: 24
Joined: Tue Sep 09, 2008 4:00 am
Contact:

Re: BGP and routing filter improvement suggestions

Mon Oct 22, 2012 9:37 pm

Please post any missing BGP and Routing filter functionality or new features that you would like to see in future routing implementations.
Any work in this issue: http://forum.mikrotik.com/viewtopic.php ... 81&start=0 ?
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8309
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: BGP and routing filter improvement suggestions

Tue Oct 23, 2012 2:43 pm

in BGP, it would be nice to see prepended AS path in Advertisements

and, when will connected routes be used when doing recursive nexthop lookup?..
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Topic Author
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: BGP and routing filter improvement suggestions

Wed Oct 24, 2012 10:26 am

in BGP, it would be nice to see prepended AS path in Advertisements
That part is completely redesigned so you will be able to see prepends.
and, when will connected routes be used when doing recursive nexthop lookup?..
Can you describe in more details what exactly you mean?
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8309
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: BGP and routing filter improvement suggestions

Wed Oct 24, 2012 11:42 am

and, when will connected routes be used when doing recursive nexthop lookup?..
Can you describe in more details what exactly you mean?
http://wiki.mikrotik.com/wiki/Manual:IP ... hop_lookup
Routes with interface name as the value of gateway are not used for nexthop lookup. If route has both interface nexthops and active IP address nexthops, then interface nexthops are ignored.
so it's not possible to do something like
/ip route
add dst-address=8.8.8.8 gateway=PPTP_Interface scope=10
add gateway=8.8.8.8 check-gateway=ping
meanwhile this works:
/ip route
add dst-address=8.8.8.8 gateway=some_IP-address scope=10
add gateway=8.8.8.8 check-gateway=ping
where, in case of PPTP, that some_IP-address you need to pervertly add as Remote address in PPTP Profile, if pptp's gateway can change between sessions
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Topic Author
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: BGP and routing filter improvement suggestions

Wed Oct 24, 2012 11:44 am

Will look into it.
 
User avatar
gustkiller
Member
Member
Posts: 418
Joined: Sat Jan 07, 2006 5:15 am
Location: Brazil
Contact:

Re: BGP and routing filter improvement suggestions

Wed Oct 24, 2012 4:52 pm

show ip bgp ( cisco) ou show route (juniper) like routing search in cli.
Mikrotik Certified Consultant
 
User avatar
mrz
MikroTik Support
MikroTik Support
Topic Author
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: BGP and routing filter improvement suggestions

Wed Oct 24, 2012 5:03 pm

Already possible with
/ip route print where bgp
 
User avatar
gustkiller
Member
Member
Posts: 418
Joined: Sat Jan 07, 2006 5:15 am
Location: Brazil
Contact:

Re: BGP and routing filter improvement suggestions

Wed Oct 24, 2012 9:50 pm

Already possible with
/ip route print where bgp
Not like juniper and cisco. See below

Juniper

gustavo@BRD01> show route 177.66.x00.1 ( just show route with a unique IP not the prefix)

inet.0: 425051 destinations, 426119 routes (425042 active, 8 holddown, 25 hidden)
+ = Active Route, - = Last Active, * = Both

177.66.x00.0/24 *[BGP/170] 08:30:35, localpref 450, from 177.128.20x.x
AS path: 53004 I
> to 177.128.x.x.x via ae0.802


RouterOS = have to know the whole prefix ( not only a single ip like juniper and cisco to find the route prefix) AS PATH and other not show.

[gustavo@SRF] > ip route print where bgp dst-address in 177.66.200.1
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
[gustavo@SRF] > ip route print where bgp dst-address in 177.66.200.0/24
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
8 ADb 177.66.200.0/24 177.128.20x.x 200
Mikrotik Certified Consultant
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8309
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: BGP and routing filter improvement suggestions

Wed Oct 24, 2012 10:21 pm

AS PATH and other not show
maybe, 'print detail' instead of just 'print'?..
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
gustkiller
Member
Member
Posts: 418
Joined: Sat Jan 07, 2006 5:15 am
Location: Brazil
Contact:

Re: BGP and routing filter improvement suggestions

Wed Oct 24, 2012 11:52 pm

Print detail worked, but not with a single ip search.

The advantage of junos and ios is that we dont have to know or predict what is the entire network ou prefix to find out information about it. Just a single ip address from that prefix will bring the information about the prefix that IP address belong.


Try out at route-views.routeviews.org log in and do a show ip bgp ( one single ip address from your netblock) and see the magic :)
Mikrotik Certified Consultant
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8309
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: BGP and routing filter improvement suggestions

Thu Oct 25, 2012 12:35 am

yep, I know, lack of search by ip being covered by some network was discussed long ago, that's why I didn't comment that :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
gustkiller
Member
Member
Posts: 418
Joined: Sat Jan 07, 2006 5:15 am
Location: Brazil
Contact:

Re: BGP and routing filter improvement suggestions

Thu Oct 25, 2012 1:11 am

yep, I know, lack of search by ip being covered by some network was discussed long ago, that's why I didn't comment that :)
LOL :D
Mikrotik Certified Consultant
 
blake
Member
Member
Posts: 426
Joined: Mon May 31, 2010 10:46 pm
Location: Arizona

Re: BGP and routing filter improvement suggestions

Thu Oct 25, 2012 10:53 am

Why don't you guys try this? :)
/ip route print where bgp and 177.66.x00.1 in dst-address
You're welcome. ;-)
 
User avatar
mrz
MikroTik Support
MikroTik Support
Topic Author
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: BGP and routing filter improvement suggestions

Thu Oct 25, 2012 10:55 am

Blakes mentioned command does exactly the same as show route 177.66.x00.1.
Maybe we will think of something so that you don't need to write such long commands.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8309
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: BGP and routing filter improvement suggestions

Thu Oct 25, 2012 10:56 am

hoooooooly sh*t! it works! it works!

thanks xD
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
gustkiller
Member
Member
Posts: 418
Joined: Sat Jan 07, 2006 5:15 am
Location: Brazil
Contact:

Re: BGP and routing filter improvement suggestions

Thu Oct 25, 2012 6:08 pm

holy cow! It works! Thank you!
Mikrotik Certified Consultant
 
User avatar
linkwave
Trainer
Trainer
Posts: 53
Joined: Fri May 25, 2007 9:13 pm
Location: Grosseto, Italy
Contact:

Re: BGP and routing filter improvement suggestions

Sat Oct 27, 2012 3:45 pm

BGP origin validation
https://www.ripe.net/lir-services/resou ... validation
This feature is considered.
+1
Fabulous!

Lorenzo
MTCNEL
 
User avatar
shade
newbie
Posts: 31
Joined: Fri Jan 14, 2011 7:40 pm
Location: Russia,Maykop

Re: BGP and routing filter improvement suggestions

Mon Oct 29, 2012 4:26 pm

I want a rule which will filter all subprefixes in a specified prefix, it seems filter only exact specified prefixes and ignore smaller subprefixes.
Oh and the ability in a routing filter to send received/sent prefixes to an address list
+1
I add/remove routing filer items with API, it will be more easy to work with address/prefix list.
Нерешаемых проблем нет — есть проблемы, которые никто не решает
 
User avatar
mrz
MikroTik Support
MikroTik Support
Topic Author
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: BGP and routing filter improvement suggestions

Mon Oct 29, 2012 4:40 pm

I want a rule which will filter all subprefixes in a specified prefix, it seems filter only exact specified prefixes and ignore smaller subprefixes.
[admin@t36] /ip route> /ip route print where dst-address in 23.23.23.0/24
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
12 ADC  23.23.23.1/32      23.23.23.2      pppoe-out1                0
13 ADo  23.23.23.2/32                      10.5.101.3              110
18 ADo  23.23.23.4/32                      10.5.101.3              110
 
User avatar
shade
newbie
Posts: 31
Joined: Fri Jan 14, 2011 7:40 pm
Location: Russia,Maykop

Re: BGP and routing filter improvement suggestions

Mon Oct 29, 2012 5:06 pm

mrz, what?

I want something like
/routing filter add all-subprefix-in-prefix=192.168.0.0/24 action=accept
/routing filter add all-subprefix-in-prefix=192.168.1.0/24 action=discard

If I add
/routing filter add prefix=192.168.0.0/24 action=accept
/routing filter add prefix=192.168.1.0/24 action=discard
it will filter just 192.168.0.0/24 (to accept) and 192.168.1.0/24 (to discard), and will not affect to route 192.168.0.0/30 or 192.168.1.1/32 for example
Нерешаемых проблем нет — есть проблемы, которые никто не решает
 
eflanery
Member
Member
Posts: 382
Joined: Fri May 28, 2004 10:11 pm
Location: Moscow, ID
Contact:

Re: BGP and routing filter improvement suggestions

Mon Oct 29, 2012 6:32 pm

mrz, what?

I want something like
/routing filter add all-subprefix-in-prefix=192.168.0.0/24 action=accept
/routing filter add all-subprefix-in-prefix=192.168.1.0/24 action=discard

If I add
/routing filter add prefix=192.168.0.0/24 action=accept
/routing filter add prefix=192.168.1.0/24 action=discard
it will filter just 192.168.0.0/24 (to accept) and 192.168.1.0/24 (to discard), and will not affect to route 192.168.0.0/30 or 192.168.1.1/32 for example
Try this:
/routing filter add prefix=192.168.0.0/24 prefix-length=24-32 action=accept
/routing filter add prefix=192.168.1.0/24 prefix-length=24-32 action=discard

(plus appropriate chain= )

--Eric
 
User avatar
doneware
Trainer
Trainer
Posts: 522
Joined: Mon Oct 08, 2012 8:39 pm
Location: Hungary

Re: BGP and routing filter improvement suggestions

Tue Oct 30, 2012 12:02 pm

Anything else?
qppb, please?
#TR0359
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1819
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: BGP and routing filter improvement suggestions

Wed Oct 31, 2012 11:00 pm

All existing problems will be addressed. Please list improvements that are currently missing and you would like to see.
Hi Maris,

I have heard a few different variations of what is happening with routing in RouterOS v6 from Mikrotik staff.

I have heard there is "new" routing coming in v6 (from you and Janis), and also that v6 already has the improved routing (from Sergejs).

Which of these is it ?

- New routing-test type package for version 6

or

- Routing included in version 6 is improved


Thanks,




Andrew
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
wulfgard
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Wed Oct 17, 2012 1:06 pm
Location: France
Contact:

Re: BGP and routing filter improvement suggestions

Mon Nov 05, 2012 3:19 am

Hello

full IPV6 support in BGP and especially being able to setup IPV6 address for peers is nowdays a MUST HAVE
upstreams and peering points uses dedicated session for IPV4 and IPV6

best regards
Thierry
System and Network Engineer
Mikrotik Trainer - MTCNA MTCRE
Official French Mikrotik Distributor
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1819
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: BGP and routing filter improvement suggestions

Mon Nov 05, 2012 10:17 am

Hello

full IPV6 support in BGP and especially being able to setup IPV6 address for peers is nowdays a MUST HAVE
upstreams and peering points uses dedicated session for IPV4 and IPV6

best regards
Thierry
This is already possible in v5. We have IPv6 peers in production for around 10 months now.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
mrz
MikroTik Support
MikroTik Support
Topic Author
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: BGP and routing filter improvement suggestions

Mon Nov 05, 2012 11:22 am

@ nz_monkey: v6 currently has the same routing as v5.
 
User avatar
wulfgard
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Wed Oct 17, 2012 1:06 pm
Location: France
Contact:

Re: BGP and routing filter improvement suggestions

Mon Nov 05, 2012 11:29 am

Hello

full IPV6 support in BGP and especially being able to setup IPV6 address for peers is nowdays a MUST HAVE
upstreams and peering points uses dedicated session for IPV4 and IPV6

best regards
Thierry
This is already possible in v5. We have IPv6 peers in production for around 10 months now.
Can you show a setup example

a+
Thierry
System and Network Engineer
Mikrotik Trainer - MTCNA MTCRE
Official French Mikrotik Distributor
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1819
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: BGP and routing filter improvement suggestions

Mon Nov 05, 2012 5:06 pm

In the peers remote address, simply put an IPv6 address instead of an IPv4 one , then click on the "Advanced" tab and make sure only IPv6 is ticked.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
wulfgard
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Wed Oct 17, 2012 1:06 pm
Location: France
Contact:

Re: BGP and routing filter improvement suggestions

Mon Nov 05, 2012 5:48 pm

In the peers remote address, simply put an IPv6 address instead of an IPv4 one , then click on the "Advanced" tab and make sure only IPv6 is ticked.
Oups sorry did not tried this
works well
Thanks

A+
Thierry
System and Network Engineer
Mikrotik Trainer - MTCNA MTCRE
Official French Mikrotik Distributor
 
User avatar
shade
newbie
Posts: 31
Joined: Fri Jan 14, 2011 7:40 pm
Location: Russia,Maykop

Re: BGP and routing filter improvement suggestions

Fri Nov 09, 2012 5:34 pm

mrz, what?

I want something like
/routing filter add all-subprefix-in-prefix=192.168.0.0/24 action=accept
/routing filter add all-subprefix-in-prefix=192.168.1.0/24 action=discard

If I add
/routing filter add prefix=192.168.0.0/24 action=accept
/routing filter add prefix=192.168.1.0/24 action=discard
it will filter just 192.168.0.0/24 (to accept) and 192.168.1.0/24 (to discard), and will not affect to route 192.168.0.0/30 or 192.168.1.1/32 for example
Try this:
/routing filter add prefix=192.168.0.0/24 prefix-length=24-32 action=accept
/routing filter add prefix=192.168.1.0/24 prefix-length=24-32 action=discard

(plus appropriate chain= )

--Eric
thanks, it works
Нерешаемых проблем нет — есть проблемы, которые никто не решает
 
User avatar
wulfgard
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Wed Oct 17, 2012 1:06 pm
Location: France
Contact:

Re: BGP and routing filter improvement suggestions

Fri Nov 30, 2012 5:27 am

BGP Peer Groups would be good too. When you have say 10 peers with common settings, the only thing thats different is the peer IP and remote AS, have them belong to a parent group that defines all the other settings, then when you need to change a setting you only need to change it in one place instead of 10.
BGP groups most likely will not be implemented, but we will think of some way to make configuration easy if you have peers with common settings. Some of common parameters can be set in instance.
That's a shame :( BGP groups are a very very important feature if you're taking part at large IXes, like AMSIX in the Netherlands or DECIX in Germany... It just makes a lot of configuration a lot easier.
at least multi neighboor ip address like in JUNOS would make part of the trick
 
depe
just joined
Posts: 12
Joined: Thu May 03, 2012 8:06 pm

Re: BGP and routing filter improvement suggestions

Fri Dec 07, 2012 9:08 pm

May be I am doing something wrong.
I have a /19 and a /21 ip address family and 3 BGP peers.
I can only advertise in /24 networks.

I want to advertise to one peer without prepend and the others with prepend to balance incoming traffic.

In quagga I add some /24 to a prefix-list A, and some others to another prefix-list B.
Later create a filter that publish without prepend if the address is included in prefix-list A and with prepend 5 or 10 if included in prefix-list B.

Is this possible with Mikrotik ?
I was able to do, but creating 40 filters to each bgp peer, and filtering each one with these filters, a very ugly solution.

If this is not possible will be great if we can choose a prefix list name instead of address.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8309
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: BGP and routing filter improvement suggestions

Sat Dec 08, 2012 1:34 am

depe, have you tried using action=passthrough with some set-route-comment=your_list and then action=jump + subchains which will match by comment to set prepend?

or in every peer's chain first jump to common subnet marking chain, and then setting prepend based on comment?..
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
maznu
Member Candidate
Member Candidate
Posts: 197
Joined: Tue May 05, 2015 11:12 am
Location: Manchester, UK
Contact:

Re: BGP and routing filter improvement suggestions

Tue Nov 15, 2016 1:47 pm

BGP flow-spec. While routers in the DFZ can use a public IP2ASN database, for anybody with a complex peering network it'd be amazing to have ASN numbers within NetFlow/IPFIX data.
Marek
 
cheeze
Member Candidate
Member Candidate
Posts: 146
Joined: Tue Jul 31, 2012 7:44 am

Re: BGP and routing filter improvement suggestions

Fri Dec 02, 2016 6:44 pm

I realize that what I am asking for down below is a LOOOOOT of work but....I'd like to put them in there.

BGP Labeled Unicast (RFC3107) for both IPv4 and IPv6
BGP Link-State (RFC7752) for the TE database distribution between areas (allowing for inter-area MPLS-TE)
BGP Route-Target Constraints (RFC4684) for MPLS VPNs
BGP MPLS VPNS (RFC4364) for IPv4 unicast/multicast and IPv6 unicast/multicast (we have it for IPv4 unicast only)
BGP MVPNs (RFC6513) for IPv4 and IPv6 multicast VPNs
BGP Flowspec (RFC5575) for DDoS mitigation
BGP IPv6 nexthop resolution for any IP in the IPv6 range and not just Global Unicast address range.

If need be the ones I'd prefer to have focus on would be in this order...

BGP IPv6 nexthop resolution, BGP Labeled Unicast, BGP MPLS VPNs, BGP Flowspec

However if Mikrotik were to keep up with Cisco and Juniper then.....really all of them need to happen.....

As always, thank you for the hard work Mikrotik. I think we're all feverishly awaiting ROS 7 :)
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1053
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: BGP and routing filter improvement suggestions

Mon Dec 05, 2016 4:34 pm

I realize that what I am asking for down below is a LOOOOOT of work but....I'd like to put them in there.

BGP Labeled Unicast (RFC3107) for both IPv4 and IPv6
BGP Link-State (RFC7752) for the TE database distribution between areas (allowing for inter-area MPLS-TE)
BGP Route-Target Constraints (RFC4684) for MPLS VPNs
BGP MPLS VPNS (RFC4364) for IPv4 unicast/multicast and IPv6 unicast/multicast (we have it for IPv4 unicast only)
BGP MVPNs (RFC6513) for IPv4 and IPv6 multicast VPNs
BGP Flowspec (RFC5575) for DDoS mitigation
BGP IPv6 nexthop resolution for any IP in the IPv6 range and not just Global Unicast address range.

If need be the ones I'd prefer to have focus on would be in this order...

BGP IPv6 nexthop resolution, BGP Labeled Unicast, BGP MPLS VPNs, BGP Flowspec

However if Mikrotik were to keep up with Cisco and Juniper then.....really all of them need to happen.....

As always, thank you for the hard work Mikrotik. I think we're all feverishly awaiting ROS 7 :)
+1 Yes to all of this!! :-P
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com
 
faisali
Member Candidate
Member Candidate
Posts: 179
Joined: Fri Oct 08, 2010 5:11 am

Re: BGP and routing filter improvement suggestions

Tue Dec 06, 2016 5:28 am

Request to fix the logic/selection of prefixes when using BGP Communities only in the selection criteria in the chain/filter list.

------
Background:-
When you have prefixes with multiple BGP communities tags, ACL filters will not properly select prefixes if the BGP community tag is not the first couple of tags in the list on that prefix

However, if you combine the selection of such a prefix with one more filter parameter , then the ACL works correctly.
----------

Who is online

Users browsing this forum: No registered users and 6 guests