Community discussions

 
YUJOBIKA
Member Candidate
Member Candidate
Topic Author
Posts: 122
Joined: Sat Sep 15, 2007 5:55 pm

Why "bgp set-bgp-prepend=5" is a winner ?

Thu Nov 01, 2012 8:28 pm

Here my route filter:

/routing filter
add action=accept chain=isp1-out disabled=no invert-match=no prefix=x.x.4.0/24 prefix-length=24 protocol=connect,static,bgp set-bgp-prepend-path=""
add action=accept chain=isp2-out disabled=no invert-match=no prefix=x.x.4.0/24 prefix-length=24 protocol=connect,static,bgp set-bgp-prepend=5 set-bgp-prepend-path=""

I want inbound traffic flow from isp1. I already prepend 5x for isp2, but as seen in the picture...the winner is isp2. Why this could be happen ?
bgp.jpg
You do not have the required permissions to view the files attached to this post.
 
User avatar
wulfgard
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Wed Oct 17, 2012 1:06 pm
Location: France
Contact:

Re: Why "bgp set-bgp-prepend=5" is a winner ?

Thu Nov 01, 2012 11:40 pm

What are showing the looking glass of Telia Sonera and Global Crossing from your AS announces

Regards
Thierry
System and Network Engineer
Mikrotik Trainer - MTCNA MTCRE
Official French Mikrotik Distributor
 
YUJOBIKA
Member Candidate
Member Candidate
Topic Author
Posts: 122
Joined: Sat Sep 15, 2007 5:55 pm

Re: Why "bgp set-bgp-prepend=5" is a winner ?

Fri Nov 02, 2012 4:45 am

What are showing the looking glass of Telia Sonera and Global Crossing from your AS announces

Regards
Thierry
Thanks for your attention.

From Global Crossing, prepend 5x still a winner. Here the result (ASxxx33 is mine):

Route Server: route-server.gblx.net

BGP routing table entry for x.x.4.0/24, version 925469324
Paths: (8 available, best #4, table default)
Not advertised to any peer
3491 4761 xxx52 xxx52 xxx86 xxx33 xxx33 xxx33 xxx33 xxx33, (received & used)
ge4-12-1000M.ar6.PHX1.gblx.net from loop0.ir1.SFO1.gblx.net
Origin IGP, metric 0, localpref 300, valid, internal
Community: 3491:400 3549:300 3549:4142 3549:8040 3549:8080 3549:8100 3549:8230 3549:30840 (North American; United States)
Originator: loop0.ar2.SJC2.gblx.net, Cluster list: 0.0.0.21
3491 4761 xxx52 xxx52 xxx86 xxx33 xxx33 xxx33 xxx33 xxx33, (received & used)
ge4-12-1000M.ar6.PHX1.gblx.net from loop0.ir1.PAO2.gblx.net
Origin IGP, metric 0, localpref 300, valid, internal
Community: 3491:400 3549:300 3549:4142 3549:8040 3549:8080 3549:8100 3549:8230 3549:30840 (North American; United States)
Originator: loop0.ar2.SJC2.gblx.net, Cluster list: 0.0.0.21
3491 4761 xxx52 xxx52 xxx86 xxx33 xxx33 xxx33 xxx33 xxx33, (received & used)
ge4-12-1000M.ar6.PHX1.gblx.net from loop0.ir1.LAX1.gblx.net
Origin IGP, metric 0, localpref 300, valid, internal
Community: 3491:400 3549:300 3549:4014 3549:8040 3549:8080 3549:8100 3549:8230 3549:30840 (North American; United States)
Originator: loop0.ar4.LAX1.gblx.net, Cluster list: 0.0.0.11
3491 4761 xxx52 xxx52 xxx86 xxx33 xxx33 xxx33 xxx33 xxx33, (received & used)
ge4-12-1000M.ar6.PHX1.gblx.net from loop0.ir1.PHX1.gblx.net
Origin IGP, metric 0, localpref 300, valid, internal, best
Community: 3491:400 3549:300 3549:4014 3549:8040 3549:8080 3549:8100 3549:8230 3549:30840 (North American; United States)
Originator: loop0.ar4.LAX1.gblx.net, Cluster list: 0.0.0.11
6762 4761 xxx52 xxx52 xxx86 xxx33 xxx33 xxx33 xxx33 xxx33, (received & used)
ge4-12-1000M.ar6.PHX1.gblx.net from loop0.scr2.GRU1.gblx.net
Origin IGP, metric 100, localpref 200, valid, internal
Community: 3549:2831 3549:34076 (South American; Brazil)
Originator: loop0.ar4.GRU1.gblx.net, Cluster list: 0.0.2.109
6762 4761 xxx52 xxx52 xxx86 xxx33 xxx33 xxx33 xxx33 xxx33, (received & used)
ge4-12-1000M.ar6.PHX1.gblx.net from loop0.scr1.GRU1.gblx.net
Origin IGP, metric 100, localpref 200, valid, internal
Community: 3549:2831 3549:34076 (South American; Brazil)
Originator: loop0.ar4.GRU1.gblx.net, Cluster list: 0.0.2.109
6762 4761 xxx52 xxx52 xxx86 xxx33 xxx33 xxx33 xxx33 xxx33, (received & used)
ge4-12-1000M.ar6.PHX1.gblx.net from loop0.ir2.SCL1.gblx.net
Origin IGP, metric 100, localpref 200, valid, internal
Community: 3549:2854 3549:34152 (South American; Chile)
Originator: loop0.ar4.SCL1.gblx.net, Cluster list: 0.0.2.209
6762 4761 xxx52 xxx52 xxx86 xxx33 xxx33 xxx33 xxx33 xxx33, (received & used)
ge4-12-1000M.ar6.PHX1.gblx.net from loop0.ir1.SCL1.gblx.net
Origin IGP, metric 100, localpref 200, valid, internal
Community: 3549:2854 3549:34152 (South American; Chile)
Originator: loop0.ar4.SCL1.gblx.net, Cluster list: 0.0.2.209



From Telliasonera seems the best route is correct (came from ASxxx02):

Router: New York
Command: show route protocol bgp x.x.4.2 table inet.0


inet.0: 474305 destinations, 1949511 routes (473974 active, 88 holddown, 291282 hidden)
+ = Active Route, - = Last Active, * = Both

x.x.4.0/24 *[BGP/170] 2d 07:12:08, localpref 200, from 213.248.80.240
AS path: xxx47 xxx02 xxx33 I
to 213.155.131.136 via ae6.0
> to 213.155.131.138 via ae9.0
[BGP/170] 2d 07:11:12, localpref 200, from 213.248.80.241
AS path: xxx47 xxx02 xxx33 I
to 213.155.131.136 via ae6.0
> to 213.155.131.138 via ae9.0
[BGP/170] 2d 06:36:09, MED 0, localpref 150
AS path: 6453 xxx47 xxx02 xxx33 I
> to 213.248.100.178 via ae2.0
[BGP/170] 09:14:07, MED 0, localpref 150, from 129.250.1.182
AS path: 2914 xxx52 xxx86 xxx33 xxx33 xxx33 xxx33 xxx33 I
to 129.250.8.29 via xe-7/0/2.0
to 129.250.9.177 via xe-10/0/0.0
> to 129.250.8.153 via xe-11/2/0.0
[BGP/170] 09:20:08, MED 0, localpref 150
AS path: 6762 xx61 xxx52 xxx52 xxx86 xxx33 xxx33 xxx33 xxx33 xxx33 I
> to 213.248.95.226 via xe-8/3/1.0
[BGP/170] 09:14:07, MED 0, localpref 150, from 208.178.65.29
AS path: 3549 3491 xx61 xxx52 xxx52 xxx86 xxx33 xxx33 xxx33 xxx33 xxx33 I
to 213.248.94.82 via xe-7/2/0.0
to 64.208.27.73 via xe-10/2/1.0
> to 208.178.58.181 via xe-11/1/1.0


Why from Telia is correct, but from Global Crossing does not ?
How to make all route come from ASxxx02 ?
 
User avatar
wulfgard
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Wed Oct 17, 2012 1:06 pm
Location: France
Contact:

Re: Why "bgp set-bgp-prepend=5" is a winner ?

Fri Nov 02, 2012 4:39 pm

Telia side is good no prepend

x.x.4.0/24 *[BGP/170] 2d 07:12:08, localpref 200, from 213.248.80.240
AS path: xxx47 xxx02 xxx33 I
to 213.155.131.136 via ae6.0
> to 213.155.131.138 via ae9.0

GBLX is also good prepend 5

3491 4761 xxx52 xxx52 xxx86 xxx33 xxx33 xxx33 xxx33 xxx33, (received & used)
ge4-12-1000M.ar6.PHX1.gblx.net from loop0.ir1.PHX1.gblx.net
Origin IGP, metric 0, localpref 300, valid, internal, best

so where is the shame ?
System and Network Engineer
Mikrotik Trainer - MTCNA MTCRE
Official French Mikrotik Distributor
 
YUJOBIKA
Member Candidate
Member Candidate
Topic Author
Posts: 122
Joined: Sat Sep 15, 2007 5:55 pm

Re: Why "bgp set-bgp-prepend=5" is a winner ?

Fri Nov 02, 2012 6:43 pm

Telia side is good no prepend

x.x.4.0/24 *[BGP/170] 2d 07:12:08, localpref 200, from 213.248.80.240
AS path: xxx47 xxx02 xxx33 I
to 213.155.131.136 via ae6.0
> to 213.155.131.138 via ae9.0

GBLX is also good prepend 5

3491 4761 xxx52 xxx52 xxx86 xxx33 xxx33 xxx33 xxx33 xxx33, (received & used)
ge4-12-1000M.ar6.PHX1.gblx.net from loop0.ir1.PHX1.gblx.net
Origin IGP, metric 0, localpref 300, valid, internal, best

so where is the shame ?

What I confused is why prepend 5x still have best path ? Please see my picture in the first post. I want all inbound traffic come from isp1 (ASxxx02). And let isp2 (ASxxx86) as backup only, just in case isp1 down.
 
User avatar
wulfgard
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Wed Oct 17, 2012 1:06 pm
Location: France
Contact:

Re: Why "bgp set-bgp-prepend=5" is a winner ?

Fri Nov 02, 2012 7:21 pm

you cannot make all trafic come from one ISP with BGP even with PREPEND

i am wondering if you are not speaking allso for outbound trafic because in your picture we can see same metric and local-pref ( 0 and 70 )

so you must also modify local-pref to send traffic through correct ISP ( highest number wins )
System and Network Engineer
Mikrotik Trainer - MTCNA MTCRE
Official French Mikrotik Distributor
 
YUJOBIKA
Member Candidate
Member Candidate
Topic Author
Posts: 122
Joined: Sat Sep 15, 2007 5:55 pm

Re: Why "bgp set-bgp-prepend=5" is a winner ?

Sat Nov 03, 2012 4:44 am

you cannot make all trafic come from one ISP with BGP even with PREPEND

i am wondering if you are not speaking allso for outbound trafic because in your picture we can see same metric and local-pref ( 0 and 70 )

so you must also modify local-pref to send traffic through correct ISP ( highest number wins )

"Set BGP Local Pref" only for outbound traffic right ? Actually I don't care for outgoing traffic, because it is only 10-20% of my bandwidth capacity.

What I concern is for inbound traffic. Capacity for isp1 is 20Mbps and isp2 is 10Mbps. So I need to make some prefix come from isp1. Let's say like this:

Prefix I have:
X.X.4.0/23
X.X.110.0/23

I need traffic flow like this:
X.X.4.0/24 --- inbound from isp1 (isp2 for backup only)
X.X.5.0/24 --- inbound from isp2 (isp1 for backup only)
X.X.110.0/24 --- inbound from isp1 (isp2 for backup only)
X.X.111.0/24 --- inbound from isp1 (isp2 for backup only)

Is there any way to "force" traffic like I need ?
 
User avatar
wulfgard
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Wed Oct 17, 2012 1:06 pm
Location: France
Contact:

Re: Why "bgp set-bgp-prepend=5" is a winner ?

Sun Nov 04, 2012 3:17 pm

to nsure traffic flowing in only from one ISP you must stop announcing prefix on others ISP but you will lost redundancy

may be what you can do is trying to use communities from Telia and GBLX to make them change their own MED or LOCAL-PREF to your prefix

more info at

http://onesc.net/communities/as1299/
http://onesc.net/communities/as3549/




a+
Theirry
System and Network Engineer
Mikrotik Trainer - MTCNA MTCRE
Official French Mikrotik Distributor

Who is online

Users browsing this forum: No registered users and 6 guests