Page 1 of 1

VPLS Bridge Issues

Posted: Thu Nov 15, 2012 11:15 pm
by gilljr
Topology
Customer Network <---> RB1100(a) <--> RB1100(b) <---> MikroRouter8000ux2(c) <---> RB1100(d) <---> Customer Network

The connection between device a and device b is a 100Mbps microwave link with all data running on a vlan. All other connections are Gigabit Ethernet handoffs.

device a - v5.13
device b - v5.14
device c - v5.15
device d - v5.19
I am running OSPF on all nodes
MPLS is running on all nodes

I am bridging a customer's network utilizing a VPLS tunnel. I also am traffic shaping the customer to 50Mbps of traffic over this path. This worked fine for a long time using just device a and device b. I recently added devices c and d. With the customer hanging off device d as shown above, the customer is reporting all forms of issues with his Microsoft sharing over the network. My customer can ping across and most everything else works. If I eliminate device d and hang the tunnel off c, the traffic flows fine and the customer reports no issues (just as it was when the customer was off of device b).

I am leaning towards a bug in version 5.19 of the Router OS as the cause. Has anyone else seen this behavior before? Does anyone else have suggestions as to what I maybe doing wrong or any other troubleshooting ideas for me?

Re: VPLS Bridge Issues

Posted: Sat Nov 17, 2012 4:57 am
by Belyivulk
Check that you can get 1500byte frames without fragmentation from end to end - you potentially have the MTU set to low on one of the interfaces.

That's where i would start :)

Re: VPLS Bridge Issues

Posted: Mon Nov 19, 2012 11:49 pm
by gilljr
I will check and see if I get fragmentation. I only segment that I would expect issues with is the Micorwave radio link where I have VLANs and it has always worked on the Microwave segment.