Community discussions

 
sparrow
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 52
Joined: Wed Jul 11, 2012 10:59 am

OSPF GRE or IPIP or EOIP instead of virtual link

Fri Apr 12, 2013 6:37 pm

Hi guys,
I've a trouble setting an ospf network, more precisely using virtual link which has affected by bug.
My network is shown below:
ospf.JPG
How can I do a link/tunnel to interconnect the area 2 to backbone area?
I'm trying to establish that using GRE Tunnel but without good result.
Someone have a solution for me?
If they wants an export compact of configuration please tell me

P.S:sorry for my bad english
You do not have the required permissions to view the files attached to this post.
Last edited by sparrow on Tue Apr 16, 2013 7:13 pm, edited 2 times in total.
MTCNA - MTCRE - MTCWE
 
w0lt
Member
Member
Posts: 484
Joined: Wed Apr 02, 2008 2:12 pm
Location: Minnesota USA

Re: OSPF GRE or IPIP or EOIP instead virtual link

Fri Apr 12, 2013 8:16 pm

Send me your export. I have a similar configuration running just fine.
MTCNA - 2011

" The Bitterness of Poor Quality Remains Long After the Sweetness of Low Price is Forgotten "

Image
 
sparrow
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 52
Joined: Wed Jul 11, 2012 10:59 am

Re: OSPF GRE or IPIP or EOIP instead virtual link

Mon Apr 15, 2013 11:15 am

Send me your export. I have a similar configuration running just fine.
Hi,
Thanks for your interest!
So, here I attach the export compact for every router:

R1
/interface bridge
add name=LOOPBACK
/routing ospf instance
set [ find default=yes ] distribute-default=always-as-type-1 name=R1 redistribute-connected=as-type-1 \
    redistribute-static=as-type-1 router-id=10.10.10.10
/ip address
add address=192.168.1.100/24 interface=ether1
add address=192.168.2.1/30 interface=ether2
add address=192.168.3.1/30 interface=ether3
add address=10.10.10.10/32 interface=LOOPBACK network=10.10.10.10
/ip route
add distance=1 gateway=192.168.1.254
/routing ospf interface
add dead-interval=2s hello-interval=1s interface=ether2 network-type=broadcast retransmit-interval=1s
add cost=11 dead-interval=2s hello-interval=1s interface=ether3 network-type=broadcast priority=2 \
    retransmit-interval=1s
add dead-interval=2s hello-interval=1s interface=ether1 network-type=broadcast retransmit-interval=1s
/routing ospf network
add area=backbone network=192.168.2.0/30
add area=backbone network=192.168.3.0/30
add area=backbone network=192.168.1.0/24
/system identity
set name=R1
R2
/interface bridge
add name=LOOPBACK
/interface gre
add local-address=10.10.10.20 name=gre-tunnel1 remote-address=10.10.10.30
/routing ospf instance
set [ find default=yes ] name=R2 redistribute-connected=as-type-1 \
    redistribute-static=as-type-1 router-id=10.10.10.20
add distribute-default=always-as-type-1 name=Area1-R2 redistribute-connected=\
    as-type-1 redistribute-static=as-type-1 router-id=10.10.10.20
/routing ospf area
add area-id=0.0.0.1 instance=Area1-R2 name=Area1
/ip address
add address=192.168.4.1/24 interface=ether1
add address=192.168.2.2/30 interface=ether2
add address=192.168.3.2/30 interface=ether3
add address=10.10.10.20/32 interface=LOOPBACK network=10.10.10.20
add address=192.168.50.1/30 disabled=yes interface=gre-tunnel1
/routing ospf interface
add dead-interval=2s hello-interval=1s interface=ether2 network-type=broadcast \
    retransmit-interval=1s
add cost=11 dead-interval=2s hello-interval=1s interface=ether3 network-type=\
    broadcast priority=2 retransmit-interval=1s
add dead-interval=2s hello-interval=1s interface=ether1 network-type=broadcast \
    retransmit-interval=1s
add dead-interval=2s hello-interval=1s interface=gre-tunnel1 network-type=\
    point-to-point passive=yes retransmit-interval=1s
/routing ospf network
add area=backbone network=192.168.2.0/30
add area=backbone network=192.168.3.0/30
add area=Area1 network=192.168.4.0/24
add area=Area1 disabled=yes network=192.168.50.0/30
/system identity
set name=R2
R3
/interface bridge
add name=LOOPBACK
/interface gre
add local-address=10.10.10.30 name=gre-tunnel1 remote-address=10.10.10.20
/routing ospf area
add area-id=0.0.0.1 name=Area1
/routing ospf instance
set [ find default=yes ] name=R3 redistribute-connected=as-type-1 \
    redistribute-static=as-type-1 router-id=10.10.10.30
add distribute-default=always-as-type-1 name=R3-Area2 redistribute-connected=\
    as-type-1 redistribute-static=as-type-1 router-id=10.10.10.30
/routing ospf area
add area-id=0.0.0.2 instance=R3-Area2 name=Area2
/ip address
add address=192.168.4.2/24 interface=ether1
add address=192.168.5.1/24 interface=ether2
add address=10.10.10.30/32 interface=LOOPBACK network=10.10.10.30
add address=192.168.6.1/30 interface=ether3
add address=192.168.50.2/30 disabled=yes interface=gre-tunnel1
/routing ospf interface
add dead-interval=2s hello-interval=1s interface=ether1 network-type=broadcast \
    retransmit-interval=1s
add dead-interval=2s hello-interval=1s interface=ether3 network-type=broadcast \
    retransmit-interval=1s
add dead-interval=2s hello-interval=1s interface=gre-tunnel1 network-type=\
    point-to-point passive=yes retransmit-interval=1s
/routing ospf network
add area=Area1 network=192.168.4.0/24
add area=Area2 network=192.168.6.0/30
add area=Area1 disabled=yes network=192.168.50.0/30
/system identity
set name=R3
R4
/interface bridge
add name=LOOPBACK
/routing ospf area
add area-id=0.0.0.2 name=Area2
/routing ospf instance
set [ find default=yes ] name=R4 redistribute-connected=as-type-1 \
    redistribute-static=as-type-1 router-id=10.10.10.40
/ip address
add address=10.10.10.40/32 interface=LOOPBACK network=10.10.10.40
add address=192.168.6.2/30 interface=ether1
add address=192.168.7.1/24 interface=ether2
/routing ospf interface
add dead-interval=2s hello-interval=1s interface=ether1 network-type=broadcast \
    retransmit-interval=1s
/routing ospf network
add area=Area2 network=192.168.6.0/30
/system identity
set name=R4
As you can see I've tried to establish GRE tunnel (now disabled only on ospf) betwenn R2 and R3 (area1) but with no good result, only starting a ping on GRE interface i can reach the remote end (R4).I hope in your help.....
Thanks for your support!
Regards
MTCNA - MTCRE - MTCWE
 
sparrow
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 52
Joined: Wed Jul 11, 2012 10:59 am

Re: OSPF GRE or IPIP or EOIP instead virtual link

Tue Apr 16, 2013 9:56 am

Guys no one has a solution for me?
MTCNA - MTCRE - MTCWE
 
sparrow
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 52
Joined: Wed Jul 11, 2012 10:59 am

Re: OSPF GRE or IPIP or EOIP instead of virtual link

Mon Apr 22, 2013 12:10 pm

Guys, it's never possible that no one know a solution about this problem?
I hope in yours help
Thanks
Regards
Last edited by sparrow on Tue Apr 23, 2013 6:57 pm, edited 1 time in total.
MTCNA - MTCRE - MTCWE
 
sparrow
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 52
Joined: Wed Jul 11, 2012 10:59 am

Re: OSPF GRE or IPIP or EOIP instead of virtual link

Tue Apr 23, 2013 6:57 pm

Thanks Solved!!
MTCNA - MTCRE - MTCWE
 
darbeau
just joined
Posts: 2
Joined: Wed Jul 04, 2012 8:37 pm

Re: OSPF GRE or IPIP or EOIP instead of virtual link

Sat May 18, 2013 10:47 am

Hi,

Can you share how you solved the issue? I am running into some of the same problems.

Thank you kindly,
Dan
 
sparrow
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 52
Joined: Wed Jul 11, 2012 10:59 am

Re: OSPF GRE or IPIP or EOIP instead of virtual link

Wed Nov 19, 2014 7:04 pm

Hi,

Can you share how you solved the issue? I am running into some of the same problems.

Thank you kindly,
Dan
Here a simple guide:

http://www.routerositalia.net/forum/vie ... =36&t=1915
MTCNA - MTCRE - MTCWE
 
tania
newbie
Posts: 42
Joined: Fri Feb 07, 2014 10:15 am

Re: OSPF GRE or IPIP or EOIP instead of virtual link

Sun Jan 11, 2015 10:21 am

Who is online

Users browsing this forum: No registered users and 8 guests