Page 1 of 1

GRE tunnel problem

Posted: Mon Jul 29, 2013 2:24 pm
by simaskkk
I need to establish two parallel GRE tunnels between same MikroTik routers (one tunnel interface is on one vrf, second is on another). I have no problems with first GRE tunnel.

To configure second tunnel, I give additional (secondary) IP on WAN interface for both routers and use those IPs as GRE tunnel end-points. Because end-point IPs are different it shouldn’t be a problem for router to distinguish for which tunnel GRE packet belongs when it arrives to device, however it isn't working. I can see packets are sent out via GRE interface, but they don't arrive to another end of the tunnel.

I verified connectivity between secondary IPs, it is fine.
RouterOS ver. 6.1 , model RB750.

Any ideas how to solve it ? It seems like a bug for me. Same problems happens with IPIP tunnels as well.

Re: GRE tunnel problem

Posted: Mon Jul 29, 2013 8:38 pm
by samsung172
do you try pptp (gre) behind nat? A lot of nat routers, don't support more than one gre.

Re: GRE tunnel problem

Posted: Mon Jul 29, 2013 8:47 pm
by simaskkk
There are no NAT anywhere in the topology. PPTP isn't an option because of the company policy (because of the weak security). GRE tunnels will be protected by IPSec VPN (this is next thing I'll be testing after this), but now I need to solve this problem.
RouterOS allows to create multiple tunnels, so it implies, that it support it :)

Re: GRE tunnel problem

Posted: Tue Jul 30, 2013 2:11 pm
by simaskkk
I connected sniffer today and was able to sniff the traffic, it seems RouterOS is ignoring "Local Address" setting in the GRE interface configuration. No matter what address is set in this field, it is ignored and IP of outgoing interface is used.

Re: GRE tunnel problem

Posted: Tue Jul 30, 2013 2:23 pm
by efaden
I connected sniffer today and was able to sniff the traffic, it seems RouterOS is ignoring "Local Address" setting in the GRE interface configuration. No matter what address is set in this field, it is ignored and IP of outgoing interface is used.
Have you tried another tunnel type? EoIP or IPIP?

Re: GRE tunnel problem

Posted: Mon Aug 05, 2013 3:42 pm
by simaskkk
It was my mistake in configuration, sorry to bother you with this :)