Community discussions

MUM Europe 2020
 
ropeba
Member Candidate
Member Candidate
Topic Author
Posts: 220
Joined: Sat Jul 29, 2006 4:13 pm

IPv6 work only after disable/enable address

Tue Dec 03, 2013 5:20 am

I have a problem on all routers in my network. Sometime IPv6 address stop to work and after disable/enable IPv6 address everything work ok. I have this problem on all routers and on all versions ROS, does someone have solution for the problem?

scenario:

1. add ip address to interface

2. ping gateway:
xxxx:xxxx::1 56 62 1ms echo reply
xxxx:xxxx::1 56 62 1ms echo reply
xxxx:xxxx::1 56 62 1ms echo reply
xxxx:xxxx::1 56 62 1ms echo reply

3. add default route

4. ping gateway:

xxxx:xxxx::1 timeout
xxxx:xxxx::1 timeout
xxxx:xxxx::1 timeout
xxxx:xxxx::1 timeout

5. disable/enable ipv6 address

6. ping gateway:
xxxx:xxxx::1 56 62 1ms echo reply
xxxx:xxxx::1 56 62 1ms echo reply
xxxx:xxxx::1 56 62 1ms echo reply
xxxx:xxxx::1 56 62 1ms echo reply

Same problem when I reconnect PPPoE client(disable pppoe-out1 on WAN port), I must disable/enable IPv6 address on a LAN interface to work.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: IPv6 work only after disable/enable address

Tue Dec 03, 2013 10:23 am

where you have PPPoE try RouterOS 6.7 the other issue is still in the works (disable/enable for ipv6 address to work again)
 
ropeba
Member Candidate
Member Candidate
Topic Author
Posts: 220
Joined: Sat Jul 29, 2006 4:13 pm

Re: IPv6 work only after disable/enable address

Tue Dec 03, 2013 12:56 pm

I have same problem on 6.7. When client is reconnected with PPPoE IPv6 is not working anymore so IPv6 must be disabled/enabled on LAN interface on CPE router.
 
hci
Long time Member
Long time Member
Posts: 600
Joined: Fri May 28, 2004 5:10 pm

Re: IPv6 work only after disable/enable address

Tue Dec 03, 2013 6:10 pm

I am having similar problem. Causes long delays until PC figures out IPv6 does not work.
 
TonyJr
Member Candidate
Member Candidate
Posts: 201
Joined: Sat Nov 12, 2011 1:30 am
Location: UK
Contact:

Re: IPv6 work only after disable/enable address

Thu Dec 05, 2013 12:53 am

I have a problem on all routers in my network. Sometime IPv6 address stop to work and after disable/enable IPv6 address everything work ok. I have this problem on all routers and on all versions ROS, does someone have solution for the problem?

scenario:

1. add ip address to interface

2. ping gateway:
xxxx:xxxx::1 56 62 1ms echo reply
xxxx:xxxx::1 56 62 1ms echo reply
xxxx:xxxx::1 56 62 1ms echo reply
xxxx:xxxx::1 56 62 1ms echo reply

3. add default route

4. ping gateway:

xxxx:xxxx::1 timeout
xxxx:xxxx::1 timeout
xxxx:xxxx::1 timeout
xxxx:xxxx::1 timeout

5. disable/enable ipv6 address

6. ping gateway:
xxxx:xxxx::1 56 62 1ms echo reply
xxxx:xxxx::1 56 62 1ms echo reply
xxxx:xxxx::1 56 62 1ms echo reply
xxxx:xxxx::1 56 62 1ms echo reply

Same problem when I reconnect PPPoE client(disable pppoe-out1 on WAN port), I must disable/enable IPv6 address on a LAN interface to work.
I had this problem with 5.x I cannot remember which versions specifically. It was fixed in a later release. Anyway, I had a script that ran when a certain IPv6 host could not be contacted, I think using netwatch. Then the script disabled, paused, enabled the required interfaces. In one of the 5.x versions, I even had to re-set the IPv6 address in the script otherwise the interface became invalid.
:global HEpassword "xxx"
:global HEtid "xxx"
:global HEint "sit1"
:global HEwan "vlan9"
:log info ("HE-UPD: Finding wan IP")
:global HEcurrentIP [/ip address get [/ip address find interface="$HEwan"] address]
:log info ("HE-UPD: $HEcurrentIP")
:set HEcurrentIP [:pick $HEcurrentIP 0 [:find $HEcurrentIP "/"]]
:log info ("HE-UPD: $HEcurrentIP")
:log info ("HE-UPD: ---6to4 update being attempted interface---")
/interface 6to4 set "$HEint" disabled=yes
:log info ("HE-UPD: sit1 disabled")
/interface 6to4 set "$HEint" disabled=no local-address=$HEcurrentIP
:log info ("HE-UPD: 6to4 new v4addr set and re-enabled")
:log info ("HE-UPD: Start Fetch")
/tool fetch mode=http port=80 address=ipv4.tunnelbroker.net host=ipv4.tunnelbroker.net src-path="/ipv4_end.php\?ipv4b=$HEcurrentIP&pass=$HEpassword&user_id=$HEusername&tunnel_id=$HEtid" dst-path="henet.txt"
:delay 1
:log info ("HE-UPD: Fetch done")
:global 6to4OUT [/file get henet.txt contents]
:put ("HE-UPD: Update Result: $6to4OUT")
:log info "HE-UPD: 6to4 update result was '$6to4OUT'"
:log info ("HE-UPD: Re-enable LAN again")
:local lan6 [/ipv6 address find address="2001:470:xxxx:1::1/64"]
/ipv6 address set $lan6 disabled=yes
/ipv6 address set $lan6 disabled=no
[b]:log info ("HE-UPD: Re-enable GellNet again")
[b]:local gellnet6 [/ipv6 address find address="2001:470:xxxx:2::1/64"]
/ipv6 address set $gellnet6 disabled=yes
/ipv6 address set $gellnet6 disabled=no
:log info ("HE-UPD: Re-enable GellNet-IPv6 again")
:local gellnet6native [/ipv6 address find address="2001:470:xxxx:3::1/64"][/b]
/ipv6 address set $gellnet6native disabled=yes
/ipv6 address set $gellnet6native disabled=no
:log info ("HE-UPD: Re-enable sit1 address")
:local sit1local [/ipv6 address find address="2001:470:1f08:xxxx::2/64"]
/ipv6 address set $sit1local disabled=yes
/ipv6 address set $sit1local disabled=no
:log info ("HE-UPD: Refresh 2k route")
   /ipv6 route remove [/ipv6 route find dst-address="2000::/3"]
   /ipv6 route add comment="" disabled=no distance=1 dst-address=2000::/3 gateway=2001:470:1f08:xxxx::1 scope=30 target-scope=10
:log info ("HE-UPD: Refresh default route")
   /ipv6 route remove [/ipv6 route find dst-address="::/0"]
   /ipv6 route add comment="" disabled=no distance=1 dst-address=::/0 gateway=2001:470:1f08:xxxx::1 scope=30 target-scope=10
:log info ("HE-UPD: 6to4 update complete")
Good luck!
 
ropeba
Member Candidate
Member Candidate
Topic Author
Posts: 220
Joined: Sat Jul 29, 2006 4:13 pm

Re: IPv6 work only after disable/enable address

Thu Dec 05, 2013 2:19 am

I have a problem with IPv6 address on LAN interface when disable/enable or reconect wan (PPPoE client interface). I can ping IPv6 destination from router but not from PC. And problem persist on 6.7, you can see on video.
http://youtu.be/6Mo1HN4y6ug
 
TonyJr
Member Candidate
Member Candidate
Posts: 201
Joined: Sat Nov 12, 2011 1:30 am
Location: UK
Contact:

Re: IPv6 work only after disable/enable address

Thu Dec 05, 2013 2:25 am

I have a problem with IPv6 address on LAN interface when disable/enable or reconect wan (PPPoE client interface). I can ping IPv6 destination from router but not from PC. And problem persist on 6.7, you can see on video.
http://youtu.be/6Mo1HN4y6ug

Looks like the old problem I used to have. Router Advertisements send stale information or: Stop when disable interface, but do not start when enable interface. Changing something else after, helps it along.

See the script I posted about half way through, how to find route with script, disable and enable it. Attach script to netwatch for an ipv6 address.

Hope this helps.

Tony
 
Leto
just joined
Posts: 16
Joined: Wed Aug 10, 2011 9:25 pm

Re: IPv6 work only after disable/enable address

Mon Dec 30, 2013 7:01 am

Having the same problem, makes ipv6 unusable.

Who is online

Users browsing this forum: No registered users and 6 guests