Community discussions

MikroTik App
 
andersm
just joined
Topic Author
Posts: 10
Joined: Fri Sep 14, 2012 3:52 pm

LDP Neighbour Failure

Wed Apr 30, 2014 5:49 pm

Hi,

I am having issues with an LDP dynamic neighbour dropping its listed addresses after approx. 10 seconds.

On initial connection, all the neighbours addresses appear and I can happily pass traffic over that section of the network using MPLS VPN4.
After a few seconds, the LDP neighbour drops all its addresses and the traffic stops.

Other neighbours and their addresses to that router all stay connected, and never drop.

I have compared all the settings to other routers on the network, and all looks ok.
Rebooting the neighbour brings the addresses back, but then once again it "times out"

Has anyone else had this happen, and come up with a fix?

Running on a CCR1036 v6.12

Cheers,
Andy
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1189
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: LDP Neighbour Failure

Sat May 03, 2014 3:00 am

What kind of link is it to the other router? Is there any kind of packet loss over that link. Is the routing that LDP rides on stable?
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com
 
andersm
just joined
Topic Author
Posts: 10
Joined: Fri Sep 14, 2012 3:52 pm

Re: LDP Neighbour Failure

Sat May 03, 2014 11:07 am

Hi IPANetEngineer,

The link is a licensed 18GHz radio. It supports jumbo frames, and can happily pass 2500 byte pings, with no fragmentation.
It is running rock stable, as the back haul network between the sites happily runs at 1-2ms pings and can support over 350mbps throughput.

The network runs RIP v2 to route the base network, then MPLS ontop of that, with BGP to distribute the VPN4 VRF's
This same config has worked rock stable across other areas of the network for many months now, without any issues.

I talked to another engineer where I live, and he said he has had the exact same thing happen. He ended up defaulting the router and manually re-building the config.
I tried that, and its now working perfectly, reloading the config from an export.

I am worried that it might be a bug in RouterOS, and was interested if anyone else has had the same issue.

It just seems odd that the LDP dynamic neighbour comes up, it shows the connected networks, the VRF's pass traffic then about 15 seconds later the neighbours listed networks vanish.
The opposite end of the link still shows its connected and can see the neighbours networks listed.
[user@router] /mpls ldp neighbor> pr de
Flags: X - disabled, D - dynamic, O - operational, T - sending-targeted-hello, 
V - vpls 
 0 DO   transport=172.16.254.32 send-targeted=no peer=172.16.254.32:0 
        local-transport=172.16.254.33 
        addresses=10.0.14.1,172.16.16.4,172.16.56.17,172.16.66.4,172.16.254.32 

 1 DO   transport=172.16.254.36 send-targeted=no peer=172.16.254.36:0 
        local-transport=172.16.254.33 
        addresses=""
Hopefully after the re-build it won't do it again… has been running very stable for the last 48hrs so far.

Andy.

Who is online

Users browsing this forum: No registered users and 8 guests