Community discussions

 
kellogs
Member Candidate
Member Candidate
Topic Author
Posts: 114
Joined: Sun Jan 04, 2009 10:55 am

migrating cisco to mikrotik

Fri Aug 01, 2014 1:39 pm

Dear Member

I have the following config on Cisco

interface FastEthernet0/0
ip address 2.1.1.1 255.255.255.252

interface FastEthernet0/1
ip address 1.1.1.1 255.255.255.252

interface Vlan1
description -=LAN-1=-
ip address 192.168.1.1 255.255.255.0

Interface 0/0 and 0/1 IPs are for BGP with 2 upstream and Vlan1 is the LAN IP. I have assigned those 3 IPs onto mikrotik individual eth interface.

Interface 0/0 -> Mikrotik ether1-BGP1
Interface 0/1 -> Mikrotik ether2-BGP2
Interface Vlan1 -> Mikrotik ether3-LAN

Cisco BGP config has

network 4.4.4.4 mask 255.255.255.240
network 5.5.5.5 mask 255.255.255.240

I am unable to add 4.4.4.4/30 and 5.5.5.5/30 into Mikrotik->BGP->Networks since those IP Networks are not assigned to any Mikrotik interface.

In this scenario, should i create a bridge on mikrotik with ether1 and ether2 as members and assign 4.4.4.4/30 and 5.5.5.5/30 onto the bridge interface?

The cisco router also has the following config

ip nat inside source static 192.168.1.111 4.4.4.6
ip nat inside source static 192.168.1.112 4.4.4.7
ip nat inside source static 192.168.1.113 5.5.5.7
ip nat inside source static 192.168.1.114 5.5.5.8

I would like to setup the same on Mikrotik using DNAT but Where should i assign the IP address of 4.4.46, 4.4.4.7, 5.5.5.7 and 5.5.5.8 on Mikrotik? The bridge interface?

Thanks!
 
lz1dsb
Member Candidate
Member Candidate
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

Re: migrating cisco to mikrotik

Fri Aug 01, 2014 2:28 pm

Dear Member

I have the following config on Cisco

interface FastEthernet0/0
ip address 2.1.1.1 255.255.255.252

interface FastEthernet0/1
ip address 1.1.1.1 255.255.255.252

interface Vlan1
description -=LAN-1=-
ip address 192.168.1.1 255.255.255.0

Interface 0/0 and 0/1 IPs are for BGP with 2 upstream and Vlan1 is the LAN IP. I have assigned those 3 IPs onto mikrotik individual eth interface.

Interface 0/0 -> Mikrotik ether1-BGP1
Interface 0/1 -> Mikrotik ether2-BGP2
Interface Vlan1 -> Mikrotik ether3-LAN

Cisco BGP config has

network 4.4.4.4 mask 255.255.255.240
network 5.5.5.5 mask 255.255.255.240

I am unable to add 4.4.4.4/30 and 5.5.5.5/30 into Mikrotik->BGP->Networks since those IP Networks are not assigned to any Mikrotik interface.

In this scenario, should i create a bridge on mikrotik with ether1 and ether2 as members and assign 4.4.4.4/30 and 5.5.5.5/30 onto the bridge interface?

The cisco router also has the following config

ip nat inside source static 192.168.1.111 4.4.4.6
ip nat inside source static 192.168.1.112 4.4.4.7
ip nat inside source static 192.168.1.113 5.5.5.7
ip nat inside source static 192.168.1.114 5.5.5.8

I would like to setup the same on Mikrotik using DNAT but Where should i assign the IP address of 4.4.46, 4.4.4.7, 5.5.5.7 and 5.5.5.8 on Mikrotik? The bridge interface?

Thanks!
You can use a bridge interface in the RouterOS... if it's not assigned to any physical port or ports, it behaves pretty much like a Loopback interface in the IOS.
Regarding the NAT... check out this example&
http://wiki.mikrotik.com/wiki/Manual:IP ... Source_NAT

to give you an example in your case:
/ip firewall nat add chain=dstnat dst-address=4.4.4.6 \
to-addresses=192.168.1.111

/ip firewall nat add chain=srcnat src-address=192.168.1.11 \
to-addresses=4.4.4.6

Who is online

Users browsing this forum: No registered users and 14 guests