Community discussions

 
2dfx
just joined
Topic Author
Posts: 22
Joined: Tue Mar 05, 2013 6:30 pm

OSPF between Mikrotik and Linux loses routes

Sat Oct 18, 2014 6:34 pm

Hi!

I have two routers.
One mikrotik and second Linux with quagga.
Mikrotik should be distribute default route, linux should distribute the route to network behind it.

Network:
0/0|10.8.2.10/24 (gateway) <-> 10.8.2.252/24|10.10.15.8/24 (mikrotik) <-> 10.10.15.10/24|10.9.6.1/24 (linux)

After start this scheme - all work fine.
Linux router have default route comming from 10.10.15.8
Mikrotik have route to 10.9.6.0/24 fom 10.10.15.10

But after 5 min work - mikrotik lost route 10.9.6.0/24

Mikrotik:
RouterOS 6.20
BoardName CCR1036-8G-2S+
Firmware 3.19
/ip address print
Flags: X - disabled, I - invalid, D - dynamic 
 #   ADDRESS            NETWORK         INTERFACE  
 4   10.8.2.252/24      10.8.2.0        Roting_Lan                                                                            
 5   10.8.2.1/32        10.8.2.1        Routing_Lan_VRRP
21   10.10.15.8/24      10.10.15.0      Core


/ip route print 
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 A S  0.0.0.0/0                          10.8.2.10                 1
 9 ADC  10.8.2.0/24        10.8.2.252      Roting_Lan                0
10 ADC  10.8.2.1/32        10.8.2.1        Routing_Lan_VRRP          0
27  Do  10.9.6.0/24                        10.10.15.10             110
30 ADC  10.10.15.0/24      10.10.15.8      Core                      0

/routing export 
/routing ospf instance
set [ find default=yes ] distribute-default=always-as-type-1 redistribute-connected=as-type-1 redistribute-static=as-type-1 router-id=10.10.15.8
/routing filter
add action=accept chain=ospf-in prefix=10.0.0.0/8 prefix-length=8-30
add action=accept chain=ospf-in prefix=172.16.0.0/12 prefix-length=12-30
add action=accept chain=ospf-in prefix=192.168.0.0/16 prefix-length=16-30
add action=discard chain=ospf-in disabled=yes prefix=0.0.0.0/0 prefix-length=0
add action=discard chain=ospf-in
add action=accept chain=ospf-out prefix=0.0.0.0/0 prefix-length=0
add action=discard chain=ospf-out
/routing ospf area range
add area=backbone
/routing ospf network
add area=backbone network=10.10.15.0/24
add area=backbone disabled=yes

Linux config
Ip addresses:
10.10.15.0/24 dev eth1  proto kernel  scope link  src 10.10.15.10
10.9.6.0/24 dev eth0  proto kernel  scope link  src 10.9.6.1

Running config ospfd:
Current configuration:
!
hostname ospfd1
password 8 1234
log stdout
service password-encryption
!
!
!
interface eth0
!
interface eth1
 ip ospf cost 50
!
interface eth2
!
interface eth3
!
interface lo
!
router ospf
 ospf router-id 10.10.15.10
 redistribute connected route-map ospf-out
 redistribute static route-map ospf-out
 network 10.10.15.0/24 area 0.0.0.0
!
ip prefix-list ospf-out seq 10 permit 10.9.0.0/16 ge 23 le 24
ip prefix-list ospf-out seq 30000 deny 0.0.0.0/0 le 32
!
route-map ospf-out permit 10
 match ip address prefix-list ospf-out
!
route-map ospf-out deny 30000
!
line vty
!
end
I try to get log from mikrotik.
After next route will be lost:
route,ospf,debug RECV: Database Description <- 10.10.15.10 on Core (10.10.15.8) in 18-Oct 18:43:32.45 from 10.8.1.252
route,ospf,debug,raw PACKET: in 18-Oct 18:43:32.46 from 10.8.1.252
route,ospf,debug,raw     45 C0 00 34 73 71 00 00 01 59 13 1B 0A 0A 0F 0A in 18-Oct 18:43:32.46 from 10.8.1.252
route,ospf,debug,raw     0A 0A 0F 08 02 02 00 20 0A 0A 0F 0A 00 00 00 00 in 18-Oct 18:43:32.47 from 10.8.1.252
route,ospf,debug,raw     5F 18 00 00 00 00 00 00 00 00 00 00 05 DC 02 07 in 18-Oct 18:43:32.48 from 10.8.1.252
route,ospf,debug,raw     54 5E 29 70 in 18-Oct 18:43:32.48 from 10.8.1.252
route,ospf,info Database Description packet has init bit set in middle of an exchange in 18-Oct 18:43:32.49 from 10.8.1.252
route,ospf,info OSPFv2 neighbor 10.10.15.10: state change from Full to 2-Way in 18-Oct 18:43:32.50 from 10.8.1.252
route,ospf,debug Originate Router LSA in 18-Oct 18:43:32.50 from 10.8.1.252
route,ospf,debug     area=backbone in 18-Oct 18:43:32.51 from 10.8.1.252
route,ospf,debug Installing an LSA in 18-Oct 18:43:32.52 from 10.8.1.252
route,ospf,debug     lsa=Router LSA id=10.10.15.8 originator=10.10.15.8 seqnum=0x80000051 in 18-Oct 18:43:32.53 from 10.8.1.252
route,ospf,debug     old=Router LSA id=10.10.15.8 originator=10.10.15.8 seqnum=0x80000050 in 18-Oct 18:43:32.54 from 10.8.1.252
route,ospf,debug Flooding an LSA in 18-Oct 18:43:32.54 from 10.8.1.252
route,ospf,debug     lsa=Router LSA id=10.10.15.8 originator=10.10.15.8 seqnum=0x80000051 in 18-Oct 18:43:32.55 from 10.8.1.252
route,ospf,debug     area=backbone in 18-Oct 18:43:32.56 from 10.8.1.252
route,ospf,debug Deleting an LSA in 18-Oct 18:43:32.57 from 10.8.1.252
route,ospf,debug     lsa=Router LSA id=10.10.15.8 originator=10.10.15.8 seqnum=0x80000050 in 18-Oct 18:43:32.58 from 10.8.1.252
route,ospf,debug Should form adjacency: yes, I am DR/BDR in 18-Oct 18:43:33.13 from 10.8.1.252
route,ospf,debug     remoteID=10.10.15.10 in 18-Oct 18:43:33.14 from 10.8.1.252
route,ospf,debug Starting Database Description exchanges in 18-Oct 18:43:33.15 from 10.8.1.252
route,ospf,debug     neighbor=10.10.15.10 in 18-Oct 18:43:33.15 from 10.8.1.252
route,ospf,debug SEND: Database Description 10.10.15.8 -> 10.10.15.10 on Core in 18-Oct 18:43:33.16 from 10.8.1.252
route,ospf,debug,raw PACKET: in 18-Oct 18:43:33.17 from 10.8.1.252
route,ospf,debug,raw     02 02 00 20 0A 0A 0F 08 00 00 00 00 22 B7 00 00 in 18-Oct 18:43:33.18 from 10.8.1.252
route,ospf,debug,raw     00 00 00 00 00 00 00 00 05 DC 42 07 54 5E 25 D3 in 18-Oct 18:43:33.18 from 10.8.1.252
route,ospf,debug OSPFv2 neighbor 10.10.15.10: state change from 2-Way to ExStart in 18-Oct 18:43:33.19 from 10.8.1.252
route,ospf,debug Recalculating all OSPFv2 intra-area routes in 18-Oct 18:43:34.14 from 10.8.1.252
route,ospf,debug Recalculating all inter-area routes in 18-Oct 18:43:34.14 from 10.8.1.252
route,ospf,debug     summary-area=backbone in 18-Oct 18:43:34.15 from 10.8.1.252
route,ospf,debug Recalculating AS-external routes in 18-Oct 18:43:34.16 from 10.8.1.252
route,debug,calc Begin calculation in 18-Oct 18:43:34.24 from 10.8.1.252
route,debug,event Removed route in 18-Oct 18:43:34.24 from 10.8.1.252
route,debug,event     state=ACTIVE in 18-Oct 18:43:34.25 from 10.8.1.252
route,debug,event     dst-prefix=10.9.6.0/24 in 18-Oct 18:43:34.26 from 10.8.1.252
route,debug,event     attributes in 18-Oct 18:43:34.27 from 10.8.1.252
route,debug,event         protocol=OSPF in 18-Oct 18:43:34.28 from 10.8.1.252
route,debug,event         scope=20 in 18-Oct 18:43:34.28 from 10.8.1.252
route,debug,event         next-hop= address=10.10.15.10 in 18-Oct 18:43:34.29 from 10.8.1.252
route,debug,event         origin-type=OSPF in 18-Oct 18:43:34.30 from 10.8.1.252
route,debug,event         origin-instance-id=0 in 18-Oct 18:43:34.31 from 10.8.1.252
route,debug,event         ospf-metric=10 in 18-Oct 18:43:34.31 from 10.8.1.252
route,debug,event         ospf-type=external-type-2 in 18-Oct 18:43:34.32 from 10.8.1.252
route,debug,calc End calculation in 18-Oct 18:43:34.33 from 10.8.1.252
route,debug Begin redistribution in 18-Oct 18:43:34.34 from 10.8.1.252
route,debug Accept withdraw 10.9.6.0/24 in 18-Oct 18:43:34.34 from 10.8.1.252
route,debug Commit prefix 10.9.6.0/24 in 18-Oct 18:43:34.35 from 10.8.1.252
route,debug End redistribution in 18-Oct 18:43:34.36 from 10.8.1.252
And after next route added again:
route,ospf,debug RECV: Link State Update <- 10.10.15.10 on Core (10.10.15.8) in 18-Oct 18:44:17.79 from 10.8.1.252
route,ospf,debug,raw PACKET: in 18-Oct 18:44:17.80 from 10.8.1.252
route,ospf,debug,raw     45 C0 00 98 73 8C 00 00 01 59 4B A8 0A 0A 0F 0A in 18-Oct 18:44:17.80 from 10.8.1.252
route,ospf,debug,raw     E0 00 00 05 02 04 00 84 0A 0A 0F 0A 00 00 00 00 in 18-Oct 18:44:17.81 from 10.8.1.252
route,ospf,debug,raw     FC 45 00 00 00 00 00 00 00 00 00 00 00 00 00 03 in 18-Oct 18:44:17.82 from 10.8.1.252
route,ospf,debug,raw     00 01 02 05 0A 09 06 00 0A 0A 0F 0A 80 00 00 1D in 18-Oct 18:44:17.82 from 10.8.1.252
route,ospf,debug,raw     F1 6A 00 24 FF FF FF 00 80 00 00 14 00 00 00 00 in 18-Oct 18:44:17.83 from 10.8.1.252
route,ospf,debug,raw     00 00 00 00 00 01 02 01 0A 0A 0F 0A 0A 0A 0F 0A in 18-Oct 18:44:17.84 from 10.8.1.252
route,ospf,debug,raw     80 00 00 37 41 F3 00 24 02 00 00 01 0A 0A 0F 0A in 18-Oct 18:44:17.85 from 10.8.1.252
route,ospf,debug,raw     0A 0A 0F 0A 02 00 00 32 00 01 02 02 0A 0A 0F 0A in 18-Oct 18:44:17.86 from 10.8.1.252
route,ospf,debug,raw     0A 0A 0F 0A 80 00 00 0D B9 E1 00 20 FF FF FF 00 in 18-Oct 18:44:17.87 from 10.8.1.252
route,ospf,debug,raw     0A 0A 0F 08 0A 0A 0F 0A in 18-Oct 18:44:17.88 from 10.8.1.252
route,ospf,debug LSA Update received: Installing and flooding it in 18-Oct 18:44:17.89 from 10.8.1.252
route,ospf,debug     header=AS-External LSA id=10.9.6.0 originator=10.10.15.10 seqnum=0x8000001d in 18-Oct 18:44:17.89 from 10.8.1.252
route,ospf,debug Installing an LSA in 18-Oct 18:44:17.90 from 10.8.1.252
route,ospf,debug     lsa=AS-External LSA id=10.9.6.0 originator=10.10.15.10 seqnum=0x8000001d in 18-Oct 18:44:17.91 from 10.8.1.252
route,ospf,debug     old=AS-External LSA id=10.9.6.0 originator=10.10.15.10 seqnum=0x8000001c in 18-Oct 18:44:17.92 from 10.8.1.252
route,ospf,debug Deleting an LSA in 18-Oct 18:44:17.93 from 10.8.1.252
route,ospf,debug     lsa=AS-External LSA id=10.9.6.0 originator=10.10.15.10 seqnum=0x8000001c in 18-Oct 18:44:17.94 from 10.8.1.252
route,ospf,debug LSA Update received: Installing and flooding it in 18-Oct 18:44:17.94 from 10.8.1.252
route,ospf,debug     header=Router LSA id=10.10.15.10 originator=10.10.15.10 seqnum=0x80000037 in 18-Oct 18:44:17.96 from 10.8.1.252
route,ospf,debug Installing an LSA in 18-Oct 18:44:17.96 from 10.8.1.252
route,ospf,debug     lsa=Router LSA id=10.10.15.10 originator=10.10.15.10 seqnum=0x80000037 in 18-Oct 18:44:17.97 from 10.8.1.252
route,ospf,debug     old=Router LSA id=10.10.15.10 originator=10.10.15.10 seqnum=0x80000036 in 18-Oct 18:44:17.98 from 10.8.1.252
route,ospf,debug Flooding an LSA in 18-Oct 18:44:17.99 from 10.8.1.252
route,ospf,debug     lsa=Router LSA id=10.10.15.10 originator=10.10.15.10 seqnum=0x80000037 in 18-Oct 18:44:18.0 from 10.8.1.252
route,ospf,debug     area=backbone in 18-Oct 18:44:18.0 from 10.8.1.252
route,ospf,debug Deleting an LSA in 18-Oct 18:44:18.1 from 10.8.1.252
route,ospf,debug     lsa=Router LSA id=10.10.15.10 originator=10.10.15.10 seqnum=0x80000036 in 18-Oct 18:44:18.2 from 10.8.1.252
route,ospf,debug LSA Update received: Installing and flooding it in 18-Oct 18:44:18.3 from 10.8.1.252
route,ospf,debug     header=Network LSA id=10.10.15.10 originator=10.10.15.10 seqnum=0x8000000d in 18-Oct 18:44:18.4 from 10.8.1.252
route,ospf,debug Installing an LSA in 18-Oct 18:44:18.4 from 10.8.1.252
route,ospf,debug     lsa=Network LSA id=10.10.15.10 originator=10.10.15.10 seqnum=0x8000000d in 18-Oct 18:44:18.5 from 10.8.1.252
route,ospf,debug Flooding an LSA in 18-Oct 18:44:18.6 from 10.8.1.252
route,ospf,debug     lsa=Network LSA id=10.10.15.10 originator=10.10.15.10 seqnum=0x8000000d in 18-Oct 18:44:18.7 from 10.8.1.252
route,ospf,debug     area=backbone in 18-Oct 18:44:18.8 from 10.8.1.252
route,ospf,debug RECV: Link State Acknowledgement <- 10.10.15.10 on Core (10.10.15.8) in 18-Oct 18:44:18.9 from 10.8.1.252
route,ospf,debug,raw PACKET: in 18-Oct 18:44:18.9 from 10.8.1.252
route,ospf,debug,raw     45 C0 00 54 73 8D 00 00 01 59 4B EB 0A 0A 0F 0A in 18-Oct 18:44:18.10 from 10.8.1.252
route,ospf,debug,raw     E0 00 00 05 02 05 00 40 0A 0A 0F 0A 00 00 00 00 in 18-Oct 18:44:18.11 from 10.8.1.252
route,ospf,debug,raw     88 2A 00 00 00 00 00 00 00 00 00 00 00 10 02 01 in 18-Oct 18:44:18.12 from 10.8.1.252
route,ospf,debug,raw     0A 0A 0F 08 0A 0A 0F 08 80 00 00 52 3C 0C 00 24 in 18-Oct 18:44:18.13 from 10.8.1.252
route,ospf,debug,raw     00 31 02 05 00 00 00 00 0A 0A 0F 08 80 00 00 2B in 18-Oct 18:44:18.14 from 10.8.1.252
route,ospf,debug,raw     D0 2C 00 24 in 18-Oct 18:44:18.14 from 10.8.1.252
route,ospf,debug Ignoring Link State Acknowledgment received in 18-Oct 18:44:18.15 from 10.8.1.252
route,ospf,debug     LSA header=Router LSA id=10.10.15.8 originator=10.10.15.8 seqnum=0x80000052 in 18-Oct 18:44:18.16 from 10.8.1.252
route,ospf,debug Ignoring Link State Acknowledgment received in 18-Oct 18:44:18.17 from 10.8.1.252
route,ospf,debug     LSA header=AS-External LSA id=0.0.0.0 originator=10.10.15.8 seqnum=0x8000002b in 18-Oct 18:44:18.17 from 10.8.1.252
route,ospf,debug SEND: Link State Acknowledgement 10.10.15.8 -> 224.0.0.5 on Core in 18-Oct 18:44:18.45 from 10.8.1.252
route,ospf,debug,raw PACKET: in 18-Oct 18:44:18.46 from 10.8.1.252
route,ospf,debug,raw     02 05 00 54 0A 0A 0F 08 00 00 00 00 E3 11 00 00 in 18-Oct 18:44:18.47 from 10.8.1.252
route,ospf,debug,raw     00 00 00 00 00 00 00 00 00 01 02 05 0A 09 06 00 in 18-Oct 18:44:18.48 from 10.8.1.252
route,ospf,debug,raw     0A 0A 0F 0A 80 00 00 1D F1 6A 00 24 00 01 02 01 in 18-Oct 18:44:18.49 from 10.8.1.252
route,ospf,debug,raw     0A 0A 0F 0A 0A 0A 0F 0A 80 00 00 37 41 F3 00 24 in 18-Oct 18:44:18.49 from 10.8.1.252
route,ospf,debug,raw     00 01 02 02 0A 0A 0F 0A 0A 0A 0F 0A 80 00 00 0D in 18-Oct 18:44:18.50 from 10.8.1.252
route,ospf,debug,raw     B9 E1 00 20 in 18-Oct 18:44:18.51 from 10.8.1.252
route,ospf,debug Recalculating all OSPFv2 intra-area routes in 18-Oct 18:44:19.17 from 10.8.1.252
route,ospf,debug Recalculating all inter-area routes in 18-Oct 18:44:19.18 from 10.8.1.252
route,ospf,debug     summary-area=backbone in 18-Oct 18:44:19.18 from 10.8.1.252
route,ospf,debug Recalculating AS-external routes in 18-Oct 18:44:19.19 from 10.8.1.252
route,ospf,debug Installing an OSPF route in the main routing table in 18-Oct 18:44:19.20 from 10.8.1.252
route,ospf,debug     prefix=10.9.6.0/24 in 18-Oct 18:44:19.21 from 10.8.1.252
route,debug,calc Begin calculation in 18-Oct 18:44:19.25 from 10.8.1.252
route,debug,calc Next hop resolved in 18-Oct 18:44:19.25 from 10.8.1.252
route,debug,calc     address=10.10.15.10 in 18-Oct 18:44:19.26 from 10.8.1.252
route,debug,calc     route=10.10.15.0/24 in 18-Oct 18:44:19.27 from 10.8.1.252
route,debug,calc     immediate-address=10.10.15.10 in 18-Oct 18:44:19.28 from 10.8.1.252
route,debug,calc     interface=Core in 18-Oct 18:44:19.28 from 10.8.1.252
route,debug,event Added candidate route in 18-Oct 18:44:19.29 from 10.8.1.252
route,debug,event     dst-prefix=10.9.6.0/24 in 18-Oct 18:44:19.30 from 10.8.1.252
route,debug,event     attributes in 18-Oct 18:44:19.31 from 10.8.1.252
route,debug,event         protocol=OSPF in 18-Oct 18:44:19.31 from 10.8.1.252
route,debug,event         scope=20 in 18-Oct 18:44:19.32 from 10.8.1.252
route,debug,event         next-hop= address=10.10.15.10 in 18-Oct 18:44:19.33 from 10.8.1.252
route,debug,event         origin-type=OSPF in 18-Oct 18:44:19.34 from 10.8.1.252
route,debug,event         origin-instance-id=0 in 18-Oct 18:44:19.34 from 10.8.1.252
route,debug,event         ospf-metric=10 in 18-Oct 18:44:19.35 from 10.8.1.252
route,debug,event         ospf-type=external-type-2 in 18-Oct 18:44:19.36 from 10.8.1.252
route,debug,calc Select route in 18-Oct 18:44:19.37 from 10.8.1.252
route,debug,calc     dst-address=10.9.6.0/24 in 18-Oct 18:44:19.37 from 10.8.1.252
route,debug,calc     attributes in 18-Oct 18:44:19.38 from 10.8.1.252
route,debug,calc         protocol=OSPF in 18-Oct 18:44:19.39 from 10.8.1.252
route,debug,calc         scope=20 in 18-Oct 18:44:19.40 from 10.8.1.252
route,debug,calc         next-hop= address=10.10.15.10 in 18-Oct 18:44:19.40 from 10.8.1.252
route,debug,calc         origin-type=OSPF in 18-Oct 18:44:19.41 from 10.8.1.252
route,debug,calc         origin-instance-id=0 in 18-Oct 18:44:19.42 from 10.8.1.252
route,debug,calc         ospf-metric=10 in 18-Oct 18:44:19.42 from 10.8.1.252
route,debug,calc         ospf-type=external-type-2 in 18-Oct 18:44:19.43 from 10.8.1.252
route,debug,calc End calculation in 18-Oct 18:44:19.44 from 10.8.1.252
route,debug Begin redistribution in 18-Oct 18:44:19.45 from 10.8.1.252
route,debug Accept add 10.9.6.0/24 in 18-Oct 18:44:19.45 from 10.8.1.252
route,debug Commit prefix 10.9.6.0/24 in 18-Oct 18:44:19.46 from 10.8.1.252
route,debug End redistribution in 18-Oct 18:44:19.47 from 10.8.1.252
The situation is repeated approximately every 5 minutes
 
2dfx
just joined
Topic Author
Posts: 22
Joined: Tue Mar 05, 2013 6:30 pm

Re: OSPF between Mikrotik and Linux loses routes

Thu Oct 23, 2014 3:50 pm

Sloved.

The problem with MTU.
Set up a GRE tunnel and OSPF began to work correctly.

Who is online

Users browsing this forum: No registered users and 11 guests