Community discussions

MikroTik App
 
gnuttisch
Member
Member
Topic Author
Posts: 309
Joined: Fri Sep 10, 2010 3:49 pm

OSPF dont fill up my routing table after switching to NBMA?

Thu Nov 06, 2014 2:09 am

Hi,

I have just tried swithing over one of my sites to ospf nbma instead of broadcast. I have one AP and 5 clients, all running 6.19 whit wireless-fp.

At the AP, I added all the clients to nbma neighbor and switched to nbma on the wlan1 network type.
At the client, I added the APs, address to the nbma neighbor list and switched the wlan1 interface to nbma.

The LSA list filled up at the client but not the routing list?
I disabled/enabled the instance on the AP and client, no routing table. Not even after a reboot.

So finally, after about 45 min without any routing table, I switched back to broadcast and the network went up after a minute or two.

Any ides? Because you should run nbma on wireless links right?

Im running mpls/vpls overt the ospf network, can I get rid of ospf and installing anything more stable then this crap? ?

Regards..
 
gnuttisch
Member
Member
Topic Author
Posts: 309
Joined: Fri Sep 10, 2010 3:49 pm

Re: OSPF dont fill up my routing table after switching to NB

Thu Nov 06, 2014 5:25 pm

Okej, so today I have set up an lab-test to reproduce this issue.

I have on Omnitik whit 3 sxt connected to it via NV2.
All running 6.19 and wireless-fp and whit the latest firmware of routerboard.

Not filling up the routingtable but lsa works, here in omnitik but also in the SXTs.
[admin@MikroTik] > ro os lsa pr
AREA       TYPE         ID             ORIGINATOR     SEQUENCE-NU...        AGE
backbone   router       10.0.0.1       10.0.0.1           0x80000015        615
backbone   router       10.0.0.2       10.0.0.2           0x80000003       1582
backbone   router       10.0.0.3       10.0.0.3           0x80000004       1395
backbone   router       10.0.1.1       10.0.1.1           0x80000007       1371
backbone   router       10.0.1.2       10.0.1.2           0x8000000B        611
backbone   router       10.0.2.2       10.0.2.2           0x80000009        621
backbone   router       10.0.3.2       10.0.3.2           0x80000008        617
backbone   network      10.0.0.2       10.0.1.2           0x80000002        611
backbone   network      10.0.0.3       10.0.2.2           0x80000001        621
backbone   network      10.0.0.4       10.0.3.2           0x80000002        617
backbone   network      10.0.2.1       10.0.1.1           0x80000002       1376
Omnitik
/interface wireless
set [ find default-name=wlan1 ] disabled=no l2mtu=1600 mode=ap-bridge \
    rx-chains=0 tx-chains=0 tx-power=1 tx-power-mode=card-rates \
    wireless-protocol=nv2
/routing ospf instance
set [ find default=yes ] router-id=10.0.0.1
/ip address
add address=10.0.0.1/29 interface=wlan1 network=10.0.0.0
/ip upnp
set allow-disable-external-interface=no
/routing ospf interface
add interface=wlan1 network-type=nbma
/routing ospf nbma-neighbor
add address=10.0.0.2
add address=10.0.0.3
add address=10.0.0.4
/routing ospf network
add area=backbone network=10.0.0.0/29
/system logging
add topics=ospf
SXT-1
/interface wireless
set [ find default-name=wlan1 ] disabled=no l2mtu=1600 rx-chains=0 tx-chains=0 \
    tx-power=1 tx-power-mode=all-rates-fixed wireless-protocol=nv2
/routing ospf instance
set [ find default=yes ] router-id=10.0.3.2
/ip address
add address=10.0.0.4/29 interface=wlan1 network=10.0.0.0
add address=10.0.3.2/30 interface=ether1 network=10.0.3.0
/ip upnp
set allow-disable-external-interface=no
/routing ospf interface
add interface=wlan1 network-type=nbma
/routing ospf nbma-neighbor
add address=10.0.0.1
/routing ospf network
add area=backbone network=10.0.0.0/29
add area=backbone network=10.0.3.0/30
/system leds
set 0 interface=wlan1
SXT-2
/interface wireless
set [ find default-name=wlan1 ] disabled=no l2mtu=1600 tx-power=1 \
    tx-power-mode=all-rates-fixed
/routing ospf instance
set [ find default=yes ] router-id=10.0.2.2
/ip address
add address=10.0.0.3/29 interface=wlan1 network=10.0.0.0
add address=10.0.2.2/30 interface=ether1 network=10.0.2.0
/ip upnp
set allow-disable-external-interface=no
/routing ospf interface
add interface=wlan1 network-type=nbma
/routing ospf nbma-neighbor
add address=10.0.0.1
/routing ospf network
add area=backbone network=10.0.2.0/30
add area=backbone network=10.0.0.0/29
/system leds
set 0 interface=wlan1
SXT-3
/interface wireless
set [ find default-name=wlan1 ] disabled=no l2mtu=1600 tx-power=1 \
    tx-power-mode=all-rates-fixed
/routing ospf instance
set [ find default=yes ] router-id=10.0.1.2
/ip address
add address=10.0.0.2/29 interface=wlan1 network=10.0.0.0
add address=10.0.1.2/30 interface=ether1 network=10.0.1.0
/ip upnp
set allow-disable-external-interface=no
/routing ospf interface
add interface=wlan1 network-type=nbma
/routing ospf nbma-neighbor
add address=10.0.0.1
/routing ospf network
add area=backbone network=10.0.0.0/29
add area=backbone network=10.0.1.0/30
/system leds
set 0 interface=wlan1
If I switch to broadcast insted of NBMA it works, the routingtable fills up.

Could anyone please help me whit this issue? What am I doing wrong?

Regards..
 
gnuttisch
Member
Member
Topic Author
Posts: 309
Joined: Fri Sep 10, 2010 3:49 pm

Re: OSPF dont fill up my routing table after switching to NB

Thu Nov 06, 2014 9:39 pm

Now I have tested the latest ros 6.21.1 and their is no different behavior from ros 6.19.
I have also tried to downgrade to ros 5.26 and that don't work either.

The LSA list is filled up but no ospf routes in the routingtable.


Anyone?
 
gnuttisch
Member
Member
Topic Author
Posts: 309
Joined: Fri Sep 10, 2010 3:49 pm

Re: OSPF dont fill up my routing table after switching to NB

Fri Nov 07, 2014 9:50 am

Okej, so some new info.

In my Omnitik, where I have 3 sxt connected to I get 1 (one) line of osfp route. Where I should have three.
The funny thing is that it populate the route whit the highest route =)

So, When I have all three sxt connected, it looks like this in the routingtable in the Omnitik.
#      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADS  0.0.0.0/0                          192.168.19.1              0
 1 ADC  10.0.0.0/29        10.0.0.1        wlan1                     0
 2 ADo  10.0.3.0/30                        10.0.0.4                110
 3 ADC  192.168.19.0/24    192.168.19.220  ether1                    0
And when I disable SXT-3 who has address 10.0.0.4, it looks like this.
 
#      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADS  0.0.0.0/0                          192.168.19.1              0
 1 ADC  10.0.0.0/29        10.0.0.1        wlan1                     0
 2 ADo  10.0.2.0/30                        10.0.0.3                110
 3 ADC  192.168.19.0/24    192.168.19.220  ether1                    0
And when I disable SXT-2, who has address 10.0.0.3, it looks like this.
#      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADS  0.0.0.0/0                          192.168.19.1              0
 1 ADC  10.0.0.0/29        10.0.0.1        wlan1                     0
 2 ADo  10.0.1.0/30                        10.0.0.2                110
 3 ADC  192.168.19.0/24    192.168.19.220  ether1                    0

Any idees? How should I conf nbma?
 
und3ath
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Mon Mar 23, 2009 7:01 pm

Re: OSPF dont fill up my routing table after switching to NB

Mon Nov 17, 2014 12:46 am

When do you want to use nbma, you have to set priority for every nbma neighbour and also add static interface with the proper priority.
How to:
on you AP add static interface with priority=1 and ospf type=nbma. Then add all the nbma neighbours with priority=0

On every of your clients add as the nbma neighbour the ip of AP and priority 1. Also add static interface with ospf type=nbma and priority=0.
 
gnuttisch
Member
Member
Topic Author
Posts: 309
Joined: Fri Sep 10, 2010 3:49 pm

Re: OSPF dont fill up my routing table after switching to NB

Mon Nov 17, 2014 9:48 am

Yes, I figured it out at last :) But haven't had the time to close this post.

Thanks for your replay.

Who is online

Users browsing this forum: No registered users and 12 guests