Community discussions

 
ellerem
just joined
Topic Author
Posts: 2
Joined: Fri Feb 20, 2015 10:36 am

State of Openflow

Sat Feb 21, 2015 1:18 am

Could we please have a general statement about openflow?

- When is a stable V1.3 likely to be available?
- When is any kind of hardware switching likely to be available?
- When are encrypted connections likely to be available?
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: State of Openflow

Tue Feb 24, 2015 9:51 am

All the described features are in our todo list, thank you for raising the questions. At the moment there is no specific timeframe, when features will be available.
 
buraglio
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Mon Aug 10, 2015 5:59 pm
Location: +1 (217)
Contact:

Re: State of Openflow

Mon Aug 10, 2015 6:05 pm

I've been working with openflow since since the very early days, ~2009. I recently picked up some Mikrotik gear to start replacing a lot of old pfsense stuff. I'd like to start using the OpenFlow offering, but would really like to see something newer than 1.0.
How is OpenFlow being implemented? Is it OVS based?
Is there any possibility of adding a modern OpenvSwitch build to Mikrotik RouterOS? The benefits of this seem pretty obvious to me (although admittedly I am biased). Allowing for OpenFlow 1.3 would be pretty nice, even if it is just the required options to support the standard. I can help with the implementation and testing if that is a possibility. Again, I'm pretty new to RouterOS and don't have the best communication paths, so if there are better places to ask I'm happy to do so.
ForwardingPlane, LLC
https://www.forwardingplane.net
 
andrewmoses
just joined
Posts: 2
Joined: Mon Jan 18, 2016 2:35 pm

Re: State of Openflow

Mon Jan 18, 2016 2:42 pm

I've been working with openflow since since the very early days, ~2009. I recently picked up some Mikrotik gear to start replacing a lot of old pfsense stuff. I'd like to start using the OpenFlow offering, but would really like to see something newer than 1.0.
How is OpenFlow being implemented? Is it OVS based?
Is there any possibility of adding a modern OpenvSwitch build to Mikrotik RouterOS? The benefits of this seem pretty obvious to me (although admittedly I am biased). Allowing for OpenFlow 1.3 would be pretty nice, even if it is just the required options to support the standard. I can help with the implementation and testing if that is a possibility. Again, I'm pretty new to RouterOS and don't have the best communication paths, so if there are better places to ask I'm happy to do so.
Even I'm in search of some place to learn how to configure routerboard openflow. I have rb750gl with routeros 6.32.3. If you had found any place, kindly ping me. thanking you.
 
buraglio
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Mon Aug 10, 2015 5:59 pm
Location: +1 (217)
Contact:

Re: State of Openflow

Mon Jan 18, 2016 4:19 pm

I didn't find a config guide, I just worked it out myself. I've been using OpenFlow since 2009 so it wasn't unfamiliar. I'm willing to write up a guide if folks are interested, but the bulk of the work isn't in routerOS, it's the controller.
If you're interested in what it's like running SDN in produiction, I can offer a podcast I did with Ivan Pepelnjak where we discuss the OpenFlow based network I ran at a large scientific conference.It's available here

Off the top of my head, I think the setup commands are something like
/openflow add controllers=10.69.69.69 comment="This is my OpenDaylight Controller"
/openflow set name="OpenFlow CloudRouter"
/openflow set datapath-id=c0:ff:ee:c0:ff:ee
/openflow port add interface=ether1,ether2,ether3
/openflow port add interface=vlan_69
There may be a few more bits, but you get the idea. The rest of the work is on the controller. FWIW, I think there is a lot of value using OpenFlow as a control protocol for broadband provisioning, I've written up many opinion pieces on the subject. if you just search for my name and OpenFlow you can probably find them if you're so inclined.

nb
ForwardingPlane, LLC
https://www.forwardingplane.net
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 985
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: State of Openflow

Tue Jan 19, 2016 6:23 pm

All the described features are in our todo list, thank you for raising the questions. At the moment there is no specific timeframe, when features will be available.
+1 to implement newer versions of OpenFlow...SDN is getting to be more and more mainstream and this would put MIkroTik in a great position to be a low cost SDN router.
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com
 
buraglio
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Mon Aug 10, 2015 5:59 pm
Location: +1 (217)
Contact:

Re: State of Openflow

Wed Jun 15, 2016 10:51 pm

I'd love to seen an update on this. Anyone? 
ForwardingPlane, LLC
https://www.forwardingplane.net
 
dirkdus
just joined
Posts: 1
Joined: Tue Oct 04, 2016 11:26 pm

Openflow on mikrotik?

Tue Oct 04, 2016 11:32 pm

Anyone ever succeeded in connecting with a controller? I've setup a simple Openflow switch on my mikrotik 2011L routerboard. So far I've tried connecting with opendaylight and with pox, without any success.

Thanks for any pointer,

Dirk
 
MarkvS
just joined
Posts: 1
Joined: Wed Oct 19, 2016 3:51 pm

Re: State of Openflow

Wed Oct 19, 2016 4:19 pm

Hi Dirk,
I've got a similar setup running, with success. I'm using a RB2011UiAS-2HnD, and a VM on my desktop running Ubuntu 14.04 with Opendaylight (ODL).
I installed / configured Dlux and L2switch features on ODL conform the manual. Furthermore i installed Wireshark 2.2.1 on the VM to get some insight in the traffic.

The RB was made factory default, and i added an IP address 192.168.10.251 on the first ethernet interface. This interface is going to be used for the communications to the ODL server (with IP address 192.168.10.26). This is connected to my home network (192.168.10.0/24 and sort of out of band network for Openflow).
The other interfaces of the RB are configured as Openflow interfaces, in an isolated network.
I connected two nodes to these Openflow interfaces, and after the ODL server was running, the flows were installed on the RB and the nodes could ping each other.
(i put in a DHCP server on an old router to provide IP adresses on one of the Openflow interfaces).

It is a pitty that the RB doesn't yet support a higher Openflow version, the functionality is quite limited. I'm looking into the possibility of running Opeflow on a OpenWRT instance in the RB, to see if that can support something like Openflow 1.3. Hopefully Mikrotik will provide an update to openflow support on the RB.

i included my config below. It is quite straight forward. Maybe this helps.

With kind regards,
Mark

[admin@MikroTik] > export
# oct/19/2016 14:54:36 by RouterOS 6.37.1
#
/interface bridge
add admin-mac=4C:5E:0C:xx:xx:xx auto-mac=no name=bridgeLocal
/openflow
add controllers=192.168.10.26 datapath-id=1/00:00:00:00:00:AA disabled=no \
name=oflow1 passive-port=1
/interface bridge port
add bridge=bridgeLocal interface=ether2
add bridge=bridgeLocal interface=ether3
add bridge=bridgeLocal interface=ether4
add bridge=bridgeLocal interface=ether5
add bridge=bridgeLocal interface=ether6
add bridge=bridgeLocal interface=ether7
add bridge=bridgeLocal interface=ether8
add bridge=bridgeLocal interface=ether9
add bridge=bridgeLocal interface=ether10
add bridge=bridgeLocal interface=sfp1
/interface wireless cap
#
set bridge=bridgeLocal discovery-interfaces=ether1 enabled=yes interfaces=\
wlan1
/ip address
add address=192.168.10.251/24 interface=ether1 network=192.168.10.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1
/openflow port
add disabled=no interface=ether2 switch=oflow1
add disabled=no interface=ether3 switch=oflow1
add disabled=no interface=ether4 switch=oflow1
add disabled=no interface=ether5 switch=oflow1
add disabled=no interface=ether6 switch=oflow1
add disabled=no interface=ether7 switch=oflow1
add disabled=no interface=ether8 switch=oflow1
add disabled=no interface=ether9 switch=oflow1
add disabled=no interface=ether10 switch=oflow1
/system clock
set time-zone-name=Europe/Amsterdam
 
User avatar
erreferre
just joined
Posts: 21
Joined: Mon Sep 08, 2014 2:29 pm

Re: State of Openflow

Fri Dec 22, 2017 12:00 pm

Any news about OpenFlow 1.3 or higher?
All the described features are in our todo list, thank you for raising the questions. At the moment there is no specific timeframe, when features will be available.
MTCNA, MTCWE, MTCTCE, MTCRE, MTCUME, MTCINE
www.aerowi.es
 
buraglio
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Mon Aug 10, 2015 5:59 pm
Location: +1 (217)
Contact:

Re: State of Openflow

Fri Dec 22, 2017 4:26 pm

Any news about OpenFlow 1.3 or higher?
All the described features are in our todo list, thank you for raising the questions. At the moment there is no specific timeframe, when features will be available.
My guess is that since OpenFlow has mostly being leveraged in datancenters and enterprise networks that at this point that the ROS offering is dying a slow, uneventful death.
Last edited by buraglio on Wed Dec 12, 2018 9:18 pm, edited 3 times in total.
ForwardingPlane, LLC
https://www.forwardingplane.net
 
User avatar
erreferre
just joined
Posts: 21
Joined: Mon Sep 08, 2014 2:29 pm

Re: State of Openflow

Fri Mar 23, 2018 11:08 am

Please MikroTik staff, any news about OpenFlow 1.3 or higher? I only need a date: 2018, 2019, 2020, ... SDN is here and we need to know if we can go forward with MikroTik or change to another manufacturer. Thanks.
MTCNA, MTCWE, MTCTCE, MTCRE, MTCUME, MTCINE
www.aerowi.es
 
buraglio
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Mon Aug 10, 2015 5:59 pm
Location: +1 (217)
Contact:

Re: State of Openflow

Wed Nov 21, 2018 4:34 pm

Please MikroTik staff, any news about OpenFlow 1.3 or higher? I only need a date: 2018, 2019, 2020, ... SDN is here and we need to know if we can go forward with MikroTik or change to another manufacturer. Thanks.
Any update? If this is ever going to happen it needs to meet a handful of requirements to be usable, most of which are not well documented. For reference, the faucet foundation has a set of tests that hardware needs to pass to conform to an actual useful implementation of OF 1.3 (multi table support being a hard requirement that many vendors happily ignore). If using OVS as a base, full implementation of >2.1 should work. See https://github.com/faucetsdn/faucet for more details.
I am very, very happy to test this out and provide useful feedback however is useful.
ForwardingPlane, LLC
https://www.forwardingplane.net
 
akant
just joined
Posts: 10
Joined: Tue Oct 11, 2011 8:29 am

Re: State of Openflow

Thu Aug 15, 2019 2:31 am

++1 for OpenFlow support specifically 1.3 !!!

Who is online

Users browsing this forum: No registered users and 2 guests