Community discussions

MikroTik App
 
DimebagDarrell
just joined
Topic Author
Posts: 10
Joined: Fri Jun 07, 2013 4:15 am

CHR hotspot not working?

Mon Sep 13, 2021 12:50 am

Hello, I am testing a configuration in GNS3 with CHR 6.48.2 and a Virtual Machine with Windows 10 Pro.

I create a bridge and add the hotspot for the setup, connect the windows virtual machine to the ether2 I receive ip and get to the portal, but when I do a bypass the internet does not work, it is not possible to navigate. but if I ping I go anywhere. If I enter with Username and Password, I don't have internet either but I have ping. Is it a license limitation?

My configuration:
# sep/12/2021 18:40:54 by RouterOS 6.48.2
# software id = 
#
#
#
/interface bridge
add comment="BRIDGE HOTSPOT" name=bridge-dist
/interface ethernet
set [ find default-name=ether1 ] comment=WAN
set [ find default-name=ether2 ] comment="LAN - 1"
set [ find default-name=ether3 ] comment="LAN - 2"
set [ find default-name=ether4 ] comment="LAN - 3"
set [ find default-name=ether5 ] comment="LAN - 4"
set [ find default-name=ether6 ] comment="LAN - 5"
set [ find default-name=ether7 ] comment="LAN - 6"
set [ find default-name=ether8 ] comment="LAN - 7"
set [ find default-name=ether9 ] comment="LAN - 8"
set [ find default-name=ether10 ] comment="LAN ADMIN"
/ip hotspot profile
add dns-name=hotspot.test.wisp hotspot-address=192.168.3.1 name=hsprof1
/ip hotspot user profile
set [ find default=yes ] shared-users=unlimited
/ip pool
add name=hs-pool-11 ranges=192.168.3.2-192.168.3.254
/ip dhcp-server
add address-pool=hs-pool-11 disabled=no interface=bridge-dist lease-time=1h name=dhcp1
/ip hotspot
add address-pool=hs-pool-11 disabled=no interface=bridge-dist name=hotspot1 profile=hsprof1
/interface bridge port
add bridge=bridge-dist interface=ether2
add bridge=bridge-dist interface=ether3
add bridge=bridge-dist interface=ether4
add bridge=bridge-dist interface=ether5
add bridge=bridge-dist interface=ether6
add bridge=bridge-dist interface=ether7
add bridge=bridge-dist interface=ether8
add bridge=bridge-dist interface=ether9
/ip address
add address=192.168.3.1/24 comment="hotspot network" interface=bridge-dist network=192.168.3.0
/ip dhcp-client
add disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.3.0/24 comment="hotspot network" gateway=192.168.3.1
/ip dns
set servers=8.8.8.8,1.1.1.1
/ip firewall filter
add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" disabled=yes
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" disabled=yes
add action=masquerade chain=srcnat out-interface=ether1
add action=passthrough chain=dstnat to-addresses=0.0.0.0
add action=masquerade chain=srcnat comment="masquerade hotspot network" disabled=yes src-address=192.168.3.0/24
add action=masquerade chain=srcnat comment="masquerade hotspot network" src-address=192.168.3.0/24
/ip hotspot ip-binding
add mac-address=08:00:27:XX:XX:XX server=hotspot1 type=bypassed
/ip hotspot user
add name=asdf password=asdf
/tool romon
set enabled=yes

Who is online

Users browsing this forum: No registered users and 8 guests