Community discussions

 
tdonahue
just joined
Topic Author
Posts: 1
Joined: Fri Dec 02, 2016 4:48 am

CHR crashes on VirtualBox

Fri Dec 02, 2016 5:58 am

Hi all,

I am working on scripting some configuration stuff using the RouterOS API, and I have been running into some stability issues while running CHR under Virtualbox. When the router crashes, I have found that it will work for a short time, then ether1 will start to become unreachable. A short while after this happens, the text on the screen gets distorted and the the router reboots. I suspect that the reboot is being kicked off by the watchdog.

I have found that I don't seem to have these issues if I use the x86 iso to install RouterOS with identical settings on the VM (I cloned the VM and created a new virtual disk drive), only when using the CHR disk image. I have also found that this seems to happen primarily when one of the network adapters is either in "Bridged" or "Host-only" mode. I have a couple CHR VMs that are setup for "Internal" networking, that I don't believe I have experienced this error with.

Has anyone else experienced any issues with CHR in a Virtualbox?

Virtualbox Version: 5.1.10
CHR Versions: 6.37.3 and 6.38rc38

Current configuration:
#
/ip pool
add name=dhcp_pool1 ranges=10.1.1.100-10.1.1.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether3 name=dhcp1
/routing ospf instance
set [ find default=yes ] redistribute-connected=as-type-1 redistribute-other-ospf=as-type-1
/ip address
add address=10.1.1.1/24 interface=ether3 network=10.1.1.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether2
add dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dhcp-server config
set store-leases-disk=5d
/ip dhcp-server network
add address=10.1.1.0/24 gateway=10.1.1.1
/routing ospf interface
add authentication=md5 authentication-key=OSPF interface=ether3 network-type=broadcast
add authentication=md5 authentication-key=OSPF interface=ether2 network-type=broadcast
/routing ospf network
add area=backbone network=10.1.1.0/24
add area=backbone network=192.168.56.0/24
/system clock
set time-zone-name=America/New_York
/system ntp client
set server-dns-names=0.us.pool.ntp.org
Tim Donahue
You do not have the required permissions to view the files attached to this post.
 
foo34
just joined
Posts: 1
Joined: Mon Nov 12, 2018 12:48 pm

Re: CHR crashes on VirtualBox

Mon Nov 12, 2018 1:13 pm

I stumbled across this post because I was having pretty much the same problem. I was trying to use RouterOS x86 ver 6.42.9 in some VirtualBox VMs to do some inter VM networking stuff. The RouterOS VM would boot up okay, but then after about 3-5 mins, would just restart on its own accord. After playing around with the settings, I noticed this only seemed to happen when using the virtualised Intel PRO/1000 MT Desktop (82540EM) and Intel PRO/1000 MT Server (82545EM) NICs. I didn't try the 82543GC. After changing to the AMD PCNet FAST III (Am79C973) NICs, it seems to be running fine now.

Not sure what is causing the problem with the Intel NICs.

Who is online

Users browsing this forum: No registered users and 4 guests