Community discussions

MikroTik App
 
hashbang
Member Candidate
Member Candidate
Topic Author
Posts: 157
Joined: Sat Jul 26, 2014 6:38 pm

very poor performance in chr vis a vis x86

Tue Jan 24, 2017 12:45 am

Hi,
I tested chr 6.38.1 and x86 on the same server with virtual box. Virtual box setup :
Dual Xeon 56xx 32gb ram. (total of 16 cpu shown in MT)
Centos 7 running as host with latest intel drivers x520.
Paravirtualized drivers used
Virtualization acceleration used KVM
2 bridges one for lan and other for wan to pass vlans both having one interface in it on the host
Using it as a bras with 400 users chr started to show cpu usage to 50% and winbox got sluggish, Profiling showed cpu usage consumed by networking
On same platform same configurations with x86
2600 users running and no problem, CPU usage 60%
Unable to do tests on vmware workstation because it didnt supported vlans out of the box.
Any misconfigurations in VB to have such a poor performance
 
User avatar
TomjNorthIdaho
Forum Guru
Forum Guru
Posts: 1059
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: very poor performance in chr vis a vis x86

Tue Jan 24, 2017 4:15 pm

When installed and everything is configured correctly ... both x86 32-bit ROS and CHR 64-bit ROS perform close to the same throughout.

- In my tests, on my physical machines running ESXi, both machines appear to top out at around 20 gig when performing a speedtest (btest) to the loopback IP address of 127.0.0.1
- Both feel and look the same.
- Both work well.
- However - Under sustained heavy I/O network loads, x86 will often loose the IP stack and stop talking on the network - however, CHR will continue operating under heavy sustained loads.

In my option and my experience, if you run VMware ESXi hypervisor boxes, then you should only use CHR.

North Idaho Tom Jones
 
hashbang
Member Candidate
Member Candidate
Topic Author
Posts: 157
Joined: Sat Jul 26, 2014 6:38 pm

Re: very poor performance in chr vis a vis x86

Tue Jan 24, 2017 5:04 pm

thnx, That means virtualbox have performance problem. In my test I found latency jitters, high cpu usage when using paravirtualized drivers. Performance seems better when using intel card but then it strips the vlan tags. How good is kvm ?

Who is online

Users browsing this forum: No registered users and 7 guests