Community discussions

 
jclendenan
just joined
Topic Author
Posts: 1
Joined: Tue Mar 21, 2017 12:17 am

CHR + Xenserver, Crash on live migration

Tue Mar 21, 2017 12:35 am

Hi Guys,

Doing some testing with CHR image (latest RC Build 6.39rc55) And it worked and installed using the VMDK as expected.
Xenserver 7.0 with latest patches.

However when I do a live migration between the machines, the kernel crashes into a spinlock at 100% CPU.

Any ideas?
 
User avatar
gamerxp
just joined
Posts: 9
Joined: Fri Dec 09, 2016 2:54 am
Location: Thailand
Contact:

Re: CHR + Xenserver, Crash on live migration

Mon May 08, 2017 9:54 am

I use CHR+XenServer before. And have the same problem.

My guess is CHR doesn't run with Xen's Driver / XenTools so hypervisor (XenServer) cannot fully manage some memory of VM resulting in crashed.

Note:
Your system-id will change when moving so you need to assign license in Mikrotik website.

Please correct me if I wrong.
[MTCNA] 1608NA602
 
JnSchl
just joined
Posts: 4
Joined: Wed Sep 23, 2015 11:11 am

Re: CHR + Xenserver, Crash on live migration

Sat Nov 25, 2017 2:47 pm

Any news here? Still 100% on live-migrations.
 
a101g99
just joined
Posts: 3
Joined: Sun Dec 10, 2017 6:11 pm

Re: CHR + Xenserver, Crash on live migration

Sun Dec 10, 2017 6:21 pm

The same applies to ubuntu 16.04 / xen 4.6.5 / chr 6.40.4
 
kasparskr
MikroTik Support
MikroTik Support
Posts: 112
Joined: Mon Jul 27, 2015 11:46 am

Re: CHR + Xenserver, Crash on live migration

Fri Jan 19, 2018 1:56 pm

Hello, please try the live migration using the newest release-candidate version 6.42rc11.
 
a101g99
just joined
Posts: 3
Joined: Sun Dec 10, 2017 6:11 pm

Re: CHR + Xenserver, Crash on live migration

Fri Jan 19, 2018 3:30 pm

It seems to work ... migrate and remigrate, thanks a lot.
 
a101g99
just joined
Posts: 3
Joined: Sun Dec 10, 2017 6:11 pm

Re: CHR + Xenserver, Crash on live migration

Wed Dec 12, 2018 6:29 pm

Now I try to upgrade from 6.42.7 to a newer version (6.43.x) and it happens again. But not only the live migration ... directly after upgrading the host takes 100% CPU. I still run on Ubuntu 16.04 with Xen 4.6.5.

Who is online

Users browsing this forum: No registered users and 5 guests