Page 1 of 1

CHR + Xenserver, Crash on live migration

Posted: Tue Mar 21, 2017 12:35 am
by jclendenan
Hi Guys,

Doing some testing with CHR image (latest RC Build 6.39rc55) And it worked and installed using the VMDK as expected.
Xenserver 7.0 with latest patches.

However when I do a live migration between the machines, the kernel crashes into a spinlock at 100% CPU.

Any ideas?

Re: CHR + Xenserver, Crash on live migration

Posted: Mon May 08, 2017 9:54 am
by gamerxp
I use CHR+XenServer before. And have the same problem.

My guess is CHR doesn't run with Xen's Driver / XenTools so hypervisor (XenServer) cannot fully manage some memory of VM resulting in crashed.

Note:
Your system-id will change when moving so you need to assign license in Mikrotik website.

Please correct me if I wrong.

Re: CHR + Xenserver, Crash on live migration

Posted: Sat Nov 25, 2017 2:47 pm
by JnSchl
Any news here? Still 100% on live-migrations.

Re: CHR + Xenserver, Crash on live migration

Posted: Sun Dec 10, 2017 6:21 pm
by a101g99
The same applies to ubuntu 16.04 / xen 4.6.5 / chr 6.40.4

Re: CHR + Xenserver, Crash on live migration

Posted: Fri Jan 19, 2018 1:56 pm
by kasparskr
Hello, please try the live migration using the newest release-candidate version 6.42rc11.

Re: CHR + Xenserver, Crash on live migration

Posted: Fri Jan 19, 2018 3:30 pm
by a101g99
It seems to work ... migrate and remigrate, thanks a lot.

Re: CHR + Xenserver, Crash on live migration

Posted: Wed Dec 12, 2018 6:29 pm
by a101g99
Now I try to upgrade from 6.42.7 to a newer version (6.43.x) and it happens again. But not only the live migration ... directly after upgrading the host takes 100% CPU. I still run on Ubuntu 16.04 with Xen 4.6.5.