Community discussions

MikroTik App
 
eduplant
just joined
Topic Author
Posts: 8
Joined: Tue Dec 19, 2017 9:45 am

CHR Serial0 settings catch-22?

Tue Dec 19, 2017 10:22 am

On a HW routerboard, you can set the onboard serial baud rate (usually for `serial0`) with `system routerboard settings set baud-rate=<rate>`. Another way seems to be to press `s` during the boot process and select it that way. CHR shows only `routerboard=no` (for good reason; it isn't one), but this precludes you from using either `boot-delay` or the direct `baud-rate` settings.

The only remaining option appears to be to set the rate from `/port`. Attempts to change the rate from the line itself yield:
[admin@gns3-test] > port set [ find where name=serial0 ] baud-rate=1000000

failure: Cannot change port while in use!
I've also tried to coerce it to happen via `/system scheduler` firing an on-boot script to set the rate using `/port`, but on-boot still isn't early enough to catch it before the line is in use.

Is there a way to force RouterOS to relinquish the serial line (perhaps from a telnet/SSH session) or otherwise get around the catch-22? Any advice appreciated.

Who is online

Users browsing this forum: No registered users and 8 guests