Community discussions

 
nikc
Member Candidate
Member Candidate
Topic Author
Posts: 180
Joined: Wed Jul 13, 2016 6:05 pm

Proxomox Hosted CHR - IP Configuration

Tue Jan 22, 2019 11:55 am

Hi all

I am working on a feasibility study to replace my existing VM platform to Proxmox and it works in a slightly strange way (IMO) compared to how my current platform works.

Basically I have a Hetzner dedicated server with a single fixed IP + a small /29 subnet. To enable the VMs to use the IPs from the subnet there is a a little bit of routing config required on the host, and then on the VMs I have to manually apply an IP and some routing.

I've managed to get this working for a debian and ubuntu hosted VM, but struggling a little with how to configure this for CHR, to try to explain i thought i'd share the IP config for the two linux boxes.

VM Host IP (numbers changed for this post) = 99.88.7.180

Ubuntu VM config (the key here to make this work is the routes)

network:
version: 2
renderer: networkd
ethernets:
ens18:
addresses: [99.88.9.17/32]
gateway4: 99.88.7.180
routes:
- to: 0.0.0.0/0
via: 99.88.7.180
on-link: true
nameservers:
addresses: [8.8.8.8,8.8.4.4]

Deian VM config (the key here to make this work is the again the pointopoint statement, which is a route)

auto ens18
iface ens18 inet static
address 99.88.9.17
netmask 255.255.255.255
pointopoint 99.88.7.180
gateway 99.88.7.180

So on my CHR box I tried adding the IP 99.88.9.17/32 to ether1, then put in a route that said 0.0.0.0/0 should go via 99.88.7.180

/ip address add interface=ether1 address=99.88.9.17 netmask=255.255.255.255
/ip route add dst-address=0.0.0.0/0 gateway=99.88.7.180

No joy ... do i need to do something above and beyond assigning the IP and sticking the route on the device to get the routing to work in the same way ?

Thanks !

NikC
 
User avatar
jprietove
Trainer
Trainer
Posts: 91
Joined: Fri Jun 03, 2016 3:00 pm
Location: Cádiz, Spain
Contact:

Re: Proxomox Hosted CHR - IP Configuration

Tue Jan 22, 2019 12:39 pm

Try this:
/ip address add interface=ether1 address=99.88.9.17 network=99.88.7.180
/ip route add dst-address=0.0.0.0/0 gateway=99.88.7.180
 
nikc
Member Candidate
Member Candidate
Topic Author
Posts: 180
Joined: Wed Jul 13, 2016 6:05 pm

Re: Proxomox Hosted CHR - IP Configuration

Tue Jan 22, 2019 12:59 pm

Try this:
/ip address add interface=ether1 address=99.88.9.17 network=99.88.7.180
/ip route add dst-address=0.0.0.0/0 gateway=99.88.7.180
Awesome that worked a treat, thanks a lot for your help.

Who is online

Users browsing this forum: No registered users and 11 guests