Page 1 of 1

VRRP Hyper-V Master Master Problem

Posted: Sat May 11, 2019 9:56 pm
by PCaddict69
hi , i create two clean chr instance with one internal link to test vrrp and i only manage to get MASTER on both side... i can ping between the two interface when vrrp is disabled.
the only config on them is this. Is a clean install i just try to figure out why is not working... no filter rules nothing...

chr1
add address=192.168.7.3/29 interface=ether3 network=192.168.7.0
add address=192.168.7.2 interface=vrrp1 network=192.168.7.2
/interface vrrp
add interface=ether2 name=vrrp1 priority=250 vrid=10

chr2
Flags: X - disabled, I - invalid, D - dynamic
# ADDRESS NETWORK INTERFACE
0 192.168.7.1/29 192.168.7.0 ether2
1 192.168.7.2/29 192.168.7.0 vrrp1
2 D 10.0.1.244/24 10.0.1.0 ether1

add address=192.168.7.2 interface=vrrp1 network=192.168.7.2
1 192.168.7.3/29 192.168.7.0 ether3
2 192.168.7.2/29 192.168.7.0 vrrp1
3 D 10.0.1.245/24 10.0.1.0 ether1

ping test without vrrp
[admin@MikroTik] /ip address> /tool ping 192.168.7.1
current: 350.5Mbps
average: 381.8Mbps

Re: VRRP Hyper-V Master Master Problem

Posted: Sat May 11, 2019 10:14 pm
by Sob
How does:
add address=192.168.7.2 interface=vrrp1 network=192.168.7.2
turn into:
2 192.168.7.2/29 192.168.7.0 vrrp1
with /29 mask? It should be /32.

Re: VRRP Hyper-V Master Master Problem

Posted: Sat May 11, 2019 10:15 pm
by PCaddict69
hi i just change the vrrp address both side for /32 same results...

Re: VRRP Hyper-V Master Master Problem

Posted: Sat May 11, 2019 10:28 pm
by Sob
Check if VRRP traffic from one router reaches the other, maybe something blocks that. Look for protocol 112 and 224.0.0.18.

Re: VRRP Hyper-V Master Master Problem

Posted: Sat May 11, 2019 10:51 pm
by PCaddict69
finally find it in hyper-v on the nic you have to apply spoofing mac address....