Page 1 of 1

MikroTik CHR 6.44.3 high latency on ESXi, vs 6.0

Posted: Thu May 30, 2019 12:07 pm
by tr00g33k

Installation and configuration:
-Imported vmdk 6.44.3 to datastore
-Converted vmdk
-Created new virtual machine with 2 cpu, 4 gbram, 512mb disk as it is on MikroTik site
-Connected disk to ide0
-Network cards vmxnet3

We installed MikroTik CHR 6.44.3 on vmware ESXi and we have problem with high latency and unresponsivnes when any small traffic gets through MikroTik.
-It install full BGP table in under 30 seconds without problem, but have problem when any internet traffic from client pass through
-Nothing vissible on CPU, just latency goes up over 300ms, and a lot of packet loss, and upload traffic doesnt go higer than 0,5Mbp on 1Gbps internet link connected to it

The same procedure on ESXi 6.0, everything ok, without problem traffic passess few 100Mbps. We tried even exporting ovf from ESXi 6.0 to 6.5, but the same problem on 6.5. We tried changeing hardware version, change the vmxnet3 to e1000 etc, tried only one CPU always the same problem.

MikroTik configuration is the same, the same vlans, everything only vmware version is diffrent.

On 6.5 we have more than 100 VPS, everything ok, only problem with MikroTik, did anybody else encountered similar issue, or have any idea what to try ?

Re: MikroTik CHR 6.44.3 high latency on ESXi, vs 6.0  [SOLVED]

Posted: Mon Jun 03, 2019 12:57 pm
by hedele
This may sound stupid but did you maybe forget to activate a license (trial or paid)? By default CHR has a hard-limit of 1 Mbps if no license is installed.

Re: MikroTik CHR 6.44.3 high latency on ESXi, vs 6.0

Posted: Tue Jun 04, 2019 11:06 pm
by tr00g33k
Exactly :) If i would see a post earlier would sure saved me an hour or two of trubleshooting configuration of two data-centers that we dont have any problems with, only CHR have strange problems (or admin didnt get enough of sleep for few days) :)

The strangest problems, are most of the time stupid. We activated the license on vmware 6.0. in lab enviroment exported ovf template, moved to production vmware 6.5, CHR system ID changed, and the license was not valid anymore. Activate-ing the license solved all the problems with our data-centers :)