Page 1 of 1

CHR: Additional limitations?!?!

Posted: Fri Jul 05, 2019 5:48 pm
by similar
First - sorry for my bad english.
Second - my question:

Is there any other limitations, instead of 1gbps per interface on CHR with p1 trial license?
Especially for loading speeds in hotspot controller web server, serving login page/s with bootstrap and jquery loaded?
All the content are loaded with very low speed:
12kb (stock) login page is loaded for about 2 secs. From RB2011UiAS it loads for 300-315ms.
My 220kb custom login page is never loaded.
bootstrap.css (120kb): loaded 40kb for 13 min! then drop connection
jquery.min.css(80kb): loaded 30kb fo 12 min! thn drop connection

When user login through stock login page all is ok - he can reach his 50mbps limit easy, but login page age several kilobytes.
Ive tested with 4 accounts and they reach 195mbps total on interface, so - there is no bandwidth problem at all.

My custom login page, that i simply copy from my RB2011UiAS never loads at full.

I have several RB2011UiAS used for hotspot controllers. Everything is fine with them.
I plan to migrate them to CHR installed on Proxmox.
Proxmox work as expected, CHR installed, same version as RB2011UiAS, configuration migrated without errors. Just files over 30-40kb (.html, .css, .js) never loaded. I see in Chroime developer console, that browser request them and they start loading, but after some kbytes and time is stops and throw error. I can see that they are partially loaded. Same browser load all OK from RB2011UiAS.

My custom Hotspot portal is total of 4.5MB - some pictures, bootsrap, jquery, speedtest page, helps, EULA... etc.

Is this normal for trial p1 CHR license?
Tried with 6.43.14 (same with RB2011UiAS), then 6.45.1(stable), then downgrade do 6.43.16(long-term) - same result.
After resettin configuration i only made one hotspot server (RB2011UiAS has 6) and userman configuration - the result was same!
Hardcoded shaper somewhere?

Is there limitation or not?

Re: CHR: Additional limitations?!?!

Posted: Mon Jul 08, 2019 12:23 pm
by similar
I`we installed regular 6.43.14 (x86) from ISO - same result... On same virtual machine.
Tried to create new virtual machine, installed from ISO again - same result.
Any suggestions?

Thank you.

Re: CHR: Additional limitations?!?!

Posted: Mon Jul 08, 2019 2:07 pm
by similar
As always when i ask for help.. i found the answer myself.

DON`T USE Intel e1000 network card emulation!
All works like a charm if ethernet card emulation is not set to Intel e1000.