Community discussions

MikroTik App
 
O1DMBFan
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 59
Joined: Fri Dec 05, 2008 11:08 pm

Installing CHR on Linode - Will not boot

Thu Oct 10, 2019 8:38 pm

Hello,
I'm following the steps laid out here: https://wiki.mikrotik.com/wiki/Manual:CHR_Linode

1. Create Linode
  • Images: None chosen
  • Region: US-Dallas
  • Plan: Standard - Linode 2GB
2. Create empty disk
  • Label: CHR
  • Filesystem: raw
  • Size: 16000MB
3. Boot Linode in Rescue mode and run the following commands:
  • Run:
    wget --no-check-certificate https://download2.mikrotik.com/routeros/6.44.5/chr-6.44.5.img.zip
  • Verify with
    fdisk -l
    that "sda" is indeed our 16GB disk.
  • Run:
    unzip chr-6.44.5.img.zip | dd of=/dev/sda bs=1M
4. Power off via linode dashboard.
5. Create linode configuration
  • Label: CHR
  • VM Mode: Full virtualization
  • Boot Kernel: Direct Disk
  • Run Level: Default
  • Memory Limit: None
  • Block Device Assignment: /dev/sda = CHR
  • Helpers: All disabled with the exception of "automount devtpmfs"
I then try to boot and get the following error via Linode:
Linode TestLinode could not be booted

I've tried with different firmware files but no luck. I've tried with ext3 format disk instead of raw, still no luck. What am I missing?
 
O1DMBFan
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 59
Joined: Fri Dec 05, 2008 11:08 pm

Re: Installing CHR on Linode - Will not boot  [SOLVED]

Thu Oct 10, 2019 9:02 pm

SOLVED:
I found an error in the wiki. DD command needs an input file specified. The following code,
unzip chr-6.44.5.img.zip | dd of=/dev/sda bs=1M
Should be:
unzip chr-6.44.5.img.zip | dd if=chr-6.44.5.img of=/dev/sda bs=1M

Who is online

Users browsing this forum: No registered users and 3 guests