Page 1 of 1

CHR tx-queue-drops-per-second

Posted: Thu Apr 02, 2020 9:42 pm
by ScottReed
CHR 6.45.8
RouterMaxx Vengeance on ESXi 6.7U3 / i7-7700 / 32GB

Using as an edge router connected to IX and ISP. 90+ BGP peering sessions. Partial routes from ISP.

Any sort of load on any of the interfaces results in upwards of ~3000 tx-queue-drops-per-second.

For example:

/interface monitor-traffic interface=sfp-sfpplus7
                         name:  sfp-sfpplus7
        rx-packets-per-second:       129 961
           rx-bits-per-second:     290.7Mbps
     fp-rx-packets-per-second:             0
        fp-rx-bits-per-second:          0bps
          rx-drops-per-second:             0
         rx-errors-per-second:             0
        tx-packets-per-second:       218 756
           tx-bits-per-second:       2.1Gbps
     fp-tx-packets-per-second:             0
        fp-tx-bits-per-second:          0bps
          tx-drops-per-second:             0
    tx-queue-drops-per-second:         2 836
         tx-errors-per-second:             0

This is happening on both the front expansion MaxxWave 4-Port 10G module and the read expansion HotLava St. Helens 4-Port 10G card. Using FS modules.

CHR CPU ~40% @ 5Gbps
ESXi CPU Pkg ~80% @ 5Gbps

I'm scheduling a time to disable hyper-threading in the BIOS to hopefully obtain some more performance, but I'm doubtful this will be the fix.

Outside of NorthIdahoTom's great CHR performance tips, is there anything else anyone can think of doing?

Re: CHR tx-queue-drops-per-second

Posted: Fri Apr 03, 2020 3:28 pm
by ScottReed
We were unable to get Hyper Threading disabled on Aptio BIOS v2.18.1263

The Advanced/CPU Configuration menu shows all grey options that cannot be modified. Surprisingly, Hyper Threading wasn't listed which is strange because the i7-7700 certainly supports it and it shows "enabled" in ESXi.

Re: CHR tx-queue-drops-per-second

Posted: Fri May 08, 2020 6:00 am
by faisali
Just a suggestion:-
try to change change the queue type to multi-queue-ethernet
and also look into how to enable that for the nic via the hypervisor / Vmware.