Community discussions

MikroTik App
 
Veria
just joined
Topic Author
Posts: 11
Joined: Fri Feb 21, 2014 10:30 am

Hetzner CHR issue

Tue Nov 03, 2020 10:24 am

Hello guys,

I tried to install CHR on the Hetzner cloud, based on https://wiki.mikrotik.com/wiki/Manual:CHR_Hetzner
but I get no hard drive found after reboot.

Pasted File at November 3, 2020 10_43 AM.png

I tried many different versions with no success.

How can I fix this issue?
You do not have the required permissions to view the files attached to this post.
 
kasparskr
MikroTik Support
MikroTik Support
Posts: 127
Joined: Mon Jul 27, 2015 11:46 am

Re: Hetzner CHR issue

Tue Nov 03, 2020 3:46 pm

Hello,

thank you for reaching out to us. We just tried with the newest stable version 6.47.7 (https://download.mikrotik.com/routeros/ ... .7.img.zip) and the above mentioned Hetzner manual and CX11 cloud VM and it worked as expected. Please try again.
CHR_Hetzner_CX11.png
You do not have the required permissions to view the files attached to this post.
 
Veria
just joined
Topic Author
Posts: 11
Joined: Fri Feb 21, 2014 10:30 am

Re: Hetzner CHR issue

Tue Nov 03, 2020 7:52 pm

Thanks for your reply,
I attached my steps and results.
Is there any mistake by me?
Screenshot 2020-11-03 214015.png
Screenshot 2020-11-03 214056.png
Screenshot 2020-11-03 213923.png
You do not have the required permissions to view the files attached to this post.
 
User avatar
xvo
Forum Guru
Forum Guru
Posts: 1140
Joined: Sat Mar 03, 2018 1:12 am
Location: Moscow, Russia

Re: Hetzner CHR issue

Tue Nov 03, 2020 7:58 pm

Try of=/dev/vda
If I remember correctly that helped me with Aruba Cloud.
 
Veria
just joined
Topic Author
Posts: 11
Joined: Fri Feb 21, 2014 10:30 am

Re: Hetzner CHR issue

Tue Nov 03, 2020 8:16 pm

Try of=/dev/vda
If I remember correctly that helped me with Aruba Cloud.

Thanks
My disk located at /dev/sda

Screenshot 2020-11-03 221443.png

However, I tried vda but didn't work.
You do not have the required permissions to view the files attached to this post.
 
User avatar
xvo
Forum Guru
Forum Guru
Posts: 1140
Joined: Sat Mar 03, 2018 1:12 am
Location: Moscow, Russia

Re: Hetzner CHR issue

Tue Nov 03, 2020 10:42 pm

Ok. Short googling tells that you need forced reboot at the end of procedure, not the "regular" one:
echo 1 > /proc/sys/kernel/sysrq
echo b > /proc/sysrq-trigger
From here (in Russian).
 
Veria
just joined
Topic Author
Posts: 11
Joined: Fri Feb 21, 2014 10:30 am

Re: Hetzner CHR issue

Tue Nov 03, 2020 11:30 pm

Ok. Short googling tells that you need forced reboot at the end of procedure, not the "regular" one:
echo 1 > /proc/sys/kernel/sysrq
echo b > /proc/sysrq-trigger
From here (in Russian).
the same result, it can't detect the disk.
Also, I tried the power cycle from the panel.
 
kasparskr
MikroTik Support
MikroTik Support
Posts: 127
Joined: Mon Jul 27, 2015 11:46 am

Re: Hetzner CHR issue

Wed Nov 04, 2020 10:25 am

RouterOS v6 kernel does not support AMD EPYC CPU's, please use CX instances (Intel Xeon based ones), instead of CPX instances which are using AMD EPYC

You can use v7 beta with the CPX instances:
v7_CPX_AMD.png
You do not have the required permissions to view the files attached to this post.
 
Veria
just joined
Topic Author
Posts: 11
Joined: Fri Feb 21, 2014 10:30 am

Re: Hetzner CHR issue

Sat Nov 07, 2020 10:18 am

It didn't work with CX instances too...
 
Veria
just joined
Topic Author
Posts: 11
Joined: Fri Feb 21, 2014 10:30 am

Re: Hetzner CHR issue

Sun Nov 08, 2020 11:26 pm

RouterOS v6 kernel does not support AMD EPYC CPU's, please use CX instances (Intel Xeon based ones), instead of CPX instances which are using AMD EPYC

You can use v7 beta with the CPX instances:

v7_CPX_AMD.png
This is V7 beta.
Did you try V6?

Who is online

Users browsing this forum: No registered users and 12 guests