Community discussions

MikroTik App
 
daan9999
just joined
Topic Author
Posts: 1
Joined: Thu Mar 08, 2018 12:59 pm

RouterOS CHR Scaleway

Sun Jan 31, 2021 3:21 pm

Hello Guys,

I managed to install routeros on scaleway and I thought I share my findings here to help others. it was quite strange to do as scaleway uses pxe booting for loading their images.

Just follow the normal steps to install mikrotik chr through the rescue boot option.

After installing open the console and start the instance.
Immediately after booting enter CTRL+B this will drop you to the pxe shell of your instance.
Enter the following command:
exit
The instance will now locally boot

After routeros boot's remove the dhcp-configuration as scaleway advertises /31 which routeros does not support or use the script down below and give the dhcp-client this comment=WAN
Add a ip address instead with the following config (can be found in your scaleway web interface under Private IP)
example:
address=10.17.10.90/32
network=10.17.10.89
(seems like they use nat 1:1 to assign your external ip address?).
After this add a default route (0.0.0.0/0) to the same ip address you entered in the network. after you have done this winbox etc should start working.

edit:
you can also use this script (drop it inside the script field of the dhcp-client):
:local network [/ip dhcp-client get [find comment=WAN] gateway]
:local interface [/ip dhcp-client get [find comment=WAN] interface]
:local addressget [/ip dhcp-client get [find comment=WAN] gateway]
:local address [($addressget+1)]

/ip address remove [find comment=scalewayfix]
/ip route remove [find comment=scalewayfix]
/ip address add address=$address network=$network interface=$interface comment=scalewayfix
/ip route add dst-address=0.0.0.0/0 gateway=$network comment=scalewayfix

I am still trying to figure out how you can override the normal booting procedure of the instance to locally boot instead of pxe boot.
Edit: this is not possible you will need to override everytime you reboot.

Enjoy!
 
pacmen
newbie
Posts: 37
Joined: Wed Dec 13, 2017 6:55 pm

Re: RouterOS CHR Scaleway

Mon Feb 08, 2021 11:26 pm

what is your use case for running CHR on this cloud?

Who is online

Users browsing this forum: No registered users and 3 guests