Community discussions

 
diegotormes
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 64
Joined: Wed Feb 15, 2006 11:45 pm

OpenWRT for MetaRouter 2.6.27. Kernel Compilation error

Tue Jun 23, 2009 11:23 pm

I'm getting two errors so far.
It fails when doing "make kernel_menuconfig" with this error:
if [ -s "/tmp/trunk/build_dir/linux-metarouter/linux-2.6.27.21/patches/series" ]; then (cd "/tmp/trunk/build_dir/linux-metarouter/linux-2.6.27.21"; if quilt --quiltrc=- next >/dev/null 2>&1; then quilt --quiltrc=- push -a; else quilt --quiltrc=- top >/dev/null 2>&1; fi ); fi
make[2]: *** [/tmp/trunk/build_dir/linux-metarouter/linux-2.6.27.21/.quilt_checked] Error 127


If I try to do "make" anyway, it starts compiling until fails with the message:
In file included from src/ubinize.c:36:
../include/mtd/ubi-media.h:157: error: expected specifier-qualifier-list before '__be32'
../include/mtd/ubi-media.h:277: error: expected specifier-qualifier-list before '__be32'
../include/mtd/ubi-media.h:364: error: expected specifier-qualifier-list before '__be32'


I appreciate any ideas. Thanks.

Who is online

Users browsing this forum: No registered users and 1 guest