Page 1 of 1

cannot see output when installing

Posted: Fri Dec 11, 2009 2:28 pm
by Pantani
I'm trying to install ROS 4.3 under qemu in redhat enterprise 5.4. I'm logged in as root and these are my steps:
virt-install --connect qemu:///system -n mikrotik43 -f ~/mikrotik43.qcow2 -s 30 -r 70 --noautoconsole --os-type other --os-variant generic --accelerate --network=bridge:br0 --hvm --cdrom=/root/mikrotik-4.3.iso --nographics
I'm sure, that the installation starts sucessfully, but I don't see any text output on the minicom terminal and even in the "virsh console mikrotik43" command. The virsh command ends with "Escape character is ^]" and the console hangs up until I give CTRL+].

When I give "virt-install ... --vnc", the output on my desktop (using virt-manager linux program) is fine and I can successfully complete the installation and then even normally connect via minicom or "virsh console mikrotik43". This works perfectly.

But I want to install the mikrotik ros via text console and I don't want to use vnc. What arguments should I pass to the virt-install to run the installation in text mode? How can I do that? Or everyone uses only vnc??? :shock: The discussions on the internet said "use vnc" or "redirect the guest output to serial port" - is this possible in mikrotik installation? How?

Thank you, Tomas

Re: cannot see output when installing

Posted: Mon Dec 14, 2009 9:51 am
by Pantani
virt-install --connect qemu:///system -n fedora12 -f ~/fedora12.qcow2 -s 3 -r 256 --accelerate --network=bridge:virbr0 --hvm --location http://download.fedoraproject.org/pub/fedora/linux/releases/12/Fedora/i386/os/ --nographics -x console=ttyS0
This works on Fedora. Is there any way how to do it with Mikrotik ROS?

Re: cannot see output when installing

Posted: Mon Dec 14, 2009 11:17 am
by janisk
try to compare commands you are running. Of course, one is cdrom, other is downloaded from net, but for fedora you set
-x console=ttyS0

Re: cannot see output when installing

Posted: Mon Dec 14, 2009 12:38 pm
by Pantani
Yes, I know, that I wrote "-x console=ttyS0" to the Fedora12, but how can I change the boot parameters for Mikrotik ROS?
I've tried to download and mount the ISO image from Download section on mikrotik.com. I copied the files and changed the file ./isolinux/isolinux.cfg to
default system

label system
        kernel linux
        append load_ramdisk=1 initrd=initrd.rgz console=ttyS0

and after this I made the boot image.

I'm just trying this
virt-install --connect qemu:///system -n mikrotik -f ~/mikrotik.qcow2 -s 1 -r 64 --os-type other --os-variant generic --accelerate --network=bridge:virbr0 --hvm --cdrom=/root/mt.iso --nographics
but the console gives no output, so either the first serial port is named differently in Mikrotik ROS or something went wronng. This is the console output:
Starting install...
Creating domain...                                                                                                                                  |    0 B     00:01     
Connected to domain mikrotik
Escape character is ^]
and nothing else outputs...

Re: cannot see output when installing

Posted: Tue Dec 15, 2009 11:04 am
by Pantani
Now I've got it - I can run Mikrotik ROS in the kvm/qemu under command line only - not over VNC remotely. That was my aim. Works great!

The problem was in the ISO image packing with mkisofs. Works with "console=ttyS0" option on the kernel's parameter line.