Community discussions

 
blackmetal
Member Candidate
Member Candidate
Topic Author
Posts: 177
Joined: Mon Aug 16, 2010 9:01 am

Problem with booting ros on Xen Virtual Machines

Mon Aug 16, 2010 9:04 am

Hello,
i install ros on my xen virtal machine with iso file but when i want boot it it says Mising operation system,
is there any solution for this?
and also i attach screenshot of my error to this post,

Thanks
You do not have the required permissions to view the files attached to this post.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: Problem with booting ros on Xen Virtual Machines

Wed Aug 25, 2010 3:39 pm

ISO does not know anything about XEN, so it may fail. You can try to isntall odler RouterOS and then try to boot that image with XEN package installed on RouterOS. But i would suggest you to look at KVM instead as it is more stable and you do not need to alter kernel to run in it.
 
wpeople
Member
Member
Posts: 352
Joined: Sat May 26, 2007 6:36 pm

Re: Problem with booting ros on Xen Virtual Machines

Wed Apr 13, 2011 1:26 pm

As is posted http://forum.mikrotik.com/viewtopic.php ... 88#p258688 I could install RouterOS 4.17 into Xen HVM.
Simply booted the CD, after install, shutdown the DomU, edit the config (remove cd image, and set boot to HD image) and worked

Sadly could not install 5.0 nor can upgrade
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: Problem with booting ros on Xen Virtual Machines

Wed Apr 13, 2011 2:33 pm

can you try to boot linux with 2.6.35 kernel?
 
blackmetal
Member Candidate
Member Candidate
Topic Author
Posts: 177
Joined: Mon Aug 16, 2010 9:01 am

Re: Problem with booting ros on Xen Virtual Machines

Wed Apr 13, 2011 2:37 pm

the problem solve,d

thansk,
 
wpeople
Member
Member
Posts: 352
Joined: Sat May 26, 2007 6:36 pm

Re: Problem with booting ros on Xen Virtual Machines

Wed Apr 13, 2011 3:50 pm

Janisk, Debian 6.0 even have 2.6.32-5-xen only :-(

Do You have a good reason why not 2.6.32 work but 2.6.35 would? if so, i would try to make a 2.6.35-xen kernel. thanks!
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: Problem with booting ros on Xen Virtual Machines

Thu Apr 14, 2011 9:06 am

that -xen extension usually means that kernel have xen support in it. And that is what you want to avoid.
 
wpeople
Member
Member
Posts: 352
Joined: Sat May 26, 2007 6:36 pm

Re: Problem with booting ros on Xen Virtual Machines

Thu Apr 14, 2011 9:49 am

I don't have the point why i have to avoid xen (on Host machine).
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: Problem with booting ros on Xen Virtual Machines

Thu Apr 14, 2011 3:10 pm

if you where talking about host, then yes, you can try, if guest - avoid :)

XEN was once supported virtualization on x86 hardware but was replaced by KVM. And the later has become very stable lately.
 
wpeople
Member
Member
Posts: 352
Joined: Sat May 26, 2007 6:36 pm

Re: Problem with booting ros on Xen Virtual Machines

Thu Apr 14, 2011 5:05 pm

yes, host is xen.

I've upgrade Lenny to Squeeze, Xen 3.2-1 to 4.0 and works!
(kernel is stock 2.6.32-5-xen-amd64)
I mean, now i can install 5.0 and also upgrade 4.17 to 5.0!

Solved, thanks!
 
bobwalker
just joined
Posts: 23
Joined: Sun Apr 03, 2011 6:07 am

Re: Problem with booting ros on Xen Virtual Machines

Sat Mar 23, 2013 11:45 am

the problem solve,d

thansk,

how to solve?
 
wpeople
Member
Member
Posts: 352
Joined: Sat May 26, 2007 6:36 pm

Re: Problem with booting ros on Xen Virtual Machines

Sun Mar 24, 2013 10:39 pm

Bobwalker: as you see, upgrade from lenny to squeeze (kernel 2.6.32 to 2.6.35)

Who is online

Users browsing this forum: No registered users and 7 guests