Community discussions

 
barkas
Member Candidate
Member Candidate
Topic Author
Posts: 260
Joined: Sun Sep 25, 2011 10:51 pm

RB2011 + Metarouter

Sat Mar 10, 2012 7:39 pm

So, does it work?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24189
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB2011 + Metarouter

Mon May 07, 2012 9:06 am

yes it works
No answer to your question? How to write posts
 
ropebih
Member Candidate
Member Candidate
Posts: 109
Joined: Tue May 22, 2007 5:35 pm

Re: RB2011 + Metarouter

Mon May 07, 2012 9:54 pm

I am trying for days to run openwrt on RouterBOARD so that I can implement IGMP proxy or udpxy but without success. Open WRT is booted and runs for 1-2 minutes after which is stopped on 1-2 minutes, then it's working again for ~10 seconds and then again is not working for 1-2 minutes, and so on. More of the time is not working then it does. The term "not working" implies that openwrt does not respond to ping nor the console.
Normis, p l e a s e tell me how to solve this problem. If necessary, I can provide access to this Routerboard. Thank you!
 
User avatar
NathanA
Forum Veteran
Forum Veteran
Posts: 793
Joined: Tue Aug 03, 2004 9:01 am

Re: RB2011 + Metarouter

Mon May 07, 2012 11:29 pm

The term "not working" implies that openwrt does not respond to ping nor the console.
Fascinating...this sounds like 1 of the 2 forms of "freeze-ups" some of us have been seeing on other models of mipsbe RouterBOARDs (but not all!). You are referring to an RB2011?

-- Nathan
 
ropebih
Member Candidate
Member Candidate
Posts: 109
Joined: Tue May 22, 2007 5:35 pm

Re: RB2011 + Metarouter

Tue May 08, 2012 12:08 am

I tried with RB2011 and RB750 and it's acting identical.
 
User avatar
NathanA
Forum Veteran
Forum Veteran
Posts: 793
Joined: Tue Aug 03, 2004 9:01 am

Re: RB2011 + Metarouter

Tue May 08, 2012 3:21 am

I tried with RB2011 and RB750 and it's acting identical.
I don't have access to an RB2011 to do any testing with, but I definitely do not recommend using MetaROUTER with an RB750. The CPU is a bit underpowered, but the biggest problem is that there really isn't enough RAM to do anything useful...RouterOS has a minimum requirement of 16MB of RAM, and the RB750 only has 32MB total. If you have all packages selected for the host, and try to boot up a MR guest @ 16MB, you are going to run into out-of-memory symptoms on the host very, very quickly. I'm not sure that MikroTik intended for people to use MR on the 750: I think RouterOS just detects an MR-capable CPU and then allows you to use it regardless of available resources.

RB2011 seems to have at minimum 64MB of RAM, so it would be a more appropriate platform to try MR on from that perspective. Can you give us more details on your setup? (Are your guests ROS or other? If other, what image are you using and where did you source it from? How much RAM are you allocating to it? How did you set up the network interfaces to the guest?)

In our experience, we have concluded after conducting many independent tests that RB433AH and RB493AH are very solid MetaROUTER platforms. And then there is the RB450G, which on paper is one of the most ideal platforms suitable to running MetaROUTER on account of its amazing price, high availability, generally decent CPU performance, and good amount of RAM (256MB) and flash (512MB). But some people, including myself, have encountered similar problems with the RB450G that you are seeing on your RB2011, except that sometimes the guest freezes up (like you've seen), and other times the host freezes up. (There's a large thread about this elsewhere on the forums.) Strangely, the problems seem to clear up when you use a different power supply with the 450G: many resellers (at least in the US) seem to bundle 24V power supplies with 450Gs, and when we replace the stock power supply wit a high-amperage 12V supply, the MR problems seem to disappear completely. (At least they have for me and a few others, though there is at least one person on this forum who has tried it and has not had the same positive results.)

What power supply are you using with your RB2011, and do you have others you could try? It would be interesting to see if your problem is at all related to what we are seeing on the 450G, and if the fix/workaround is at all relevant to this board, too. Like most other RouterBOARDs, it looks like the RB2011 series' onboard regulator can accept between 8-28V. I would try to find a power supply on the lower-end of that scale to play with...whatever this problem is, it seems to be related to the input voltage somehow. Like I said, we have had great success with 12V.

Your problem may not be related at all. It sounds like your RB2011 MR is "freezing up" way more often than I have experienced on any RouterBOARD, so it may be (and probably is) a completely different issue. But it's worth a shot...

-- Nathan
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: RB2011 + Metarouter

Fri May 11, 2012 10:39 am

had rb2011 (accidently) running for several days with metarouter running (it was idling) without reboots/problems. Anyway, will add to stack of RB450G's that are already running metarouters.
 
timberwolf
Member Candidate
Member Candidate
Posts: 274
Joined: Mon Apr 25, 2011 12:08 pm
Location: Germany

Re: RB2011 + Metarouter

Wed May 16, 2012 8:18 pm

When Metarouter on this new RB with a new generation CPU also acts weird, then maybe not everything is lost, because this more sound like a software issue then.
Or, what would be very unsatisfying, the powersupply or other hardware on this board is also insufficient for higher loads.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: RB2011 + Metarouter

Thu May 17, 2012 8:53 am

describe weird.

I have metarotuer running on RB2011L w/o weird problems.
 
timberwolf
Member Candidate
Member Candidate
Posts: 274
Joined: Mon Apr 25, 2011 12:08 pm
Location: Germany

Re: RB2011 + Metarouter

Thu May 17, 2012 11:50 am

describe weird.

I have metarotuer running on RB2011L w/o weird problems.
I was referring to the report of ropebih. As long as noone else reports in this issue, it might be a special problem for his configuration.
I won't try it myself, as no RB2011 with enough RAM worth trying is available.
Slightly OT, when will a modell with more than 64MB RAM be available?
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: RB2011 + Metarouter

Thu May 17, 2012 12:00 pm

well, here is one running
                   uptime: 5d20h2m12s
                  version: 5.16
k
metarouter guest is running BT to itself to load it.


and about different models - all i can say is that it will be available when available :( as i cannot comment on planned/unplanned releases of boards that might or might not exist.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24189
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB2011 + Metarouter

Thu May 17, 2012 12:02 pm

The wireless models will have 128MB
No answer to your question? How to write posts
 
norpan
newbie
Posts: 35
Joined: Sat Dec 19, 2009 12:40 pm

Re: RB2011 + Metarouter

Fri Jun 08, 2012 1:40 pm

I have also tested MR on RB2011 with the same results as ropebih. At first I thought it was working as I didn't have any reboots, but when I started to ping the guest MR I discovered that the guest stopped answering to ping for about ~30-60sec, at least for a very long time. When the guest "came back to life" I got the reply on most if not all of the pings. Besides my pings the guest was completely idle.

I did not experience any problems with the host at all though. My RB2011 is running v5.15
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: RB2011 + Metarouter

Fri Jun 08, 2012 1:46 pm

please give meatrouter guest configuration details (including interface settings that is added to guest)
 
norpan
newbie
Posts: 35
Joined: Sat Dec 19, 2009 12:40 pm

Re: RB2011 + Metarouter

Fri Jun 08, 2012 4:05 pm

I'm trying to do a 'export compact' on guest but so far I haven't been able to login to the console to my freshly created, unconfigured metarouter.
Well, after some time I were successful logging in and ran 'export compact' which resulted in a repeatedly broadcasted and logged message on the guest:
00:01:10 ipsec,warning,critical libipsec failed pfkey open Address family not supported by protocol
For now, is my 'metarouter export compact':
/metarouter
add disk-size=8000kiB memory-size=32MiB name=mr3
/metarouter interface
add dynamic-bridge=LAN dynamic-mac-address=02:B9:06:F4:E3:BD type=dynamic virtual-machine=mr3 vm-mac-address=02:21:7A:C0:06:47
and 'bridge export compact' if you need it:
/interface bridge
add l2mtu=1524 name=LAN priority=0x7000
/interface bridge port
add bridge=LAN interface=ether2-local-master
add bridge=LAN interface=ether6-local-master
 
norpan
newbie
Posts: 35
Joined: Sat Dec 19, 2009 12:40 pm

Re: RB2011 + Metarouter

Fri Jun 08, 2012 4:53 pm

Upgraded to 5.17 and managed to add IP-address on MR guest, started a ping from a pc to MR guest:
fping -l 192.168.100.22
192.168.100.22 : [0], 84 bytes, 5.89 ms (5.89 avg, 0% loss)
192.168.100.22 : [1], 84 bytes, 1.61 ms (3.75 avg, 0% loss)
192.168.100.22 : [2], 84 bytes, 1.42 ms (2.97 avg, 0% loss)
192.168.100.22 : [3], 84 bytes, 1.38 ms (2.57 avg, 0% loss)
192.168.100.22 : [4], 84 bytes, 1.10 ms (2.28 avg, 0% loss)
192.168.100.22 : [5], 84 bytes, 1.35 ms (2.12 avg, 0% loss)
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
ICMP Host Unreachable from 192.168.100.202 for ICMP Echo sent to 192.168.100.22
192.168.100.22 : [6], 84 bytes, 85453 ms (12209 avg, 92% loss)
192.168.100.22 : [7], 84 bytes, 84443 ms (21238 avg, 91% loss)
192.168.100.22 : [8], 84 bytes, 83436 ms (28149 avg, 90% loss)
192.168.100.22 : [9], 84 bytes, 82427 ms (33577 avg, 89% loss)
192.168.100.22 : [10], 84 bytes, 81419 ms (37926 avg, 88% loss)
192.168.100.22 : [11], 84 bytes, 80411 ms (41467 avg, 86% loss)
192.168.100.22 : [12], 84 bytes, 79408 ms (44385 avg, 85% loss)
192.168.100.22 : [13], 84 bytes, 78401 ms (46815 avg, 84% loss)
192.168.100.22 : [14], 84 bytes, 77396 ms (48854 avg, 83% loss)
192.168.100.22 : [15], 84 bytes, 76395 ms (50575 avg, 82% loss)
192.168.100.22 : [16], 84 bytes, 75394 ms (52035 avg, 81% loss)
192.168.100.22 : [17], 84 bytes, 74386 ms (53277 avg, 80% loss)
192.168.100.22 : [18], 84 bytes, 73376 ms (54334 avg, 79% loss)
192.168.100.22 : [19], 84 bytes, 72372 ms (55236 avg, 78% loss)
192.168.100.22 : [20], 84 bytes, 71372 ms (56005 avg, 77% loss)
192.168.100.22 : [21], 84 bytes, 70365 ms (56657 avg, 76% loss)
192.168.100.22 : [22], 84 bytes, 69364 ms (57210 avg, 75% loss)
192.168.100.22 : [23], 84 bytes, 68362 ms (57675 avg, 73% loss)
192.168.100.22 : [24], 84 bytes, 67353 ms (58062 avg, 72% loss) 
192.168.100.22 : [25], 84 bytes, 66344 ms (58380 avg, 71% loss)
192.168.100.22 : [26], 84 bytes, 65336 ms (58638 avg, 70% loss)
192.168.100.22 : [27], 84 bytes, 64332 ms (58841 avg, 69% loss)
192.168.100.22 : [28], 84 bytes, 63324 ms (58996 avg, 68% loss)
192.168.100.22 : [29], 84 bytes, 62322 ms (59107 avg, 67% loss)
192.168.100.22 : [30], 84 bytes, 61318 ms (59178 avg, 66% loss)
192.168.100.22 : [31], 84 bytes, 60313 ms (59214 avg, 65% loss)
192.168.100.22 : [32], 84 bytes, 59312 ms (59217 avg, 64% loss)
192.168.100.22 : [33], 84 bytes, 58306 ms (59190 avg, 63% loss)
192.168.100.22 : [34], 84 bytes, 57305 ms (59136 avg, 61% loss)
192.168.100.22 : [35], 84 bytes, 56298 ms (59057 avg, 60% loss)
192.168.100.22 : [36], 84 bytes, 55295 ms (58955 avg, 59% loss)
192.168.100.22 : [37], 84 bytes, 54285 ms (58832 avg, 58% loss)
192.168.100.22 : [38], 84 bytes, 53277 ms (58690 avg, 57% loss)
192.168.100.22 : [39], 84 bytes, 52270 ms (58530 avg, 56% loss)
192.168.100.22 : [40], 84 bytes, 51267 ms (58352 avg, 55% loss)
192.168.100.22 : [41], 84 bytes, 50264 ms (58160 avg, 54% loss)
192.168.100.22 : [42], 84 bytes, 49257 ms (57953 avg, 53% loss)
192.168.100.22 : [43], 84 bytes, 48257 ms (57732 avg, 52% loss)
192.168.100.22 : [44], 84 bytes, 47249 ms (57499 avg, 51% loss)
192.168.100.22 : [45], 84 bytes, 46241 ms (57255 avg, 50% loss)
192.168.100.22 : [46], 84 bytes, 45241 ms (56999 avg, 48% loss)
192.168.100.22 : [47], 84 bytes, 44232 ms (56733 avg, 47% loss)
192.168.100.22 : [48], 84 bytes, 43225 ms (56457 avg, 46% loss)
192.168.100.22 : [49], 84 bytes, 42217 ms (56173 avg, 45% loss)
192.168.100.22 : [50], 84 bytes, 41215 ms (55879 avg, 44% loss)
192.168.100.22 : [33], 84 bytes, 58306 ms (59190 avg, 63% loss)
192.168.100.22 : [34], 84 bytes, 57305 ms (59136 avg, 61% loss)
192.168.100.22 : [35], 84 bytes, 56298 ms (59057 avg, 60% loss)
192.168.100.22 : [36], 84 bytes, 55295 ms (58955 avg, 59% loss)
192.168.100.22 : [37], 84 bytes, 54285 ms (58832 avg, 58% loss)
192.168.100.22 : [38], 84 bytes, 53277 ms (58690 avg, 57% loss)
192.168.100.22 : [39], 84 bytes, 52270 ms (58530 avg, 56% loss)
192.168.100.22 : [40], 84 bytes, 51267 ms (58352 avg, 55% loss)
192.168.100.22 : [41], 84 bytes, 50264 ms (58160 avg, 54% loss)
192.168.100.22 : [42], 84 bytes, 49257 ms (57953 avg, 53% loss)
192.168.100.22 : [43], 84 bytes, 48257 ms (57732 avg, 52% loss)
192.168.100.22 : [44], 84 bytes, 47249 ms (57499 avg, 51% loss)
192.168.100.22 : [45], 84 bytes, 46241 ms (57255 avg, 50% loss)
192.168.100.22 : [46], 84 bytes, 45241 ms (56999 avg, 48% loss)
192.168.100.22 : [47], 84 bytes, 44232 ms (56733 avg, 47% loss)
192.168.100.22 : [48], 84 bytes, 43225 ms (56457 avg, 46% loss)
192.168.100.22 : [49], 84 bytes, 42217 ms (56173 avg, 45% loss)
192.168.100.22 : [50], 84 bytes, 41215 ms (55879 avg, 44% loss)
192.168.100.22 : [51], 84 bytes, 40213 ms (55578 avg, 43% loss)
192.168.100.22 : [52], 84 bytes, 39217 ms (55269 avg, 42% loss)
192.168.100.22 : [89], 84 bytes, 2046 ms (54284 avg, 41% loss)
192.168.100.22 : [90], 84 bytes, 1042 ms (53316 avg, 40% loss)
192.168.100.22 : [91], 84 bytes, 34.9 ms (52364 avg, 39% loss)
192.168.100.22 : [92], 84 bytes, 1.97 ms (51446 avg, 38% loss)
192.168.100.22 : [93], 84 bytes, 2.01 ms (50559 avg, 38% loss)
192.168.100.22 : [94], 84 bytes, 1.28 ms (49702 avg, 37% loss)
192.168.100.22 : [95], 84 bytes, 1.29 ms (48873 avg, 37% loss)
192.168.100.22 : [96], 84 bytes, 1.53 ms (48072 avg, 37% loss)
192.168.100.22 : [97], 84 bytes, 5.62 ms (47297 avg, 36% loss)
192.168.100.22 : [98], 84 bytes, 1.52 ms (46546 avg, 36% loss)
192.168.100.22 : [99], 84 bytes, 1.45 ms (45819 avg, 36% loss)

Who is online

Users browsing this forum: No registered users and 2 guests